Bug 273147 - Plasma desktop crashing after login
Summary: Plasma desktop crashing after login
Status: RESOLVED DUPLICATE of bug 273566
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 19:32 UTC by niko.bockerman
Modified: 2011-05-18 21:50 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.51 KB, text/plain)
2011-05-17 16:57 UTC, Poteau Romuald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description niko.bockerman 2011-05-12 19:32:53 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.36-tuxonice-r3 x86_64
Distribution: "Gentoo Base System release 2.0.2"

-- Information about the crash:
- What I was doing when the application crashed:

Every time I login and the desktop is shown, few seconds passes and then plasma desktop crashes and restarts. This happens every time.

I have deleted all calendars from Akonadi, only Birthdays & Anniversaries remaining along with some Contacts.

Version of kdepim components: 4.4.11.1

I don't know what other information would be helpful but I am willing give more information when requested. Hopefully this gets fixed soon as I'm starting to hate those crashes every time I log in.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f422f562760 (LWP 22437))]

Thread 3 (Thread 0x7f421157e700 (LWP 22441)):
#0  0x00007f422cb92af3 in poll () from /lib64/libc.so.6
#1  0x00007f4229bbc399 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4229bbc7ec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f422e1a1e66 in QEventDispatcherGlib::processEvents (this=0x2433200, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f422e174a82 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f422e174e64 in QEventLoop::exec (this=0x7f421157dde0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f422e08149d in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f422e154a98 in QInotifyFileSystemWatcherEngine::run (this=0x2ec31e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f422e0844c5 in QThreadPrivate::start (arg=0x2ec31e0) at thread/qthread_unix.cpp:320
#9  0x00007f422ddf2914 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f422cb9b7dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f41fe2cb700 (LWP 22459)):
#0  0x00007f422ddf7619 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f422e085001 in wait (this=<value optimized out>, mutex=0x353da70, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x353da70, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f422e078c01 in QThreadPoolThread::run (this=0x36127d0) at concurrent/qthreadpool.cpp:140
#4  0x00007f422e0844c5 in QThreadPrivate::start (arg=0x36127d0) at thread/qthread_unix.cpp:320
#5  0x00007f422ddf2914 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f422cb9b7dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f422f562760 (LWP 22437)):
[KCrash Handler]
#6  QString (this=0x0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KCalCore::IncidenceBase::uid (this=0x0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/kcalcore/incidencebase.cpp:226
#8  0x00007f42064e84c9 in CalendarSupport::Calendar::Private::removeItemFromMaps (this=<value optimized out>, item=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.6.2-r1/work/plasma-workspace-4.6.2/plasma/generic/dataengines/calendar/akonadi/calendar.cpp:540
#9  0x00007f42064eb84a in CalendarSupport::Calendar::Private::itemsRemoved (this=0x33b3340, items=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.6.2-r1/work/plasma-workspace-4.6.2/plasma/generic/dataengines/calendar/akonadi/calendar.cpp:586
#10 0x00007f42064ec986 in CalendarSupport::Calendar::Private::rowsAboutToBeRemoved (this=0x33b3340, parent=<value optimized out>, start=<value optimized out>, end=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.6.2-r1/work/plasma-workspace-4.6.2/plasma/generic/dataengines/calendar/akonadi/calendar.cpp:128
#11 0x00007f42064ced24 in CalendarSupport::Calendar::Private::qt_metacall (this=0x33b3340, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff88fcce70) at /var/tmp/portage/kde-base/plasma-workspace-4.6.2-r1/work/plasma-workspace-4.6.2_build/plasma/generic/dataengines/calendar/moc_calendar_p.cpp:152
#12 0x00007f422e18da0f in QMetaObject::activate (sender=0x3020e60, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3278
#13 0x00007f422e1d8764 in QAbstractItemModel::rowsAboutToBeRemoved (this=0x7fff88fccac0, _t1=<value optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:188
#14 0x00007f422e16d51c in QAbstractItemModel::beginRemoveRows (this=0x3020e60, parent=..., first=0, last=0) at kernel/qabstractitemmodel.cpp:2449
#15 0x00007f4205c4cef3 in Akonadi::EntityTreeModelPrivate::monitoredItemRemoved (this=0x330d2f0, item=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/akonadi/entitytreemodel_p.cpp:917
#16 0x00007f4205c41972 in Akonadi::EntityTreeModel::qt_metacall (this=0x3020e60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff88fcd150) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/entitytreemodel.moc:155
#17 0x00007f422e18da0f in QMetaObject::activate (sender=0x1c63120, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3278
#18 0x00007f4205c95315 in Akonadi::Monitor::itemRemoved (this=0x7fff88fccac0, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/monitor.moc:190
#19 0x00007f4205c98474 in Akonadi::MonitorPrivate::emitItemNotification (this=0x330d1c0, msg=..., item=<value optimized out>, collection=<value optimized out>, collectionDest=<value optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/akonadi/monitor_p.cpp:442
#20 0x00007f4205c99333 in Akonadi::MonitorPrivate::emitNotification (this=0x330d1c0, msg=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/akonadi/monitor_p.cpp:267
#21 0x00007f4205bfe6a1 in Akonadi::ChangeRecorderPrivate::emitNotification(Akonadi::NotificationMessage const&) () from /usr/lib64/libakonadi-kde.so.4
#22 0x00007f4205c98fda in Akonadi::MonitorPrivate::dataAvailable (this=0x330d1c0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/akonadi/monitor_p.cpp:281
#23 0x00007f4205c95445 in Akonadi::Monitor::qt_metacall (this=0x1c63120, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff88fcd6b0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/monitor.moc:156
#24 0x00007f4205bfe388 in Akonadi::ChangeRecorder::qt_metacall (this=0x7fff88fccac0, _c=QMetaObject::InvokeMetaMethod, _id=-1, _a=0xffffffff) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/changerecorder.moc:72
#25 0x00007f422e18da0f in QMetaObject::activate (sender=0x330d248, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3278
#26 0x00007f4205bfea57 in Akonadi::EntityCache<Akonadi::Item, Akonadi::ItemFetchJob, Akonadi::ItemFetchScope>::fetchResult(KJob*) () from /usr/lib64/libakonadi-kde.so.4
#27 0x00007f4205c3a9e3 in Akonadi::EntityCacheBase::qt_metacall (this=0x330d248, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff88fcd8c0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/entitycache_p.moc:77
#28 0x00007f422e18da0f in QMetaObject::activate (sender=0x39bd030, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffff) at kernel/qobject.cpp:3278
#29 0x00007f422e5e9472 in KJob::result (this=0x7fff88fccac0, _t1=0x39bd030) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2_build/kdecore/kjob.moc:194
#30 0x00007f422e5e9710 in KJob::emitResult (this=0x39bd030) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdecore/jobs/kjob.cpp:312
#31 0x00007f4205c8bc39 in delayedEmitResult (this=0x39bd030, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x39c5f00) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2/akonadi/job.cpp:144
#32 Akonadi::Job::qt_metacall (this=0x39bd030, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x39c5f00) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/job.moc:91
#33 0x00007f4205c78ce5 in Akonadi::ItemFetchJob::qt_metacall (this=0x7fff88fccac0, _c=QMetaObject::InvokeMetaMethod, _id=-1, _a=0xffffffff) at /var/tmp/portage/kde-base/kdepimlibs-4.6.2-r1/work/kdepimlibs-4.6.2_build/akonadi/itemfetchjob.moc:73
#34 0x00007f422e187abe in QObject::event (this=0x39bd030, e=0x7fff88fccac0) at kernel/qobject.cpp:1217
#35 0x00007f422d2fe7dc in QApplicationPrivate::notify_helper (this=0x1a18fc0, receiver=0x39bd030, e=0x3b4ddb0) at kernel/qapplication.cpp:4462
#36 0x00007f422d303c7d in QApplication::notify (this=0x1a0b710, receiver=0x39bd030, e=0x3b4ddb0) at kernel/qapplication.cpp:4341
#37 0x00007f422ef505c6 in KApplication::notify (this=0x1a0b710, receiver=0x39bd030, event=0x3b4ddb0) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#38 0x00007f422e175d2b in QCoreApplication::notifyInternal (this=0x1a0b710, receiver=0x39bd030, event=0x3b4ddb0) at kernel/qcoreapplication.cpp:731
#39 0x00007f422e178cb1 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1962a40) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1962a40) at kernel/qcoreapplication.cpp:1372
#41 0x00007f422e1a22d3 in sendPostedEvents (s=0x1a1b5c0) at kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=0x1a1b5c0) at kernel/qeventdispatcher_glib.cpp:277
#43 0x00007f4229bb7fa1 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f4229bbc638 in ?? () from /usr/lib64/libglib-2.0.so.0
#45 0x00007f4229bbc7ec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#46 0x00007f422e1a1e13 in QEventDispatcherGlib::processEvents (this=0x1a158a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#47 0x00007f422d3b092e in QGuiEventDispatcherGlib::processEvents (this=0x7fff88fccac0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007f422e174a82 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#49 0x00007f422e174e64 in QEventLoop::exec (this=0x7fff88fce2f0, flags=) at kernel/qeventloop.cpp:201
#50 0x00007f422e178edb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#51 0x00007f421d065293 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/plasma-workspace-4.6.2-r1/work/plasma-workspace-4.6.2/plasma/desktop/shell/main.cpp:118
#52 0x0000000000407f33 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b26b "0") at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kinit/kinit.cpp:734
#53 0x0000000000408b30 in handle_launcher_request (sock=7, who=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kinit/kinit.cpp:1226
#54 0x000000000040905b in handle_requests (waitForPid=6342368) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kinit/kinit.cpp:1419
#55 0x0000000000409c01 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 272389.

Possible duplicates by query: bug 272389, bug 263823, bug 262117, bug 261853.

Reported using DrKonqi
Comment 1 squan 2011-05-13 21:24:45 UTC
I'm following openSUSE factory quite closely (tumbleweed, kde:factory, kde:unstable_factory repos) and had crashing both plasma-dasktop and kwin on login for the last two days (reproducable and on more then one user account).
For kwin it was possible to workaround since it did not crash when restarted from within the session. plasma kept on crashing (but I did not record a backtrace).

Another update of 37 new packages today fixed plasma (could be restarted even w/o leaving KDE session).
Thes packages were oxygen-gtk, many NetworkManager packages no akonadi and many unsuspicious multimedia packages.
Comment 2 squan 2011-05-14 08:59:26 UTC
Pardon, the crash in comment #1 seems to be unrelated to the original report and maybe related to using bleeding edge plasmoid-networkmanagement 0.9.1.
Comment 3 Poteau Romuald 2011-05-17 16:57:30 UTC
Created attachment 60084 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.3 (4.6.3) "release 4" using Qt 4.7.3

- What I was doing when the application crashed:

plasma crashed just after the login and the defintion of the width/height of the external monitor

-- Backtrace (Reduced):
#6  0x00007fa8c5880b10 in KCalCore::IncidenceBase::uid() const () from /usr/lib64/libkcalcore.so.4
[...]
#12 0x00007fa8ed551ae4 in QAbstractItemModel::rowsAboutToBeRemoved (this=<value optimized out>, _t1=<value optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:188
#13 0x00007fa8ed4ec658 in QAbstractItemModel::beginRemoveRows (this=0x15ab070, parent=..., first=0, last=0) at kernel/qabstractitemmodel.cpp:2449
#14 0x00007fa8c5be00d4 in Akonadi::EntityTreeModelPrivate::monitoredItemRemoved (this=0x171f220, item=...) at /usr/src/debug/kdepimlibs-4.6.3/akonadi/entitytreemodel_p.cpp:927
#15 0x00007fa8c5c22ee1 in Akonadi::EntityTreeModel::qt_metacall (this=0x15ab070, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8e96e620) at /usr/src/debug/kdepimlibs-4.6.3/build/akonadi/entitytreemodel.moc:158
Comment 4 Aaron J. Seigo 2011-05-18 21:50:33 UTC

*** This bug has been marked as a duplicate of bug 273566 ***