Bug 273104 - Dual screen with different dimension screens and one rotated, desktop size is getting strange values
Summary: Dual screen with different dimension screens and one rotated, desktop size is...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: multi-screen (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 10:47 UTC by Vasilis.Vlachoudis
Modified: 2013-01-20 19:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasilis.Vlachoudis 2011-05-12 10:47:12 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

Primary screen: 1920x1200
Second screen: 1680x1050 (rotate by 90deg on left)
Video card: Nvidia with the nvidia driver
I have disabled Twinview and xinerama since they cannot handle two screens with different rotations.
Therefore I am running as two separate x-screens.

When KDE starts it opens two desktops on both screens (:0.0 and :0.1):
Problems:
1. kwin is not started automatically for the second screen :0.1. Easy to fix, I am starting manually with kwin -display :0.1
2. the first screen shows a strange resolution of 1920x1168 however I am not able to place a window after Y:1000px. the bottom 200px are somehow lost.
3. the second screen behaves like if it has a resolution of 1920x1200 (the one of the primary display) instead of 1050x1680 (which by the way is correctly reported in the Settings program) thus when I open any new window is lost in the non-visible area.

Up to now the only solution I have was to use kwin for the primary display and another window manager like openbox, twm for the secondary display, then everything works ok.



Reproducible: Didn't try
Comment 1 Vasilis.Vlachoudis 2011-05-13 14:22:19 UTC
Additionally: I just realized now that also the global shortcuts are getting confused. When I enable the dual screen the Meta-XXX shortcuts do not work any more
Comment 2 Martin Flöser 2011-05-13 17:54:21 UTC
there will be multi-head improvements in 4.7
Comment 3 apodtele 2011-06-11 04:34:22 UTC
While  you are waiting for those improvements in 4.7, please check out a workaround idea here:

https://bugs.kde.org/show_bug.cgi?id=248563#c5
Comment 4 Martin Flöser 2013-01-20 19:03:09 UTC
I assume the issues are fixed by now due to the improvements in 4.7. If one of the issues is still present please report a new bug and please report one bug per issue.