Bug 273097 - Amarok crashed shortly after start.
Summary: Amarok crashed shortly after start.
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 08:01 UTC by midhir73
Modified: 2011-05-14 12:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description midhir73 2011-05-12 08:01:01 UTC
Version:           2.4.1 (using KDE 4.6.2) 
OS:                Linux

Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9cd5b247a0 (LWP 1890))]

Thread 10 (Thread 0x7f9cb570b700 (LWP 1893)):
#0  0x00007f9cd21eff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9cca01b32f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f9cca00d116 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f9cca00d749 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f9cca00d800 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f9cca01b2df in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f9cc59e0a88 in ?? () from /usr/lib/libpulsecommon-0.9.22.so
#7  0x00007f9ccdff4d8c in start_thread (arg=0x7f9cb570b700) at pthread_create.c:304
#8  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f9cb1986700 (LWP 1895)):
#0  0x00007f9cd21eff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9ccc9ec104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9ccc9ec639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9cd2b4d446 in QEventDispatcherGlib::processEvents (this=0x17a7680, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9cd2b21882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9cd2b21abc in QEventLoop::exec (this=0x7f9cb1985db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9cd2a38924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f9cd2b03c2f in QInotifyFileSystemWatcherEngine::run (this=0x17a76a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9cd2a3b175 in QThreadPrivate::start (arg=0x17a76a0) at thread/qthread_unix.cpp:320
#9  0x00007f9ccdff4d8c in start_thread (arg=0x7f9cb1986700) at pthread_create.c:304
#10 0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f9ca8ce4700 (LWP 1896)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9ca8ce3ac0 in ?? ()
#2  0x00007fffb75407b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 7 (Thread 0x7f9ca2fbf700 (LWP 1897)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cd2a3b82b in wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9ccffa60b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1e53170, th=0x1e07a80) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9ccffa8723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1d4f640, th=0x1e07a80) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9ccffa753f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9ca2fbee00, parent=0x1e53170, th=0x1e07a80) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9ccffa75cb in ThreadWeaver::Thread::run (this=0x1e07a80) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9cd2a3b175 in QThreadPrivate::start (arg=0x1e07a80) at thread/qthread_unix.cpp:320
#8  0x00007f9ccdff4d8c in start_thread (arg=0x7f9ca2fbf700) at pthread_create.c:304
#9  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f9ca25a1700 (LWP 1898)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cd2a3b82b in wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9ccffa60b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1e53170, th=0x1d4fa10) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9ccffa8723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1d4f640, th=0x1d4fa10) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9ccffa753f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9ca25a0e00, parent=0x1e53170, th=0x1d4fa10) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9ccffa75cb in ThreadWeaver::Thread::run (this=0x1d4fa10) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9cd2a3b175 in QThreadPrivate::start (arg=0x1d4fa10) at thread/qthread_unix.cpp:320
#8  0x00007f9ccdff4d8c in start_thread (arg=0x7f9ca25a1700) at pthread_create.c:304
#9  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9ca1da0700 (LWP 1899)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cd2a3b82b in wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9ccffa60b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1e53170, th=0x7f9ca4004990) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9ccffa8723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1d4f640, th=0x7f9ca4004990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9ccffa753f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9ca1d9fe00, parent=0x1e53170, th=0x7f9ca4004990) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9ccffa75cb in ThreadWeaver::Thread::run (this=0x7f9ca4004990) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9cd2a3b175 in QThreadPrivate::start (arg=0x7f9ca4004990) at thread/qthread_unix.cpp:320
#8  0x00007f9ccdff4d8c in start_thread (arg=0x7f9ca1da0700) at pthread_create.c:304
#9  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9ca159f700 (LWP 1900)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cd2a3b82b in wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1d8c1e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f9ccffa60b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1e53170, th=0x7f9ca4008320) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9ccffa8723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1d4f640, th=0x7f9ca4008320) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9ccffa753f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9ca159ee00, parent=0x1e53170, th=0x7f9ca4008320) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9ccffa75cb in ThreadWeaver::Thread::run (this=0x7f9ca4008320) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9cd2a3b175 in QThreadPrivate::start (arg=0x7f9ca4008320) at thread/qthread_unix.cpp:320
#8  0x00007f9ccdff4d8c in start_thread (arg=0x7f9ca159f700) at pthread_create.c:304
#9  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9c96d69700 (LWP 1901)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cc95a0832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f9ccdff4d8c in start_thread (arg=0x7f9c96d69700) at pthread_create.c:304
#3  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9c94e87700 (LWP 1904)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9cce8f02a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9ccec09180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f9cce8f02d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f9ccec17254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9ccdff4d8c in start_thread (arg=0x7f9c94e87700) at pthread_create.c:304
#4  0x00007f9cd21fd04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9cd5b247a0 (LWP 1890)):
[KCrash Handler]
#6  QAbstractAnimation::state (this=0x7f9c00000000) at animation/qabstractanimation.cpp:504
#7  0x00007f9cd44b8b01 in Context::ContextView::addCollapseAnimation (this=0x1cbb730, anim=0x24ee290) at ../../src/context/ContextView.cpp:240
#8  0x00007f9cd44b43c3 in Context::Applet::collapse (this=0x1dd4ad0, on=<value optimized out>) at ../../src/context/Applet.cpp:315
#9  0x00007f9ca82d0349 in Albums::dataUpdated (this=0x1dd4ad0, name=<value optimized out>, data=<value optimized out>) at ../../../../../src/context/applets/albums/Albums.cpp:155
#10 0x00007f9ca82d17d6 in Albums::qt_metacall (this=0x1dd4ad0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb74ac440) at ./Albums.moc:89
#11 0x00007f9cd2b375f8 in QMetaObject::activate (sender=0x1d53a30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffb74ac440) at kernel/qobject.cpp:3287
#12 0x00007f9ccf1c69d7 in Plasma::DataContainer::dataUpdated (this=<value optimized out>, _t1=<value optimized out>, _t2=<value optimized out>) at ./datacontainer.moc:112
#13 0x00007f9ccf1c72ee in Plasma::DataContainer::checkForUpdate (this=0x1d53a30) at ../../plasma/datacontainer.cpp:327
#14 0x00007f9ccf1ca48b in Plasma::DataEngine::timerEvent (this=<value optimized out>, event=<value optimized out>) at ../../plasma/dataengine.cpp:386
#15 0x00007f9cd2b361c9 in QObject::event (this=0x1e5bb80, e=<value optimized out>) at kernel/qobject.cpp:1190
#16 0x00007f9cd34e19e4 in QApplicationPrivate::notify_helper (this=0x1086e20, receiver=0x1e5bb80, e=0x7fffb74acba0) at kernel/qapplication.cpp:4462
#17 0x00007f9cd34e63aa in QApplication::notify (this=<value optimized out>, receiver=0x1e5bb80, e=0x7fffb74acba0) at kernel/qapplication.cpp:4341
#18 0x00007f9cd5535866 in KApplication::notify (this=0x7fffb74ace90, receiver=0x1e5bb80, event=0x7fffb74acba0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f9cd2b2249c in QCoreApplication::notifyInternal (this=0x7fffb74ace90, receiver=0x1e5bb80, event=0x7fffb74acba0) at kernel/qcoreapplication.cpp:731
#20 0x00007f9cd2b4ff12 in sendEvent (this=0x10858d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QTimerInfoList::activateTimers (this=0x10858d0) at kernel/qeventdispatcher_unix.cpp:604
#22 0x00007f9cd2b4ccf4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#23 0x00007f9ccc9ebbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f9ccc9ec3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f9ccc9ec639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f9cd2b4d3ef in QEventDispatcherGlib::processEvents (this=0xec5490, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007f9cd3588dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f9cd2b21882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f9cd2b21abc in QEventLoop::exec (this=0x7fffb74ace10, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f9cd2b25ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#31 0x000000000040a0f6 in main (argc=1, argv=0x7fffb74af498) at ../../src/main.cpp:288


Reproducible: Always

Steps to Reproduce:
Before 2.4.1 it helps to unmount my external HDD where the media files are on. Then i starkt amarok and then i mount my external HDD.

But now amarok crashes always after start. It helps when I move .kde/share/apps/amarok/mysqle directory away. But then all my play counts are gone when i start with a blank database.

Actual Results:  
Amarok crashes.

Expected Results:  
Amarok should work.

I have a large Music Collection with more then 13.000 Files
Comment 1 Myriam Schweingruber 2011-05-13 13:27:04 UTC
Could you please erase the amarok* files located in $HOME/.kde/share/config/ and try again?
Comment 2 midhir73 2011-05-13 13:36:58 UTC
Thank You Very Much!

It seems to be helped,.....

2011/5/13 Myriam Schweingruber <myriam@kde.org>:
> https://bugs.kde.org/show_bug.cgi?id=273097
>
>
> Myriam Schweingruber <myriam@kde.org> changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDSINFO
>         Resolution|                            |WAITINGFORINFO
>
>
>
>
> --- Comment #1 from Myriam Schweingruber <myriam kde org>  2011-05-13 13:27:04 ---
> Could you please erase the amarok* files located in $HOME/.kde/share/config/
> and try again?
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 Myriam Schweingruber 2011-05-14 12:36:16 UTC
You are welcome.

*** This bug has been marked as a duplicate of bug 258741 ***