Bug 273050 - Unable to reassign terminal panel keyboard shortcut (or any panel shortcut for that matter)
Summary: Unable to reassign terminal panel keyboard shortcut (or any panel shortcut fo...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: panels: terminal (show other bugs)
Version: 1.6.1
Platform: Ubuntu Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-11 17:49 UTC by SiegeLord
Modified: 2011-10-10 20:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments
Patches the panel actions (4.10 KB, patch)
2011-09-17 00:42 UTC, SiegeLord
Details
Patch #2 (478 bytes, patch)
2011-09-17 00:43 UTC, SiegeLord
Details
dolphin-4.7.2-fix-panel-shortcuts.patch (4.64 KB, patch)
2011-10-10 17:19 UTC, Fabian Henze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SiegeLord 2011-05-11 17:49:00 UTC
Version:           1.6.1 (using KDE 4.6.2) 
OS:                Linux

By default, the terminal panel is opened when pressing F4. I wish to reassign this shortcut to some other key combination, but it does not show up in the Settings->Configure Shortcuts dialog.

The reason why I want to reassign it is that F4 is used in other file managers for the Open Terminal functionality (i.e. spawn a new terminal window) and I want Dolphin to have the same behaviour. Right now it is impossible to assign any action to use the F4 key because the terminal panel function is using it.

Reproducible: Always

Steps to Reproduce:
Open Settings->Configure Shortcuts and search for any of the panel shortcuts (e.g. F4).

Actual Results:  
I did not see any option that had the F4 shortcut even though I can verify (by pressing that button) that it is bound to opening the terminal panel.

Expected Results:  
I expected there to be an option to change the shortcut for all panel functions.

OS: Kubuntu 11.04 x86_64 
Kernel: 2.6.38-8-generic
Compiler: cc
Comment 1 mkkot 2011-07-31 14:32:30 UTC
This should be marked as a regular bug, not a wish. If you open Settings/Shortcuts configuration dialog, you can find there all positions from View/Pannels:
- Places F9
- Informations F11
- Folders F7
- Terminal F4
- Find F12

In Settings/Shortcuts configuration They don't have any shortcuts assigned and still, they are activated under keystrokes shown above. If I change F4's function to some other command, KDE shows error that this shortcut is ambiguous.
Comment 2 Terenyi Balazs 2011-08-16 08:47:06 UTC
It is a bug, not a wishlist item. I always press F4 in Dolphin following by #@%#^@&#$! :)
Please correct it.
Thanks in advance!
Comment 3 SiegeLord 2011-09-17 00:42:30 UTC
Created attachment 63711 [details]
Patches the panel actions
Comment 4 SiegeLord 2011-09-17 00:43:03 UTC
Created attachment 63712 [details]
Patch #2
Comment 5 SiegeLord 2011-09-17 00:43:14 UTC
Ok, so I created a patch that seems to fix it for me. Basically, what seems to be at fault is the DolphinMainWindow::addActionCloneToCollection. Firstly, it creates an incomplete clone (it doesn't clone the shortcut) and secondly the clone it creates doesn't get added to the menu (View->Panels). The patch fixes those two things. Note that I know absolutely nothing about KDE programming... so my fixes may be incorrect. The patches are against the 4.6 branch... ask me if you want it done against the trunk.
Comment 6 Fabian Henze 2011-10-10 17:19:10 UTC
Created attachment 64393 [details]
dolphin-4.7.2-fix-panel-shortcuts.patch

I modified the patch to apply for dolphin 4.7.2.
Is this in trunk or kde 4.7.3 yet?

Regards,
Fabian Henze
Comment 7 Peter Penz 2011-10-10 20:15:41 UTC
Git commit 30dbb39fb6e39e7cb0f6c9c68b65d5e31112fb4a by Peter Penz.
Committed on 10/10/2011 at 22:05.
Pushed by ppenz into branch 'master'.

Allow changing shortcuts for the Panel actions

Until now the shortcuts of the Panel actions could not be changed
as they did not show up in the "Configure shortcuts..." dialog.

The patch is based on the work of "SiegeLord" and Fabian Henze
attached to bug 273050.

BUG: 273050
FIXED-IN: 4.8.0

M  +16   -20   dolphin/src/dolphinmainwindow.cpp
M  +9    -7    dolphin/src/dolphinmainwindow.h

http://commits.kde.org/kde-baseapps/30dbb39fb6e39e7cb0f6c9c68b65d5e31112fb4a
Comment 8 Peter Penz 2011-10-10 20:15:58 UTC
Thanks Fabian and "SiegeLord" for the patch! I'm sorry that I did not reply earlier, but I missed that a patch has been attached (-> I'd kindly ask to use git.reviewboard.kde.org in future for patches instead, as this is easier to track for the maintainers).

Regarding the patch: I just pushed a modified version based on your patch. The reason why I did not take your patch 1:1 was that it results in removed checkboxes in the panel-menu, so for the user it would be not visible anymore which panels are active and which are not.