Bug 273016 - Wrong loading order of styles in a table
Summary: Wrong loading order of styles in a table
Status: RESOLVED FIXED
Alias: None
Product: calligracommon
Classification: Unclassified
Component: text-layout (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks: 244340
  Show dependency treegraph
 
Reported: 2011-05-11 10:42 UTC by Lassi Nieminen
Modified: 2011-11-12 23:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lassi Nieminen 2011-05-11 10:42:05 UTC
Version:           unspecified
OS:                Linux

A table cell can have a cell-style which defines cell-properties, paragraph-properties and text-properties.
Currently loading order seems to be
1. Load cell-style
2. Load default paragraph style
3 ...

Step 2 causes problems as it can overwrite properties from step 1

Reproducible: Always

Steps to Reproduce:
To see the effect open a document from eg. https://bugs.kde.org/show_bug.cgi?id=244340
and notice how in the 4th table of the file, the text sizes of the table are replaced from sizes from default paragraph style.
Comment 1 Camilla Boemann 2011-11-12 23:08:39 UTC
Fixed with the style inheritance