Bug 272942 - Don’t make mobile connection wizard stick in my face
Summary: Don’t make mobile connection wizard stick in my face
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: networkmanagement (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 278399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-10 15:08 UTC by Kai Uwe Broulik
Modified: 2011-07-24 21:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-05-10 15:08:06 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Often I need to plug in my smartfone to my computer to copy some files over (pictures etc.) and although I have set it to automatically use mass storage connection mode instead of mobile internet, tethering or such, the Mobile Connection wizard appears and steals focus and I need to always close it.
What about ading a notification to system tray “You have plugged in a smartphone.” with a button “Configure Tethering” or something. 

Reproducible: Always
Comment 1 Lamarque V. Souza 2011-05-10 23:27:05 UTC
Git commit 87b2038e204e566a6ea096110e0db5a80a78a1f6 by Lamarque V. Souza.
Committed on 10/05/2011 at 23:23.
Pushed by lvsouza into branch 'master'.

Change the launch of Mobile Connection Wizard into a notification.

BUG: 272942
CCBUG: 269853

M  +1    -1    kded/service.cpp     
M  +0    -24   libs/service/networkinterfacemonitor.cpp     
M  +49   -1    libs/service/notificationmanager.cpp     
M  +5    -1    libs/service/notificationmanager.h     

http://commits.kde.org/networkmanagement/87b2038e204e566a6ea096110e0db5a80a78a1f6
Comment 2 Lamarque V. Souza 2011-05-10 23:27:06 UTC
Git commit d915d3e92f1347364f983c49efb7bda28f98d9bf by Lamarque V. Souza.
Committed on 10/05/2011 at 23:23.
Pushed by lvsouza into branch 'nm09'.

Change the launch of Mobile Connection Wizard into a notification.

BUG: 272942
CCBUG: 269853
(cherry picked from commit 87b2038e204e566a6ea096110e0db5a80a78a1f6)

M  +1    -1    kded/service.cpp     
M  +0    -24   libs/service/networkinterfacemonitor.cpp     
M  +49   -1    libs/service/notificationmanager.cpp     
M  +5    -1    libs/service/notificationmanager.h     

http://commits.kde.org/networkmanagement/d915d3e92f1347364f983c49efb7bda28f98d9bf
Comment 3 Will Stephenson 2011-05-26 23:50:46 UTC
Git commit 21d5765b98dca8f49e63d1cc12c9befccb1ec953 by Will Stephenson, on behalf of Lamarque V. Souza.
Committed on 10/05/2011 at 23:23.
Pushed by wstephens into branch 'libnm-qt'.

Change the launch of Mobile Connection Wizard into a notification.

BUG: 272942
CCBUG: 269853
(cherry picked from commit 87b2038e204e566a6ea096110e0db5a80a78a1f6)

M  +1    -1    kded/service.cpp     
M  +0    -24   libs/service/networkinterfacemonitor.cpp     
M  +49   -1    libs/service/notificationmanager.cpp     
M  +5    -1    libs/service/notificationmanager.h     

http://commits.kde.org/networkmanagement/21d5765b98dca8f49e63d1cc12c9befccb1ec953
Comment 4 Lamarque V. Souza 2011-07-24 21:55:33 UTC
*** Bug 278399 has been marked as a duplicate of this bug. ***