Bug 272804 - Ultimate iPod support bug collection
Summary: Ultimate iPod support bug collection
Status: RESOLVED DUPLICATE of bug 232072
Alias: None
Product: amarok
Classification: Applications
Component: Collections/iPod iPhone (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-08 20:23 UTC by Edney Matias
Modified: 2011-12-20 11:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edney Matias 2011-05-08 20:23:38 UTC
Version:           unspecified
OS:                Linux

Things that happens with my iPod Shuffle 2nd generation Silver 1GB, serial number 4H72533EVTE. 
 1. sync flawless with iTunes on Windows and copy some musics to it;
 2. i can play straight forward and in random order;
 3. it's detected on linux by amarok;
 4. after initializing it as a xA546 amarok as me my root password! Why? I just want to copy musics! GtkPod doesn't ask root password!
 5. amarok reports only one track on my iPod;
 6. the pre loaded tracks didn't show up in my collection but amarok shows how much space is taken by them;
 7. if i tell amarok to look for orfans tracks amarok finds them (23 tracks in this case) but doesn't update the number of tracks. It shows only one track;
 8; i can't play any of them directly from iPod on amarok
 9. if i click and drag the iPod from my collection, only one track is loaded. I suppose it's the same track amarok identified as the only one track on the iPod. I can't play this track neither. In this case, this track is one from Usher. I also have AC/DC loaded on the iPod.
 10. I try to erase AC/DC and amarok asks me to confirm i want to erase Usher. Indeed it asks me if I want to erase Usher for each track i try to erase from iPod. Usher is not that bad! :D
 11. i tried to load some tracks to iPod. Some tracks are load, some not. Amarok says they are already on the iPod. There's plenty of space available.
 12. the space available and the number of tracks are updated accordly for each track i can copy to iPod. In this case amarok shows 3 tracks (remember I have 23 tracks, plus 2 it should be showing up 25 tracks);
 13. i can listen to the musics i managed to copy directly from iPod;
 14. i can't erase all tracks from iPod. It asks me to confirm i want to erase 3 tracks (not 25), but it doesn't erase them;
 15. i can still listen to the tracks i tried to erase;
 16. after messing with my iPod on amarok and unplugin it I can't play musics on random order. Very weird.
 17. went windows again and restart the iPod and with it empty i went back to linux and plugged it again.
 18. amarok states i have one track! -.-
 19. i tried to copy some musics, same thing. Some it's copied, some amarok tells they are already on the device; 
 20. i managed to copy 15 tracks, and it states it's 15 traks not 16 (15 + 1 ghost track);
 21. i can listen to these musics directly from the iPod;
 22. trying to eject iPod while listing to music crashes amarok; 
 
That's it, the ultimate iPod support bug collection.

Reproducible: Always




$ rpm -qa | grep amarok
amarok-utils-2.4.1-1.fc15.i686
amarok-2.4.1-1.fc15.i686
amarok-libs-2.4.1-1.fc15.i686

$ rpm -qa | grep pod
libgpod-0.8.0-7.fc15.i686

Running kde 4.6.3 from redhat-kde repository and Fedora 15 beta. I didn't find this version on the drop box above neither amarok 2.4.1, just 2.4.0.90.
Comment 1 Myriam Schweingruber 2011-05-10 03:04:09 UTC
This is already reported several times.

*** This bug has been marked as a duplicate of bug 232072 ***