Bug 272681 - Kaffeine only playing on internal speakers
Summary: Kaffeine only playing on internal speakers
Status: RESOLVED NOT A BUG
Alias: None
Product: kaffeine
Classification: Applications
Component: general (show other bugs)
Version: 1.x
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-07 09:59 UTC by schmirrwurst
Modified: 2017-10-04 09:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schmirrwurst 2011-05-07 09:59:46 UTC
Version:           1.1 (using KDE 4.6.2) 
OS:                Linux

Under Maverick and Lucid, I had phonon configured to play video on usb speaker first, and that worked well with kaffeine as well.

Now under natty, it doesn't work anymore... First I thougt it was because of the gstreamer backend, so I've setup the xine backen in phonon, but still the same...



Reproducible: Didn't try




OS: Linux (x86_64) release 2.6.38-8-generic
Compiler: cc
Comment 1 schmirrwurst 2011-05-07 10:01:32 UTC
My submit was incomplete...
What happens now, is that kaffeine is only playing to internal speaker... and ignores the phonon settings to play on usb first. And again that worked on previous Ubuntu with 4.6.1 KDE
Comment 2 Rex Dieter 2011-05-10 15:01:31 UTC
Recent versions of kaffeine do not use phonon, but rather uses xine-lib directly.

Now, if you are using pulseaudio, and have xine-lib's pulseaudio plugin installed/enabled, then you can use kmix or pavucontrol to move it's stream to play on the output device of your choosing.

Non PA case is doable too, but is a bit more complicated (which I'm not familiar with).