Bug 272534 - KDevelop says that profiled launch is not supported, but not why
Summary: KDevelop says that profiled launch is not supported, but not why
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Profiles (show other bugs)
Version: 4.2.1
Platform: Compiled Sources Linux
: HI normal (vote)
Target Milestone: 4.2.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-05 14:57 UTC by Wolfgang Bangerth
Modified: 2013-10-08 00:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Bangerth 2011-05-05 14:57:25 UTC
Version:           4.2.1 (using KDE 4.6.0) 
OS:                Linux

When I go to "Run > Profile launch", all I get is an error box saying "The current launch configuration does not support the 'profile' mode." The problem is: I have no idea why not:
- Going through the "Run > Configure launches" dialog, I see no option that has
  anything to do with profiles -- I thought I may have to add a different
  launch configuration, for example, but there didn't seem to be anything in
  this direction
- I have both gprof and valgrind installed

The point is that I'm sure KDevelop has good reasons for the error message but it doesn't say which they are and how I can remedy them :-)


Some more digging:
- the error message is produced in kdevplatform/RunController::execute
- to the best of my knowledge, it happens because no launch for the
  'profile' id exists in LaunchConfiguration
Beyond this, my KDevelop source foo wanes...

Best
 Wolfgang

Reproducible: Always
Comment 1 Milian Wolff 2011-05-30 16:04:52 UTC
indeed, this should be disabled/removed until we have profile launches supported again
Comment 2 Aleix Pol 2013-10-08 00:34:25 UTC
Git commit d1ec3ea2e009f092eee128f5bd5f4733fa170eb6 by Aleix Pol.
Committed on 08/10/2013 at 00:31.
Pushed by apol into branch 'master'.

Remove unused Run > profile menu entry

Currently we had the menu entry but nobody using it. Technically it's
correct because whenever we'd get a profiler it would work automatically
but I'd say that also having the option but not being able to use
it is nothing but frustrating.

Commenting out the code until somebody puts some care into profiling
integration.

M  +7    -7    shell/runcontroller.cpp

http://commits.kde.org/kdevplatform/d1ec3ea2e009f092eee128f5bd5f4733fa170eb6