Bug 272393 - Crash while entering data if XIM input method is used
Summary: Crash while entering data if XIM input method is used
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.5.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 272482 274707 277897 278985 282524 304797 311347 315625 316150 317063 320068 322382 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-04 00:29 UTC by Ron McCormick
Modified: 2014-01-04 01:00 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.78 KB, text/plain)
2011-05-04 00:41 UTC, Ron McCormick
Details
New crash information added by DrKonqi (6.77 KB, text/plain)
2011-05-04 00:50 UTC, Ron McCormick
Details
This could solve the problem but I haven't been able to test it since I could not reproduce the crash (502 bytes, patch)
2011-05-05 22:43 UTC, Cristian Oneț
Details
New crash information added by DrKonqi (7.43 KB, text/plain)
2011-05-07 22:09 UTC, trioleyre
Details
New crash information added by DrKonqi (7.61 KB, text/plain)
2011-06-26 09:41 UTC, cotteuxm
Details
New crash information added by DrKonqi (9.97 KB, text/plain)
2011-10-22 07:30 UTC, jm.bourgit
Details
New crash information added by DrKonqi (4.76 KB, text/plain)
2012-06-25 04:37 UTC, richpal33
Details
New crash information added by DrKonqi (5.97 KB, text/plain)
2014-01-03 08:20 UTC, Fam.Hoogerwerf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron McCormick 2011-05-04 00:29:42 UTC
Application: kmymoney (4.5.3)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic-pae i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:  Entering a deposit to ledger for my check account.  Just upgraded/installed Ubuntu 11.?? from 10.??.  I still can't find stuff in this upgrade (like the system version identifier)

-- Backtrace:
Application: KMyMoney (kmymoney), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4202930 (LWP 1815))]

Thread 2 (Thread 0xb3de9b70 (LWP 1816)):
#0  0xb7711424 in __kernel_vsyscall ()
#1  0xb5443f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb4ab184b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4aa11af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4aa192b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb3f26304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb4aca2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb68d8e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb545273e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb4202930 (LWP 1815)):
[KCrash Handler]
#7  0xb578729f in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /usr/lib/libQtGui.so.4
#8  0xb5788318 in QWidget::effectiveWinId() const () from /usr/lib/libQtGui.so.4
#9  0xb5d6654b in ?? () from /usr/lib/libQtGui.so.4
#10 0xb5d6887a in ?? () from /usr/lib/libQtGui.so.4
#11 0xb5d67edb in ?? () from /usr/lib/libQtGui.so.4
#12 0xb5d67fa3 in ?? () from /usr/lib/libQtGui.so.4
#13 0xb5d68062 in ?? () from /usr/lib/libQtGui.so.4
#14 0xb626eb87 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#15 0xb5792144 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#16 0xb5b5711e in QComboBox::~QComboBox() () from /usr/lib/libQtGui.so.4
#17 0xb6d1a768 in KComboBox::~KComboBox() () from /usr/lib/libkdeui.so.5
#18 0x0835dd22 in ~KMyMoneyCombo (this=0xabba048, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/widgets/kmymoneycombo.h:49
#19 KMyMoneyCategory::~KMyMoneyCategory (this=0xabba048, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/widgets/kmymoneycategory.cpp:99
#20 0x0835ded2 in KMyMoneyCategory::~KMyMoneyCategory (this=0xabba048, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/widgets/kmymoneycategory.cpp:106
#21 0x0820c522 in KMyMoneyTransactionForm::TransactionForm::removeEditWidgets (this=0xa4c93b0, editWidgets=...) at /build/buildd/kmymoney-4.5.3/kmymoney/widgets/transactionform.cpp:460
#22 0x08331954 in TransactionEditor::~TransactionEditor (this=0xa9ec3d0, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/dialogs/transactioneditor.cpp:89
#23 0x08331b0a in ~StdTransactionEditor (this=0xa9ec3d0, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/dialogs/transactioneditor.cpp:705
#24 StdTransactionEditor::~StdTransactionEditor (this=0xa9ec3d0, __in_chrg=<value optimized out>) at /build/buildd/kmymoney-4.5.3/kmymoney/dialogs/transactioneditor.cpp:707
#25 0x080bd042 in deleteTransactionEditor (this=0xa204fa8) at /build/buildd/kmymoney-4.5.3/kmymoney/kmymoney.cpp:5121
#26 KMyMoneyApp::slotTransactionsEnter (this=0xa204fa8) at /build/buildd/kmymoney-4.5.3/kmymoney/kmymoney.cpp:5181
#27 0x080d5477 in KMyMoneyApp::qt_metacall (this=0xa204fa8, _c=QMetaObject::InvokeMetaMethod, _id=78, _a=0xbfa1e278) at /build/buildd/kmymoney-4.5.3/obj-i686-linux-gnu/kmymoney/kmymoney.moc:481
#28 0xb62616ba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#29 0xb62714ff in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#30 0xb57378d9 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
#31 0xb5737b38 in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
#32 0xb5738ffb in QAction::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#33 0xb579e68a in QWidgetAction::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#34 0xb6b750aa in KAction::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
#35 0xb62616ba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#36 0xb62714ff in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#37 0x08327a67 in TransactionEditor::returnPressed (this=0xa9ec3d0) at /build/buildd/kmymoney-4.5.3/obj-i686-linux-gnu/kmymoney/dialogs/transactioneditor.moc:223
#38 0x0832a0ab in TransactionEditor::qt_metacall (this=0xa9ec3d0, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xa9f4090) at /build/buildd/kmymoney-4.5.3/obj-i686-linux-gnu/kmymoney/dialogs/transactioneditor.moc:122
#39 0x0833619a in StdTransactionEditor::qt_metacall (this=0xa9ec3d0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xa9f4090) at /build/buildd/kmymoney-4.5.3/obj-i686-linux-gnu/kmymoney/dialogs/transactioneditor.moc:299
#40 0xb62616ba in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#41 0xb626be16 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#42 0xb62703b7 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#43 0xb573ed24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#44 0xb57438ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#45 0xb6c663ca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#46 0xb625b0bb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#47 0xb625ec79 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#48 0xb625ee0d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#49 0xb62883c4 in ?? () from /usr/lib/libQtCore.so.4
#50 0xb4aa0aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0xb4aa1270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0xb4aa1524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#53 0xb628853c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#54 0xb57f2775 in ?? () from /usr/lib/libQtGui.so.4
#55 0xb625a289 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#56 0xb625a522 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#57 0xb625eecc in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#58 0xb573c8e7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#59 0x08086c4f in main (argc=) at /build/buildd/kmymoney-4.5.3/kmymoney/main.cpp:260

Reported using DrKonqi
Comment 1 Ron McCormick 2011-05-04 00:41:21 UTC
Created attachment 59592 [details]
New crash information added by DrKonqi

kmymoney (4.5.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:Same thing as a few minutes ago - same amount, same date etc.  Trying to enter deposit that caused the first crash

-- Backtrace (Reduced):
#7  0xb579229f in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /usr/lib/libQtGui.so.4
#8  0xb5793318 in QWidget::effectiveWinId() const () from /usr/lib/libQtGui.so.4
[...]
#14 0xb6279b87 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#15 0xb579d144 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#16 0xb5b6211e in QComboBox::~QComboBox() () from /usr/lib/libQtGui.so.4
Comment 2 Ron McCormick 2011-05-04 00:50:06 UTC
Created attachment 59593 [details]
New crash information added by DrKonqi

kmymoney (4.5.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
Entering nother deposit - different amount; different payee

-- Backtrace (Reduced):
#7  0xb588129f in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /usr/lib/libQtGui.so.4
#8  0xb5882318 in QWidget::effectiveWinId() const () from /usr/lib/libQtGui.so.4
[...]
#14 0xb6368b87 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#15 0xb588c144 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#16 0xb5c5111e in QComboBox::~QComboBox() () from /usr/lib/libQtGui.so.4
Comment 3 Cristian Oneț 2011-05-05 08:42:02 UTC
*** Bug 272482 has been marked as a duplicate of this bug. ***
Comment 4 Cristian Oneț 2011-05-05 22:43:16 UTC
Created attachment 59666 [details]
This could solve the problem but I haven't been able to test it since I could not reproduce the crash

Could you try this patch? I haven't been able to crash KMyMoney while entering transactions for a long time (In think since the 4.5 series was released) so I can't tell what is the exact problem and if this patch fixes it but it's worth giving it a try.
BTW I also have Qt 4.7.2 + KDE 4.6.2 running + KMyMoney from SVN trunk.
Comment 5 Ron McCormick 2011-05-07 17:17:58 UTC
Thanks for your quick reply to my crash issue.

I have the patch you sent but I don't have a clue where and how to
apply it.  I am a semi novice to Ubuntu /linux but really like
KMyMoney as an alternative to Quicken.

Thanks for your help.

On Thu, May 5, 2011 at 4:43 PM, Cristian Onet <onet.cristian@gmail.com> wrote:
> https://bugs.kde.org/show_bug.cgi?id=272393
>
>
>
>
>
> --- Comment #4 from Cristian Onet <onet cristian gmail com>  2011-05-05 22:43:16 ---
> Created an attachment (id=59666)
>  --> (http://bugs.kde.org/attachment.cgi?id=59666)
> This could solve the problem but I haven't been able to test it since I could
> not reproduce the crash
>
> Could you try this patch? I haven't been able to crash KMyMoney while entering
> transactions for a long time (In think since the 4.5 series was released) so I
> can't tell what is the exact problem and if this patch fixes it but it's worth
> giving it a try.
> BTW I also have Qt 4.7.2 + KDE 4.6.2 running + KMyMoney from SVN trunk.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 6 trioleyre 2011-05-07 22:09:49 UTC
Created attachment 59744 [details]
New crash information added by DrKonqi

kmymoney (4.5.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:updating ledgers ,it crashed when I entered the data, clicked enter button.

-- Backtrace (Reduced):
#7  0x0160f29f in QWidget::testAttribute_helper (this=0x9832b60, attribute=Qt::WA_WState_Created) at kernel/qwidget.cpp:10870
#8  0x01610318 in testAttribute (this=0x9832b60) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1031
#9  QWidget::effectiveWinId (this=0x9832b60) at kernel/qwidget.cpp:2544
#10 0x01bee54b in QXIMInputContext::reset (this=0x98ebb20) at inputmethod/qximinputcontext_x11.cpp:579
#11 0x01bf087a in QXIMInputContext::setFocusWidget (this=0x98ebb20, w=0x0) at inputmethod/qximinputcontext_x11.cpp:649
Comment 7 Cristian Oneț 2011-06-01 22:54:17 UTC
*** Bug 274707 has been marked as a duplicate of this bug. ***
Comment 8 cotteuxm 2011-06-26 09:41:17 UTC
Created attachment 61338 [details]
New crash information added by DrKonqi

kmymoney (4.5.3) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed: enter new entry, button record entry, credit or debit

-- Backtrace (Reduced):
#7  0x0193029f in QWidget::testAttribute_helper (this=0xa741340, attribute=Qt::WA_WState_Created) at kernel/qwidget.cpp:10870
#8  0x01931318 in testAttribute (this=0xa741340) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1031
#9  QWidget::effectiveWinId (this=0xa741340) at kernel/qwidget.cpp:2544
#10 0x01f0f54b in QXIMInputContext::reset (this=0xa77f638) at inputmethod/qximinputcontext_x11.cpp:579
#11 0x01f1187a in QXIMInputContext::setFocusWidget (this=0xa77f638, w=0x0) at inputmethod/qximinputcontext_x11.cpp:649
Comment 9 Cristian Oneț 2011-07-18 15:18:42 UTC
*** Bug 277897 has been marked as a duplicate of this bug. ***
Comment 10 Cristian Oneț 2011-08-02 17:13:58 UTC
*** Bug 278985 has been marked as a duplicate of this bug. ***
Comment 11 Thomas Baumgart 2011-10-02 06:29:12 UTC
*** Bug 282524 has been marked as a duplicate of this bug. ***
Comment 12 jm.bourgit 2011-10-22 07:30:44 UTC
Created attachment 64778 [details]
New crash information added by DrKonqi

kmymoney (4.5.3) on KDE Platform 4.7.1 (4.7.1) using Qt 4.7.4

- What I was doing when the application crashed: enter data in an account

- Unusual behavior I noticed: not sure but I think money was starting an auto save 

- Custom settings of the application: my file '.kmy) is not on the same drive as the system

-- Backtrace (Reduced):
#7  0x03c69e0a in QWidget::testAttribute_helper (this=0xc129530, attribute=Qt::WA_WState_Created) at kernel/qwidget.cpp:10912
#8  0x03c6b020 in testAttribute (attribute=Qt::WA_WState_Created, this=0xc129530) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1031
#9  QWidget::effectiveWinId (this=0xc129530) at kernel/qwidget.cpp:2564
#10 0x0426b2f6 in QXIMInputContext::reset (this=0xbf40e48) at inputmethod/qximinputcontext_x11.cpp:579
#11 0x0426d6ed in QXIMInputContext::setFocusWidget (this=0xbf40e48, w=0x0) at inputmethod/qximinputcontext_x11.cpp:649
Comment 13 richpal33 2012-06-25 04:37:36 UTC
Created attachment 72105 [details]
New crash information added by DrKonqi

kmymoney (4.6.1) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:Entered transaction in ledger and crashed on hitting OK button. Happened three times.

-- Backtrace (Reduced):
#6  0x00007ff8e23e763f in QWidget::testAttribute_helper (this=0x4b886e0, attribute=Qt::WA_WState_Created) at kernel/qwidget.cpp:11034
#7  0x00007ff8e23e864a in testAttribute (attribute=Qt::WA_WState_Created, this=0x4b886e0) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1042
#8  QWidget::effectiveWinId (this=0x4b886e0) at kernel/qwidget.cpp:2610
#9  0x00007ff8e29788ed in QXIMInputContext::reset (this=0x2d36fb0) at inputmethod/qximinputcontext_x11.cpp:579
#10 0x00007ff8e297a073 in QXIMInputContext::setFocusWidget (this=0x2d36fb0, w=0x0) at inputmethod/qximinputcontext_x11.cpp:649
Comment 14 Cristian Oneț 2013-02-22 13:20:14 UTC
*** Bug 315625 has been marked as a duplicate of this bug. ***
Comment 15 Jekyll Wu 2013-03-05 01:22:26 UTC
*** Bug 316150 has been marked as a duplicate of this bug. ***
Comment 16 Jekyll Wu 2013-03-05 01:22:28 UTC
*** Bug 304797 has been marked as a duplicate of this bug. ***
Comment 17 Jekyll Wu 2013-03-21 02:02:52 UTC
*** Bug 317063 has been marked as a duplicate of this bug. ***
Comment 18 Jekyll Wu 2013-05-21 01:25:44 UTC
*** Bug 311347 has been marked as a duplicate of this bug. ***
Comment 19 Jekyll Wu 2013-05-21 01:25:53 UTC
*** Bug 320068 has been marked as a duplicate of this bug. ***
Comment 20 Jekyll Wu 2013-07-15 10:28:00 UTC
*** Bug 322382 has been marked as a duplicate of this bug. ***
Comment 21 Cristian Oneț 2013-08-27 07:23:52 UTC
Git commit ea6b2b13886afa30d2b402627ef8e6b374216338 by Cristian Oneț.
Committed on 27/08/2013 at 06:25.
Pushed by conet into branch 'master'.

KMyMoneyCompletion should now work properly using input methods.

Remove previous workarounds that were added to hide this problem.
Related: bug 272631, bug 320579

M  +1    -9    kmymoney/converter/mymoneystatementreader.cpp
M  +4    -6    kmymoney/widgets/kmymoneycompletion.cpp
M  +0    -9    kmymoney/widgets/kmymoneyselector.cpp

http://commits.kde.org/kmymoney/ea6b2b13886afa30d2b402627ef8e6b374216338
Comment 22 Cristian Oneț 2013-08-27 07:37:55 UTC
Git commit 9ab659c6878798b27572afb8c209c7498ccc9261 by Cristian Oneț.
Committed on 27/08/2013 at 06:25.
Pushed by conet into branch '4.6'.

KMyMoneyCompletion should now work properly using input methods.

Remove previous workarounds that were added to hide this problem.
Related: bug 272631, bug 320579
(cherry picked from commit ea6b2b13886afa30d2b402627ef8e6b374216338)

M  +1    -9    kmymoney/converter/mymoneystatementreader.cpp
M  +4    -6    kmymoney/widgets/kmymoneycompletion.cpp
M  +0    -9    kmymoney/widgets/kmymoneyselector.cpp

http://commits.kde.org/kmymoney/9ab659c6878798b27572afb8c209c7498ccc9261
Comment 23 Fam.Hoogerwerf 2014-01-03 08:20:23 UTC
Created attachment 84422 [details]
New crash information added by DrKonqi

kmymoney (4.6.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed: Entering a new ledger entry. 
- Just upgraded to Linux Kernel 3.8.0. 
- Re-installing KMyMoney with the UIbuntu Software Center doesn't help.

-- Backtrace (Reduced):
#6  0x00007f9b596e163f in QWidget::testAttribute_helper (this=0x35da3c0, attribute=Qt::WA_WState_Created) at kernel/qwidget.cpp:11034
#7  0x00007f9b596e264a in testAttribute (attribute=Qt::WA_WState_Created, this=0x35da3c0) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1042
#8  QWidget::effectiveWinId (this=0x35da3c0) at kernel/qwidget.cpp:2610
#9  0x00007f9b59c728ed in QXIMInputContext::reset (this=0x1f35240) at inputmethod/qximinputcontext_x11.cpp:579
#10 0x00007f9b59c74073 in QXIMInputContext::setFocusWidget (this=0x1f35240, w=0x0) at inputmethod/qximinputcontext_x11.cpp:649
Comment 24 Thomas Baumgart 2014-01-03 11:38:12 UTC
(In reply to comment #23)
> Created attachment 84422 [details]
> New crash information added by DrKonqi
> 
> kmymoney (4.6.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

This bug has been fixed in KMyMoney 4.6.4 and is therefor closed. Please upgrade and reopen only if the problem still persists.
Comment 25 Fam.Hoogerwerf 2014-01-04 01:00:22 UTC
Thanks Thomas,

I built the version 4.6.4 stating from the TAR archive. I found it would 
have been helpful to have the command :
sudo apt-get build-dep kmymoney given in the README.cmake file. Now I 
only ran into it on the page:
http://www.linuxquestions.org/questions/debian-26/minimun-packages-required-to-build-kde-apps-kmymoney-856535/ 
after some struggle to get cmake to run. I have done a quick test and it 
appears the program works fine.

Thanks for your efforts.

Arno Hoogerwerf



On 01/03/2014 12:38 PM, Thomas Baumgart wrote:
> https://bugs.kde.org/show_bug.cgi?id=272393
>
> --- Comment #24 from Thomas Baumgart <ipwizard@users.sourceforge.net> ---
> (In reply to comment #23)
>> Created attachment 84422 [details]
>> New crash information added by DrKonqi
>>
>> kmymoney (4.6.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1
> This bug has been fixed in KMyMoney 4.6.4 and is therefor closed. Please
> upgrade and reopen only if the problem still persists.
>