Bug 272388 - Ticket Severity/Importance cannot be edited
Summary: Ticket Severity/Importance cannot be edited
Status: CLOSED NOT A BUG
Alias: None
Product: bugs.kde.org
Classification: Websites
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Matt Rogers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 23:32 UTC by Heath Matlock
Modified: 2019-11-15 12:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heath Matlock 2011-05-03 23:32:49 UTC
Version:           unspecified
OS:                Linux

I just submitted a bug, but I should have selected "Minor" as it severity, couldn't find a way to change the severity. 

Reproducible: Didn't try
Comment 1 Christoph Feck 2011-05-04 01:00:14 UTC
You need to be logged in and the reporter of the bug, then you can change the severity using the combobox. Click "Commit" after changing the field.

You can also just add a comment, and the bug triaging team will take care of it.
Comment 2 Philippe Cloutier 2019-10-23 00:26:42 UTC
Assuming that "severity" refers to Importance, I'm afraid this was erroneously marked as resolved. I cannot change the Importance of - for example - https://bugs.kde.org/show_bug.cgi?id=413343

As for adding comments, I believe I commented on a few tickets which needed changes in recent months, and I don't remember any being taken caren of.
Comment 3 David Edmundson 2019-11-04 09:29:56 UTC
Members with bugedit rights can edit the severity. This includes all triagers.

There was no need to reopen this.
Comment 4 Philippe Cloutier 2019-11-04 12:56:22 UTC
(In reply to David Edmundson from comment #3)
> Members with bugedit rights can edit the severity. This includes all
> triagers.

In that case, this is broken. I cannot edit this very ticket's "severity".

Why was this ticket marked as resolved?
Comment 5 Philippe Cloutier 2019-11-04 12:57:46 UTC
Arguably, this ticket's "severity" should be wishlist. But of course, it can't be changed :-)
Comment 6 David Edmundson 2019-11-04 13:00:02 UTC
>In that case, this is broken. I cannot edit this very ticket's "severity".

Really? 
Can you go to https://bugs.kde.org/userprefs.cgi?tab=permissions

and confirm if you have editbugs?
Comment 7 Philippe Cloutier 2019-11-04 13:15:55 UTC
(In reply to David Edmundson from comment #6)
> >In that case, this is broken. I cannot edit this very ticket's "severity".
> 
> Really? 

Really


> Can you go to https://bugs.kde.org/userprefs.cgi?tab=permissions
> 
> and confirm if you have editbugs?

Yes
Comment 8 David Edmundson 2019-11-04 14:02:21 UTC
Can I have a screenshot of this severity box and the permissions page above.
Comment 9 Philippe Cloutier 2019-11-05 01:36:53 UTC
Can I have an answer to my question.
Otherwise I don't see why we'd bother providing screenshots for a problem which was supposedly resolved.
Comment 10 David Edmundson 2019-11-13 00:58:34 UTC
I haven't followed what your question was.

People with the editbugs group privilege should be able to edit bugs.
People without should not (the original post was saying they should. Hence closed).

If you have the editbugs groups privilege granted and can't edit bugs, that's a separate relevant bug, but somehow we're talking it here. I wanted the screenshots as it's the fastest way to confirm we're talking about the same things.
Comment 11 Philippe Cloutier 2019-11-13 01:18:23 UTC
(In reply to David Edmundson from comment #10)
> I haven't followed what your question was.

My question is the last sentence of comment #4.


> People with the editbugs group privilege should be able to edit bugs.
> People without should not (the original post was saying they should. Hence
> closed).

The definition of editbugs is "Can edit all aspects of any bug."
The Description does not say people without editbugs should be able to edit all aspects of a ticket, it merely implies the obvious - that reporters should be able to edit the Importance, which they set themselves. In fact, the Description does not say anything about editbugs.


> If you have the editbugs groups privilege granted and can't edit bugs,
> that's a separate relevant bug, but somehow we're talking it here. I wanted
> the screenshots as it's the fastest way to confirm we're talking about the
> same things.

I would argue that would be an additional issue. I think it suffices to state that a new ticket can be filed to track that problem.
Comment 12 Buovjaga 2019-11-13 09:00:07 UTC
(In reply to David Edmundson from comment #3)
> Members with bugedit rights can edit the severity. This includes all
> triagers.

The group editbugs is more restricted. Members in "contributors" group can edit severity:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging#Bug_editing_permissions

"You are restricted to only a few abilities, such as bulk editing, changing the Priority and Severity fields (Importance), or re-opening CLOSED bugs. After getting comfortable with the KDE Bugzilla process, you can request "contributor" privileges from Sysadmin, which will allow you to perform those actions."
Comment 13 Philippe Cloutier 2019-11-13 13:05:12 UTC
Thank you Buovjaga,
If I understand correctly, there are 2 issues (in addition to the one tracked here):
1. https://bugs.kde.org/userprefs.cgi?tab=permissions claims editbugs grants more permissions than it does (like editing Importance).
2. https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging#Bug_editing_permissions says the opposite of what it intends to say (following https://community.kde.org/index.php?title=Guidelines_and_HOWTOs/Bug_triaging&diff=82599&oldid=81937 )
Comment 14 Buovjaga 2019-11-13 13:25:02 UTC
(In reply to Filipus Klutiero from comment #13)
> Thank you Buovjaga,
> If I understand correctly, there are 2 issues (in addition to the one
> tracked here):
> 1. https://bugs.kde.org/userprefs.cgi?tab=permissions claims editbugs grants
> more permissions than it does (like editing Importance).
> 2.
> https://community.kde.org/Guidelines_and_HOWTOs/
> Bug_triaging#Bug_editing_permissions says the opposite of what it intends to
> say (following
> https://community.kde.org/index.php?title=Guidelines_and_HOWTOs/
> Bug_triaging&diff=82599&oldid=81937 )

Indeed, David and me apparently went editing the article at the same time just now. I fixed the headings instead.
Comment 15 David Edmundson 2019-11-13 13:25:58 UTC
The one being tracked here is now resolved. I gave the wrong group name. You aren't in "contributors", hence you don't have the powers. So there isn't a bug \o/

>2. https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging#Bug_editing_permissions says the opposite of what it intends to say 

Fixed.
Comment 16 Philippe Cloutier 2019-11-15 01:51:03 UTC
(In reply to David Edmundson from comment #15)
> The one being tracked here is now resolved. I gave the wrong group name. You
> aren't in "contributors", hence you don't have the powers. So there isn't a
> bug \o/

According to your 2019-11-04 change, this ticket is not a bug report, but rather a mere request for enhancement, so while there is no bug indeed, the issue reported remains.


> >2. https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging#Bug_editing_permissions says the opposite of what it intends to say 
> 
> Fixed.

Thanks
Comment 17 David Edmundson 2019-11-15 11:39:46 UTC
It is a request for a change that has been considered and declined.
Comment 18 Philippe Cloutier 2019-11-15 12:16:59 UTC
(In reply to David Edmundson from comment #17)
> It is a request for a change that has been considered and declined.

None of that resolves the problem.

Also note that the current resolution "NOT A BUG" is incompatible with the current Severity "wishlist".