Bug 272313 - FTP Authorization Dialog - illogical widget order
Summary: FTP Authorization Dialog - illogical widget order
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 276046 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-03 11:26 UTC by Malte Eggers
Modified: 2013-10-14 20:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12


Attachments
kdeui/dialogs/kpassworddialog.ui (3.85 KB, application/xml)
2013-10-10 13:17 UTC, Malte Eggers
Details
Separates out 'anonymous login' to separate button to make it clearly a separate concept. (9.82 KB, patch)
2013-10-10 21:06 UTC, Michael Pyne
Details
Screenshot of dialog with patch applied (29.89 KB, image/png)
2013-10-10 21:08 UTC, Michael Pyne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Malte Eggers 2011-05-03 11:26:33 UTC
Version:           4.6 (using KDE 4.6.2) 
OS:                Linux

The widget order is:
username (lineedit)
Anonymous (checkbox)
password (lineedit)

the checkbox should be on top (or possibly bottom). This makes more sense, as username and password belong together the checkbox should not separate them.. Also, it makes tabbing through widgets easier: Space>Tab>enter Username>Tab>enter Password>Enter could be used to log onto a server.

Reproducible: Always
Comment 1 Christoph Feck 2011-06-20 02:17:26 UTC
*** Bug 276046 has been marked as a duplicate of this bug. ***
Comment 2 Malte Eggers 2013-10-10 11:23:01 UTC
Not trying to be annoying or something, but for someone who knows some C++ and where the respective files are, it takes only a few minutes to fix this bug - and it has been open for more than two years now.
Comment 3 Malte Eggers 2013-10-10 13:17:42 UTC
Created attachment 82763 [details]
kdeui/dialogs/kpassworddialog.ui

I just made a fixed version. I don't really know how you like your patches, so I just provided the changed file. It works fine so far.
Comment 4 Michael Pyne 2013-10-10 21:06:03 UTC
Created attachment 82777 [details]
Separates out 'anonymous login' to separate button to make it clearly a separate concept.

May I offer this counter-proposal? It does require a couple of underlying code changes as well but it's very minor and seems to work well here. It splits off the anonymous checkbox completely into a separate option button to make it clear that anonymous mode disables all of the username/password/domain/etc. options.
Comment 5 Michael Pyne 2013-10-10 21:08:24 UTC
Created attachment 82778 [details]
Screenshot of dialog with patch applied
Comment 6 Michael Pyne 2013-10-14 20:47:07 UTC
Git commit f04f6abf8e556fa98e838becaf5ca19e316b779c by Michael Pyne.
Committed on 14/10/2013 at 19:10.
Pushed by mpyne into branch 'master'.

kdeui: Streamline KPasswordDialog.

A user reported a couple of years ago that the "Anonymous login"
checkbox is badly placed in KPasswordDialog, appearing in between the
user and password fields and sticking out like a sore thumb.

Instead of just moving the checkbox, I took the opportunity to make the
U/I match the underlying code. Since "Anonymous" mode makes the existing
U/I set both username and password fields to be read-only, it's really a
separate authentication scheme and should be treated as such, especially
since it is hard to tell visually that the Anonymous checkbox is
responsible for disabling the line edits above and below it.

The existing code relies somewhat on the widgets that are present in the
U/I file, so instead of trying to merge the new radio buttons with the
existing widgets I separated out the "anonymous" radio button and its
new counterpart, and left the rest of the existing widgets parented
under a hidden widget to minimize code churn and the risk of introducing
bugs.

Tested with a handy FTP server, and with the included KPasswordDialog
test suite.
FIXED-IN:4.12
DIGEST:Improvements to KPasswordDialog
GUI:

M  +29   -27   kdeui/dialogs/kpassworddialog.cpp
M  +107  -73   kdeui/dialogs/kpassworddialog.ui

http://commits.kde.org/kdelibs/f04f6abf8e556fa98e838becaf5ca19e316b779c