Bug 272119 - Ark can't open password protected 7-zip files
Summary: Ark can't open password protected 7-zip files
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-01 06:13 UTC by cmt28
Modified: 2011-05-01 06:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cmt28 2011-05-01 06:13:02 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

I'm using Ark 2.16.

I can extract it using command line perfectly. ("7z e myfile.7z")
When I try to open it with Ark, it gets stuck on "Loading archive..."

After some while it shows a "Incorrect Password" dialog, without asking for any password. (does not happen everytime). 

Reproducible: Always

Steps to Reproduce:
Open any password protected 7-zip archive with Ark.

Actual Results:  
It gets stuck on "Loading archive..."

Expected Results:  
Ask for a password.

OS: Linux (x86_64) release 2.6.38-ARCH
Compiler: gcc

No relevant command-line output.

[cmt@myhost ~]$ ark myfile.7z 
Application asked to unregister timer 0x9000004 which is not registered in this thread. Fix application.
QProcess: Destroyed while process is still running.

ark(2862)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x235bac0 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes.
Comment 1 Raphael Kubo da Costa 2011-05-01 06:24:45 UTC
Ark currently has some problems with archives which have password-protected headers (rar and 7z). Most of these problems should be fixed in 4.7.0 (or 4.6.4, in case I'm able to fix what's still missing).

For now, I'm marking this as a duplicate of the bug tracking the password issues.

Thanks for the report.

*** This bug has been marked as a duplicate of bug 35371 ***
Comment 2 cmt28 2011-05-01 06:42:04 UTC
(In reply to comment #1)
> Ark currently has some problems with archives which have password-protected
> headers (rar and 7z). Most of these problems should be fixed in 4.7.0 (or
> 4.6.4, in case I'm able to fix what's still missing).
> 
> For now, I'm marking this as a duplicate of the bug tracking the password
> issues.
> 
> Thanks for the report.
> 
> *** This bug has been marked as a duplicate of bug 35371 ***

It's really since KDE 2.2.1?
That's a very old bug, almost 10 years and it's still not fixed.
Comment 3 Raphael Kubo da Costa 2011-05-01 06:51:49 UTC
Yes. Different major versions, sometimes a rewrite happens, maintainers change and bugs are reintroduced.