Bug 272074 - Impossible to set up two Yahoo accounts
Summary: Impossible to set up two Yahoo accounts
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.7
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 18:42 UTC by Christophe Giboudeaux
Modified: 2011-05-04 01:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Giboudeaux 2011-04-30 18:42:16 UTC
Using master, the issue is probably valid for other providers.

The DAV resources seems to store the login informations in a cookie, which limits its usage to one account for a given provider.

eg: I have two Yahoo accounts (different login/password). If one is configured, adding the other account will fail. The 'Test connection' will pass because the resource will use the already saved credentials and the 'Fetch' button will list calendars for the first account configured.
Comment 1 Grégory Oestreicher 2011-04-30 22:16:26 UTC
Git commit 2a657b59466ad2104f86ff3bc6bc429a2a1f55c5 by Gregory Oestreicher.
Committed on 30/04/2011 at 22:25.
Pushed by goestreicher into branch 'master'.

Do not store cookies for HTTP jobs

BUG: 272074

M  +1    -0    resources/dav/common/davcollectiondeletejob.cpp     
M  +1    -0    resources/dav/common/davitemcreatejob.cpp     
M  +1    -0    resources/dav/common/davitemdeletejob.cpp     
M  +1    -0    resources/dav/common/davitemfetchjob.cpp     
M  +1    -0    resources/dav/common/davitemmodifyjob.cpp     
M  +5    -1    resources/dav/common/davmanager.cpp     
M  +3    -3    resources/dav/common/davprincipalhomesetsfetchjob.cpp     

http://commits.kde.org/kdepim-runtime/2a657b59466ad2104f86ff3bc6bc429a2a1f55c5
Comment 2 Grégory Oestreicher 2011-05-04 01:35:20 UTC
Git commit 58619f1d207b20e013e6041a678ef31aaf64637a by Gregory Oestreicher.
Committed on 30/04/2011 at 22:25.
Pushed by goestreicher into branch '4.6'.

Do not store cookies for HTTP jobs

BUG: 272074

M  +1    -0    resources/dav/common/davcollectiondeletejob.cpp     
M  +1    -0    resources/dav/common/davitemcreatejob.cpp     
M  +1    -0    resources/dav/common/davitemdeletejob.cpp     
M  +1    -0    resources/dav/common/davitemfetchjob.cpp     
M  +1    -0    resources/dav/common/davitemmodifyjob.cpp     
M  +5    -1    resources/dav/common/davmanager.cpp     
M  +3    -3    resources/dav/common/davprincipalhomesetsfetchjob.cpp     

http://commits.kde.org/kdepim-runtime/58619f1d207b20e013e6041a678ef31aaf64637a