Bug 272053 - KWin hangs on [Alt-Tab] when FlipSwitch is selected as [Alt-Tab] effect.
Summary: KWin hangs on [Alt-Tab] when FlipSwitch is selected as [Alt-Tab] effect.
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Plasma
Component: effects-window-management (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 13:44 UTC by Barafu Albino Cheetah
Modified: 2011-04-30 14:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barafu Albino Cheetah 2011-04-30 13:44:17 UTC
Version:           unspecified (using KDE 4.6.2) 
OS:                Linux

When "Effect for windows switching" is set to be FlipSwitch, there is about a 1/3 chance that all KWin hangs up, blocking input. (The only way go is Ctrl-Alt-F1). Even if it didn't, there is the same chance to hang up when using Alt-Tab, pressing it briefly. However, no bugs occur when Alt-Tab is pressed and hoild to see the FlipSwitch animation. 


Reproducible: Always

Steps to Reproduce:
1) Go System Settings -> Desktop Effects. Set "Effect for window switching" to FlipSwitch. 
2)Open a few windows. Press and hold Alt-Tab. Everything works.
3)Press Alt-Tab momentarily several times. Everything hangs.

Actual Results:  
No way to recover found. Key combo that stops desktop effects don't work. Restart your X server. 

Expected Results:  
It seems that when Alt-Tab is pressed for a moment, the animation does not start, does it? Windows should just switch.

That didn't happen in previous versions of KDE on that machine. I have the latest nvidia prop drivers (270.41.06)
Comment 1 Thomas Lübking 2011-04-30 14:26:23 UTC
probably bug #261323 - please try to disable the window title display to confirm
Comment 2 Barafu Albino Cheetah 2011-04-30 14:42:54 UTC
Yes, it helps.
Comment 3 Thomas Lübking 2011-04-30 14:49:12 UTC

*** This bug has been marked as a duplicate of bug 261323 ***