Bug 271800 - amarok crash when open list "Various Artists" in Local collection
Summary: amarok crash when open list "Various Artists" in Local collection
Status: RESOLVED DUPLICATE of bug 263256
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.0
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-26 19:34 UTC by fedor
Modified: 2011-12-05 18:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (18.99 KB, text/plain)
2011-07-01 14:57 UTC, Mauro Ransolin
Details
New crash information added by DrKonqi (16.31 KB, text/plain)
2011-12-01 22:21 UTC, J
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fedor 2011-04-26 19:34:55 UTC
Application: amarok (2.4.0)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-2-amd64 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
Amarok crash when I open list "Various Artists" in Local collection.

The crash can be reproduced every time.

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe6d7857780 (LWP 3743))]

Thread 9 (Thread 0x7fe68c2c2700 (LWP 3747)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6be32a6d2 in ?? () from /usr/lib/libvlccore.so.4
#2  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fe68a752700 (LWP 3753)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6d4ad371b in wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe6d1f4c8f4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24459e0, th=0x2353990) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fe6d1f4ef83 in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x2353990) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fe6d1f4dd6f in ThreadWeaver::ThreadRunHelper::run (this=0x7fe68a751e10, parent=0x24459e0, th=0x2353990) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fe6d1f4ddf8 in ThreadWeaver::Thread::run (this=0x2353990) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fe6d4ad3035 in QThreadPrivate::start (arg=0x2353990) at thread/qthread_unix.cpp:320
#8  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fe679a2a700 (LWP 3754)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6d4ad371b in wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe6d1f4c8f4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24459e0, th=0x249e190) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fe6d1f4ef83 in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x249e190) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fe6d1f4ef9c in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x249e190) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fe6d1f4ef9c in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x249e190) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fe6d1f4dd6f in ThreadWeaver::ThreadRunHelper::run (this=0x7fe679a29e10, parent=0x24459e0, th=0x249e190) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007fe6d1f4ddf8 in ThreadWeaver::Thread::run (this=0x249e190) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007fe6d4ad3035 in QThreadPrivate::start (arg=0x249e190) at thread/qthread_unix.cpp:320
#10 0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fe679229700 (LWP 3755)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6d4ad371b in wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe6d1f4c8f4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24459e0, th=0x7fe684002440) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fe6d1f4ef83 in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x7fe684002440) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fe6d1f4ef9c in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x7fe684002440) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fe6d1f4dd6f in ThreadWeaver::ThreadRunHelper::run (this=0x7fe679228e10, parent=0x24459e0, th=0x7fe684002440) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007fe6d1f4ddf8 in ThreadWeaver::Thread::run (this=0x7fe684002440) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007fe6d4ad3035 in QThreadPrivate::start (arg=0x7fe684002440) at thread/qthread_unix.cpp:320
#9  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fe678a28700 (LWP 3756)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6d4ad371b in wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x235d370, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fe6d1f4c8f4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24459e0, th=0x2498d60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fe6d1f4ef83 in ThreadWeaver::WorkingHardState::applyForWork (this=0x243e1a0, th=0x2498d60) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fe6d1f4dd6f in ThreadWeaver::ThreadRunHelper::run (this=0x7fe678a27e10, parent=0x24459e0, th=0x2498d60) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fe6d1f4ddf8 in ThreadWeaver::Thread::run (this=0x2498d60) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fe6d4ad3035 in QThreadPrivate::start (arg=0x2498d60) at thread/qthread_unix.cpp:320
#8  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fe6779d1700 (LWP 3757)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6c9f42c24 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe675fb2700 (LWP 3758)):
#0  0x00007fe6d42908d3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fe6d4b9c27d in QProcessManager::run (this=0x7fe6d4ef27e0) at io/qprocess_unix.cpp:245
#2  0x00007fe6d4ad3035 in QThreadPrivate::start (arg=0x7fe6d4ef27e0) at thread/qthread_unix.cpp:320
#3  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe6757b1700 (LWP 3760)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe6d068d164 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fe6d09a70e0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fe6d068d199 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fe6d09b51b4) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fe6cfd898ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007fe6d429702d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe6d7857780 (LWP 3743)):
[KCrash Handler]
#5  0x00007fe6d686f35b in CoverFetchArtPayload::prepareLastFmUrls (this=0x1440bb0, xml=...) at ../../src/covermanager/CoverFetchUnit.cpp:601
#6  0x00007fe6d686fde1 in CoverFetchArtPayload::prepareUrls (this=0x1440bb0) at ../../src/covermanager/CoverFetchUnit.cpp:458
#7  0x00007fe6d6863dd9 in CoverFetchArtPayload::setXml (this=0x1440bb0, xml=<value optimized out>) at ../../src/covermanager/CoverFetchUnit.cpp:440
#8  0x00007fe6d68630ff in CoverFetchQueue::add (this=0x203bec0, album=..., opt=CoverFetch::Automatic, src=<value optimized out>, xml=...) at ../../src/covermanager/CoverFetchQueue.cpp:56
#9  0x00007fe6d685e2d3 in CoverFetcher::slotResult (this=0x203bf30, url=<value optimized out>, data=..., e=<value optimized out>) at ../../src/covermanager/CoverFetcher.cpp:202
#10 0x00007fe6d685ebfc in CoverFetcher::qt_metacall (this=0x203bf30, _c=<value optimized out>, _id=4, _a=0x7ffff86fe2b0) at ./CoverFetcher.moc:92
#11 0x00007fe6d4bc48af in QMetaMethod::invoke (this=0x7ffff86fe610, object=0x203bf30, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#12 0x00007fe6d6643960 in invoke (this=0x1fc34c0) at /usr/include/qt4/QtCore/qmetaobject.h:119
#13 NetworkAccessManagerProxy::NetworkAccessManagerProxyPrivate::_replyFinished (this=0x1fc34c0) at ../../src/network/NetworkAccessManagerProxy.cpp:98
#14 0x00007fe6d66423da in NetworkAccessManagerProxy::qt_metacall (this=0x1fc1b90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff86fe920) at ./NetworkAccessManagerProxy.moc:86
#15 0x00007fe6d4bd118f in QMetaObject::activate (sender=0x2c9ff80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#16 0x00007fe6d24ad1ab in KDEPrivate::AccessManagerReply::jobDone (this=0x2c9ff80, kJob=<value optimized out>) at ../../kio/kio/accessmanagerreply_p.cpp:233
#17 0x00007fe6d24adb53 in KDEPrivate::AccessManagerReply::qt_metacall (this=0x2c9ff80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff86fede0) at ./accessmanagerreply_p.moc:83
#18 0x00007fe6d4bd118f in QMetaObject::activate (sender=0x2c9ffa0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff86fede0) at kernel/qobject.cpp:3278
#19 0x00007fe6d4ff4fa2 in KJob::result (this=<value optimized out>, _t1=0x2c9ffa0) at ./kjob.moc:194
#20 0x00007fe6d4ff4fe0 in KJob::emitResult (this=0x2c9ffa0) at ../../kdecore/jobs/kjob.cpp:312
#21 0x00007fe6d24e3dad in KIO::SimpleJob::slotFinished (this=0x2c9ffa0) at ../../kio/kio/job.cpp:517
#22 0x00007fe6d24e9247 in KIO::TransferJob::slotFinished (this=0x2c9ffa0) at ../../kio/kio/job.cpp:1097
#23 0x00007fe6d24ed9a1 in KIO::TransferJob::qt_metacall (this=0x2c9ffa0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff86ff200) at ./jobclasses.moc:367
#24 0x00007fe6d4bd118f in QMetaObject::activate (sender=0x1f414f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#25 0x00007fe6d25a2121 in KIO::SlaveInterface::dispatch (this=<value optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#26 0x00007fe6d259f373 in KIO::SlaveInterface::dispatch (this=<value optimized out>) at ../../kio/kio/slaveinterface.cpp:91
#27 0x00007fe6d2592cc6 in KIO::Slave::gotInput (this=0x1f414f0) at ../../kio/kio/slave.cpp:324
#28 0x00007fe6d25932dc in KIO::Slave::qt_metacall (this=0x1f414f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff86ff600) at ./slave.moc:82
#29 0x00007fe6d4bd118f in QMetaObject::activate (sender=0x1f28340, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#30 0x00007fe6d24b6687 in KIO::ConnectionPrivate::dequeue (this=0x24c9e80) at ../../kio/kio/connection.cpp:82
#31 0x00007fe6d24b673d in KIO::Connection::qt_metacall (this=0x1f28340, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2c9f4a0) at ./connection.moc:79
#32 0x00007fe6d4bcffea in QObject::event (this=0x1f28340, e=<value optimized out>) at kernel/qobject.cpp:1217
#33 0x00007fe6d557bd14 in QApplicationPrivate::notify_helper (this=0x133d930, receiver=0x1f28340, e=0x2c215f0) at kernel/qapplication.cpp:4462
#34 0x00007fe6d55808da in QApplication::notify (this=<value optimized out>, receiver=0x1f28340, e=0x2c215f0) at kernel/qapplication.cpp:4341
#35 0x00007fe6d728bbd6 in KApplication::notify (this=0x7ffff87000a0, receiver=0x1f28340, event=0x2c215f0) at ../../kdeui/kernel/kapplication.cpp:302
#36 0x00007fe6d4bbbc8c in QCoreApplication::notifyInternal (this=0x7ffff87000a0, receiver=0x1f28340, event=0x2c215f0) at kernel/qcoreapplication.cpp:731
#37 0x00007fe6d4bbf4b5 in sendEvent (receiver=0x0, event_type=0, data=0x11e0c70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11e0c70) at kernel/qcoreapplication.cpp:1372
#39 0x00007fe6d4be6bf3 in sendPostedEvents (s=0x133a1c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#40 postEventSourceDispatch (s=0x133a1c0) at kernel/qeventdispatcher_glib.cpp:277
#41 0x00007fe6cda0d4a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x00007fe6cda0dc80 in ?? () from /lib/libglib-2.0.so.0
#43 0x00007fe6cda0df1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x00007fe6d4be6d8f in QEventDispatcherGlib::processEvents (this=0x11e0870, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#45 0x00007fe6d56224de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007fe6d4bbb022 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007fe6d4bbb26c in QEventLoop::exec (this=0x7ffff8700030, flags=...) at kernel/qeventloop.cpp:201
#48 0x00007fe6d4bbf76b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#49 0x00000000004096c5 in main (argc=1, argv=0x7ffff8702518) at ../../src/main.cpp:268

Possible duplicates by query: bug 271723, bug 271562, bug 270285, bug 269854, bug 269472.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-04-27 11:27:40 UTC

*** This bug has been marked as a duplicate of bug 263256 ***
Comment 2 Mauro Ransolin 2011-07-01 14:57:21 UTC
Created attachment 61532 [details]
New crash information added by DrKonqi

amarok (2.4.0) on KDE Platform 4.5.5 (KDE 4.5.5) using Qt 4.7.0

- What I was doing when the application crashed:

- Add new files to the collection folder
- Open Amarok from status bar
- Click on Various Artists to open it
CRASH!

-- Backtrace (Reduced):
#7  0x014de5b8 in CoverFetchArtPayload::prepareLastFmUrls (this=0xa83cf08, xml=...) at ../../src/covermanager/CoverFetchUnit.cpp:601
#8  0x014e3e18 in CoverFetchArtPayload::prepareUrls (this=0xa83cf08) at ../../src/covermanager/CoverFetchUnit.cpp:458
#9  0x014d9a7e in CoverFetchArtPayload::setXml (this=0xa83cf08, xml=...) at ../../src/covermanager/CoverFetchUnit.cpp:440
#10 0x014d8632 in CoverFetchQueue::add (this=0xa0cccf8, album=..., opt=CoverFetch::Automatic, src=CoverFetch::LastFm, xml=...) at ../../src/covermanager/CoverFetchQueue.cpp:56
#11 0x014d3197 in CoverFetcher::slotResult (this=0xa0ce208, url=..., data=..., e=...) at ../../src/covermanager/CoverFetcher.cpp:202
Comment 3 J 2011-12-01 22:21:14 UTC
Created attachment 66284 [details]
New crash information added by DrKonqi

amarok (2.4.0) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed:
Opened AMarok.  Clicked on "Various Artists"  -- Crash.  Can click on other artists ok.

-- Backtrace (Reduced):
#6  0x00007f196c85c54a in CoverFetchArtPayload::prepareLastFmUrls (this=0x315c6a0, xml=...) at ../../src/covermanager/CoverFetchUnit.cpp:601
#7  0x00007f196c85d0d3 in CoverFetchArtPayload::prepareUrls (this=0x315c6a0) at ../../src/covermanager/CoverFetchUnit.cpp:458
#8  0x00007f196c851158 in CoverFetchArtPayload::setXml (this=0x315c6a0, xml=<value optimized out>) at ../../src/covermanager/CoverFetchUnit.cpp:440
#9  0x00007f196c850437 in CoverFetchQueue::add (this=0x282d6f0, album=..., opt=CoverFetch::Automatic, src=<value optimized out>, xml=...) at ../../src/covermanager/CoverFetchQueue.cpp:56
#10 0x00007f196c84b490 in CoverFetcher::slotResult (this=0x25d66a0, url=<value optimized out>, data=..., e=<value optimized out>) at ../../src/covermanager/CoverFetcher.cpp:202
Comment 4 Myriam Schweingruber 2011-12-05 18:01:42 UTC
This is already fixed in Amarok 2.4.1, please upgrade.