Bug 271720 - Incompatible HTTP_ACCEPT, HTTP_ACCEPT_CHARSET, HTTP_ACCEPT_ENCODING headers
Summary: Incompatible HTTP_ACCEPT, HTTP_ACCEPT_CHARSET, HTTP_ACCEPT_ENCODING headers
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 23:09 UTC by b4367450
Modified: 2011-08-09 14:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b4367450 2011-04-25 23:09:53 UTC
Version:           4.6.0 (using KDE 4.6.2) 
OS:                Linux

I recently came across changes nicely written up here:

http://my.opera.com/community/forums/topic.dml?id=971852

In summary:
1) Remove the "compatible" and "(like Gecko)" flags from Konqueror's User Agent.

2) Change HTTP_ACCEPT header to:
text/html, application/xhtml+xml, application/xml;q=0.9, */*;q=0.8

3) Remove "x-gzip, x-deflate" from HTTP_ACCEPT_ENCODING header.

4) Fix HTTP_ACCEPT_CHARSET by removing duplicate "utf-8" flags.

Reproducible: Always

Steps to Reproduce:
Check HTTP headers on for example:

http://browserspy.dk/headers.php

Actual Results:  
See above

Expected Results:  
See above
Comment 1 Dawit Alemayehu 2011-05-20 04:36:57 UTC
Git commit e2d70d6c478c1f82f065ed548b27d67014fd4311 by Dawit Alemayehu.
Committed on 11/05/2011 at 17:32.
Pushed by adawit into branch 'master'.

Changed the default user-agent string so that it is more aligned with other
browsers by:

    - dropping the 'comptiable' and 'U' from the string.
    - making the platform string (e.g. X11) mandatory.
    - sending the OS and machine type by default, e.g. Linux i686.

Besides being good for privacy (less differentiation), this change should make
it less likely that a different page will be sent to KDE based browsers.

CCBUG: 271720
REVIEW: 101337

M  +1    -1    kio/kio/http_slave_defaults.h     
M  +85   -58   kio/kio/kprotocolmanager.cpp     

http://commits.kde.org/kdelibs/e2d70d6c478c1f82f065ed548b27d67014fd4311
Comment 2 Dawit Alemayehu 2011-05-30 00:27:39 UTC
We won't do #2 and #3 to ensure proper functionality, especially #2 since khtml does not support XML and its XHTML support is so and so as discussion. #3 does not make sense. Why does removing the x-* versions from the header buy us ? Keeping them there most definitely buy us compatiablity with older servers. As such, those two changes will not be made.