Bug 271479 - KWalletManager needs setting for deep locked entries
Summary: KWalletManager needs setting for deep locked entries
Status: RESOLVED DUPLICATE of bug 147873
Alias: None
Product: kwalletmanager
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-22 12:41 UTC by gem
Modified: 2011-05-02 20:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gem 2011-04-22 12:41:06 UTC
Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

I was using pwmanager back in the days of KDE3 (sadly it's outdated now). By switching to KDE4 I also switched to kwallet. Today I realized that KWalletManager is missing a feature that feels crucial to me: Deep locking entries.

I have to admit that I only have one wallet, the kwallet. But please consider me not the only kubuntu-user acting like that. At the time I opened KWalletManager the kwallet was open. So I was just prompted the usual "The application x has requested access to the open wallet y". Since the wallet is open I don't have to do anything else but grant access and there you go, having access to all entries.

I would suggest to add a Deep Lock Setting. Each and every entry is encrypted and not shown in cleartext until I definetely ask for it. As soon as I do, I'll be prompted for the password of the open wallet _again_, even though the wallet is open.

Reproducible: Always

Steps to Reproduce:
open a wallet
open KWalletManager
grant KWalletManager access to the open wallet
find an entry and look at the password

Actual Results:  
password is shown cleartext

Expected Results:  
Consider the following an optional setting of KWalletManager, called something like "Deep lock all entries":

*) password is not shown cleartext
*) only applications should have access to entries of open wallets, not users
*) users should be prompted for the open wallet's password for access to single entries
Comment 1 Christoph Feck 2011-05-02 20:44:15 UTC

*** This bug has been marked as a duplicate of bug 147873 ***