Bug 271430 - Map display is blurred for OpenStreetMap and other raster maps
Summary: Map display is blurred for OpenStreetMap and other raster maps
Status: RESOLVED DUPLICATE of bug 199259
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-21 16:31 UTC by Milko Krachounov
Modified: 2011-04-24 22:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milko Krachounov 2011-04-21 16:31:12 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

For OpenStreetMap, Marble downloads raster images of the maps that are offered by the OSM server (probably those that are closest to the level of zoom of Marble), and then has to resize them to fit the actual zoom level. This means that the map image is blurred and ugly and in the latest version the readability can also suffer for some zoom levels.

The maps provided by the OSM server are rendered wonderfully by Mapnik, but the postprocessing done by Marble destroys them.

This is true for all raster map sources, such as OpenStreetMap and Osmarender. It doesn't affect maps such as the atlas, the natural earth one, or the maps of Mars, Venus and the Moon. 

It would be very nice if Marble could provide exact zooms for those maps (perhaps through a new projection mode?) so that they are not resized, or could render the maps itself with the right projection, or could otherwise make them sharp and comparable to those on OSM's website.

Reproducible: Always
Comment 1 Dennis Nienhüser 2011-04-24 22:18:29 UTC

*** This bug has been marked as a duplicate of bug 199259 ***