Bug 271366 - Dolphin crash when opening SMB share subfolder hosted on 11.1 opensuse
Summary: Dolphin crash when opening SMB share subfolder hosted on 11.1 opensuse
Status: RESOLVED DUPLICATE of bug 265945
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 18:14 UTC by nickjon
Modified: 2011-10-17 04:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.94 KB, text/plain)
2011-04-28 14:21 UTC, Sergiu Bivol
Details
New crash information added by DrKonqi (7.53 KB, text/plain)
2011-10-17 04:47 UTC, Don Robertson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nickjon 2011-04-20 18:14:49 UTC
Application: dolphin (1.6)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I open the share, authenticate, and can open the top level folder and see the subfolders.  Upon opening a subfolder, Dolphin crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4762892760 (LWP 7333))]

Thread 2 (Thread 0x7f474980f700 (LWP 7335)):
#0  0x00007f475d0a9275 in clock_gettime () from /lib64/librt.so.1
#1  0x00007f47614b62b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00007f476157933d in QTimerInfoList::updateCurrentTime (this=0x7f1d90) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00007f47615796b5 in QTimerInfoList::timerWait (this=0x7f1d90, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00007f476157817c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f474980ec4c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f4761578225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f475cdf8087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#8  0x00007f475cdf8fa9 in ?? () from /lib64/libglib-2.0.so.0
#9  0x00007f475cdf9650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00007f4761578976 in QEventDispatcherGlib::processEvents (this=0x899400, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00007f476154d052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f476154d265 in QEventLoop::exec (this=0x7f474980ede0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00007f47614621e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#14 0x00007f476152e968 in QInotifyFileSystemWatcherEngine::run (this=0x870bf0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00007f4761464a5e in QThreadPrivate::start (arg=0x870bf0) at thread/qthread_unix.cpp:285
#16 0x00007f47611d5a3f in start_thread () from /lib64/libpthread.so.0
#17 0x00007f475ff9067d in clone () from /lib64/libc.so.6
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4762892760 (LWP 7333)):
[KCrash Handler]
#6  0x00007f47602265d8 in main_arena () from /lib64/libc.so.6
#7  0x00007f4760c010c4 in QAbstractItemViewPrivate::viewOptionsV4 (this=0xb10490) at itemviews/qabstractitemview.cpp:3483
#8  0x00007f4760c05938 in QAbstractItemView::mouseReleaseEvent (this=0xb05960, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1792
#9  0x00007f474f9adc74 in DolphinTreeView::mouseReleaseEvent (this=0xb05960, event=0x7fff68981b20) at /usr/src/debug/kdebase-4.6.0/apps/dolphin/src/views/dolphintreeview.cpp:165
#10 0x00007f476074e538 in QWidget::event (this=0xb05960, event=0x7fff68981b20) at kernel/qwidget.cpp:8200
#11 0x00007f4760af2906 in QFrame::event (this=0xb05960, e=0x7fff68981b20) at widgets/qframe.cpp:557
#12 0x00007f4760c02c23 in QAbstractItemView::viewportEvent (this=0xb05960, event=0x7fff68981b20) at itemviews/qabstractitemview.cpp:1619
#13 0x00007f4760c47a85 in QTreeView::viewportEvent (this=0xb05960, event=0x7fff68981b20) at itemviews/qtreeview.cpp:1256
#14 0x00007f476154dd87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x9ab130, event=0x7fff68981b20) at kernel/qcoreapplication.cpp:847
#15 0x00007f47606fcce1 in QApplicationPrivate::notify_helper (this=0x6ba670, receiver=0x9ab130, e=0x7fff68981b20) at kernel/qapplication.cpp:4441
#16 0x00007f4760705aac in QApplication::notify (this=<value optimized out>, receiver=0x9ab130, e=0x7fff68981b20) at kernel/qapplication.cpp:4006
#17 0x00007f47621f19e6 in KApplication::notify (this=0x7fff68982860, receiver=0x9ab130, event=0x7fff68981b20) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#18 0x00007f476154dbfc in QCoreApplication::notifyInternal (this=0x7fff68982860, receiver=0x9ab130, event=0x7fff68981b20) at kernel/qcoreapplication.cpp:732
#19 0x00007f47606fdd25 in sendEvent (receiver=0x9ab130, event=0x7fff68981b20, alienWidget=0x9ab130, nativeWidget=0x77d340, buttonDown=0x7f47611cc178, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#20 QApplicationPrivate::sendMouseEvent (receiver=0x9ab130, event=0x7fff68981b20, alienWidget=0x9ab130, nativeWidget=0x77d340, buttonDown=0x7f47611cc178, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#21 0x00007f476077be08 in QETWidget::translateMouseEvent (this=0x77d340, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#22 0x00007f476077a4c9 in QApplication::x11ProcessEvent (this=0x7fff68982860, event=0x7fff68982480) at kernel/qapplication_x11.cpp:3564
#23 0x00007f47607a20f2 in x11EventSourceDispatch (s=0x6be0c0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#24 0x00007f475cdf8bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#25 0x00007f475cdf93b0 in ?? () from /lib64/libglib-2.0.so.0
#26 0x00007f475cdf9650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#27 0x00007f476157891f in QEventDispatcherGlib::processEvents (this=0x6b9eb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007f47607a1d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f476154d052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f476154d265 in QEventLoop::exec (this=0x7fff689827a0, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007f47615516ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#32 0x00007f4750341ad5 in kdemain (argc=5, argv=0x6985e0) at /usr/src/debug/kdebase-4.6.0/apps/dolphin/src/main.cpp:98
#33 0x00000000004075e9 in _start ()

Possible duplicates by query: bug 268488, bug 265945.

Reported using DrKonqi
Comment 1 Peter Penz 2011-04-20 18:33:29 UTC

*** This bug has been marked as a duplicate of bug 265945 ***
Comment 2 Sergiu Bivol 2011-04-28 14:21:58 UTC
Created attachment 59391 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
Browsing a SAMBA share hosted on an Ubuntu Server box.
Dolphin was in Column view. Switching to Icons view, opening the share, then switching back to Column view avoids the crash.

-- Backtrace (Reduced):
#7  0x00007fb564e031ef in QAbstractItemViewPrivate::viewOptionsV4 (this=<value optimized out>) at itemviews/qabstractitemview.cpp:3492
#8  0x00007fb564e07efd in QAbstractItemView::mouseReleaseEvent (this=0x29a1780, event=0x7fff9a1c0a20) at itemviews/qabstractitemview.cpp:1801
#9  0x00007fb566e5c78c in DolphinTreeView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libdolphinprivate.so.4
#10 0x00007fb564943cb8 in QWidget::event (this=0x29a1780, event=0x7fff9a1c0a20) at kernel/qwidget.cpp:8259
#11 0x00007fb564cf3a66 in QFrame::event (this=0x29a1780, e=0x7fff9a1c0a20) at widgets/qframe.cpp:557
Comment 3 Don Robertson 2011-10-17 04:47:35 UTC
Created attachment 64619 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed:

Brows samba share hosted on Ubuntu based server. Log into share. Open directory in share, Dolphin crashes. No attempt to open a zip file made.

Cannot reproduce in Konqueror.

-- Backtrace (Reduced):
#6  0x00007f4dc21ca8d9 in QAbstractItemViewPrivate::viewOptionsV4 (this=<value optimized out>) at itemviews/qabstractitemview.cpp:3492
#7  0x00007f4dc21cf5ed in QAbstractItemView::mouseReleaseEvent (this=0x20b2cd0, event=0x7fffb2470840) at itemviews/qabstractitemview.cpp:1801
#8  0x00007f4dc4227bac in DolphinTreeView::mouseReleaseEvent (this=0x20b2cd0, event=0x7fffb2470840) at ../../../dolphin/src/views/dolphintreeview.cpp:165
#9  0x00007f4dc1d08cc8 in QWidget::event (this=0x20b2cd0, event=0x7fffb2470840) at kernel/qwidget.cpp:8259
#10 0x00007f4dc20bb156 in QFrame::event (this=0x20b2cd0, e=0x7fffb2470840) at widgets/qframe.cpp:557