Bug 271268 - Drag&Drop from Ark to FolderView does not work
Summary: Drag&Drop from Ark to FolderView does not work
Status: RESOLVED DUPLICATE of bug 189322
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: 2.15
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-19 06:28 UTC by Jakub Schmidtke
Modified: 2011-05-01 20:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Schmidtke 2011-04-19 06:28:07 UTC
Version:           2.15 (using KDE 4.6.2) 
OS:                Linux

It is not possible to drop an item dragged from Ark's window onto FolderView window (showing the desktop folder).
There is a bug for that (189322) and it is marked as solved,
but it does not work in KDE 4.6.2 (and Ark 2.16, but it was not on the list of available versions in kde's bug system).


Reproducible: Always




OS: Linux (x86_64) release 2.6.38-ARCH
Compiler: gcc
Comment 1 Raphael Kubo da Costa 2011-05-01 05:48:30 UTC
What happens when you try to drag a file from Ark to folderview?

I've just tested it here with trunk and got the same results I described in comment 3 in bug 189322.
Comment 2 Jakub Schmidtke 2011-05-01 07:33:21 UTC
OK, I tested it and I got the behaviour you described, but only with zip files.
Dealing with rar files still doesn't work. What's interesting is that drag&drop from rar files work with regular dolphin windows, but not the folderview. Dragging from zip files (I'm not sure what other formats, tried only zip and rar) works with both folderview and dolphin windows.
Comment 3 Jakub Schmidtke 2011-05-01 07:38:53 UTC
I have also tried some other formats, and it doesn't work with 7zip and tar+bzip2. It works with tar+gzip, but only if the file created has '.tar.gz' extension. When it's '.tgz' it doesn't work anymore. The uncompressed '.tar' works as well. Also, when I create the file with tar+bzip2, but with '.tar.gz' extension it works.
Comment 4 Raphael Kubo da Costa 2011-05-01 20:52:46 UTC
Indeed, I was able to reproduce the issue here. I'll mark this report as a duplicate and reopen the other one.

*** This bug has been marked as a duplicate of bug 189322 ***