Bug 271012 - Floating point exception in plasma desktop shell when adding google widget
Summary: Floating point exception in plasma desktop shell when adding google widget
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 08:26 UTC by Johan Persson
Modified: 2011-04-20 02:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Persson 2011-04-15 08:26:16 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
Click "Add Widget"
Click "Get new widgets"->"Install widget from local file"
Select "google widget"
Previously I had downloaded the official Google calendar widget. WHen clicking on that widget file to install Plasma Desktop Shell crashed.

This is repeatable for me.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb59b4710 (LWP 30273))]

Thread 2 (Thread 0xa867cb70 (LWP 30280)):
#0  0xb5cd222b in clock_gettime () from /lib/librt.so.1
#1  0xb6ecaae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6f9d726 in updateCurrentTime (this=0xa9000afc, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xa9000afc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6f9bf6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa867c06c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6f9c00d in timerSourcePrepare (source=0xa9000ac8, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5c1ca70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5c1d8e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5c1dfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6f9c7b7 in QEventDispatcherGlib::processEvents (this=0x87c8b80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6f6d2bd in QEventLoop::processEvents (this=0xa867c200, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6f6d4e9 in QEventLoop::exec (this=0xa867c200, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6e6e7b9 in QThread::exec (this=0x87c8e88) at thread/qthread.cpp:490
#14 0xb6f4d23d in QInotifyFileSystemWatcherEngine::run (this=0x87c8e88) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6e713aa in QThreadPrivate::start (arg=0x87c8e88) at thread/qthread_unix.cpp:285
#16 0xb2ec2de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#17 0xb61b2d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb59b4710 (LWP 30273)):
[KCrash Handler]
#7  0xb78d515a in enter.8105 () from /lib/ld-linux.so.2
#8  0xb78d57c1 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb78d5b99 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb78d74ab in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb78de8e3 in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb78da5ff in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb78de3a6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5d3abdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb78da5ff in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5d3b342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5d3aca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6f5e194 in QLibraryPrivate::load_sys (this=0x896f8d0) at plugin/qlibrary_unix.cpp:205
#19 0xb6f58cf4 in QLibraryPrivate::load (this=0x896f8d0) at plugin/qlibrary.cpp:446
#20 0xb6f58dd8 in QLibraryPrivate::loadPlugin (this=0x896f8d0) at plugin/qlibrary.cpp:478
#21 0xb6f52c53 in QPluginLoader::load (this=0xbff972d4) at plugin/qpluginloader.cpp:227
#22 0xb7245668 in KPluginLoader::load() () from /usr/lib/libkdecore.so.5
#23 0xb7245aaf in KPluginLoader::factory() () from /usr/lib/libkdecore.so.5
#24 0xb0e3fcf9 in createInstance<Plasma::PackageStructure> (this=0x90f2e40) at /usr/include/kservice.h:555
#25 createInstance<Plasma::PackageStructure> (this=0x90f2e40) at /usr/include/kservice.h:534
#26 Plasma::OpenWidgetAssistant::finished (this=0x90f2e40) at /usr/src/debug/kdebase-workspace-4.6.0/libs/plasmagenericshell/widgetsexplorer/openwidgetassistant.cpp:170
#27 0xb0e41ccc in Plasma::OpenWidgetAssistant::qt_metacall (this=0x90f2e40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff974ac) at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/plasmagenericshell/openwidgetassistant_p.moc:80
#28 0xb6f748cd in QMetaObject::metacall (object=0x90f2e40, cl=QMetaObject::InvokeMetaMethod, idx=79, argv=0xbff974ac) at kernel/qmetaobject.cpp:237
#29 0xb6f84a2c in QMetaObject::activate (sender=0x8a22378, m=0xb0de7ea0, local_signal_index=6, argv=0x0) at kernel/qobject.cpp:3272
#30 0xb0d83cd5 in KFileWidget::accepted (this=0x8a22378) at /usr/src/debug/kdelibs-4.6.0/build/kfile/kfilewidget.moc:206
#31 0xb0da3414 in KFileWidget::slotOk (this=0x8a22378) at /usr/src/debug/kdelibs-4.6.0/kfile/kfilewidget.cpp:996
#32 0xb0da6318 in KFileWidgetPrivate::_k_fileSelected (this=0x8c1f400, i=...) at /usr/src/debug/kdelibs-4.6.0/kfile/kfilewidget.cpp:1105
#33 0xb0dc0a70 in KFileWidget::qt_metacall (this=0x8a22378, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbff97818) at /usr/src/debug/kdelibs-4.6.0/build/kfile/kfilewidget.moc:143
#34 0xb6f748cd in QMetaObject::metacall (object=0x8a22378, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbff97818) at kernel/qmetaobject.cpp:237
#35 0xb6f84a2c in QMetaObject::activate (sender=0x8b9dad0, m=0xb0de7e40, local_signal_index=7, argv=0xbff97818) at kernel/qobject.cpp:3272
#36 0xb0d7c445 in KDirOperator::fileSelected (this=0x8b9dad0, _t1=...) at /usr/src/debug/kdelibs-4.6.0/build/kfile/kdiroperator.moc:321
#37 0xb0d7c478 in KDirOperator::selectFile (this=0x8b9dad0, item=...) at /usr/src/debug/kdelibs-4.6.0/kfile/kdiroperator.cpp:1709
#38 0xb0d7c54e in KDirOperator::Private::_k_slotActivated (this=0x8ebc9a0, index=...) at /usr/src/debug/kdelibs-4.6.0/kfile/kdiroperator.cpp:2364
#39 0xb0dbc0d3 in KDirOperator::qt_metacall (this=0x8b9dad0, _c=QMetaObject::InvokeMetaMethod, _id=59, _a=0xbff979a8) at /usr/src/debug/kdelibs-4.6.0/build/kfile/kdiroperator.moc:250
#40 0xb6f748cd in QMetaObject::metacall (object=0x8b9dad0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff979a8) at kernel/qmetaobject.cpp:237
#41 0xb6f84a2c in QMetaObject::activate (sender=0x8feb608, m=0xb6ddd204, local_signal_index=3, argv=0xbff979a8) at kernel/qobject.cpp:3272
#42 0xb6a1c3f5 in QAbstractItemView::activated (this=0x8feb608, _t1=...) at .moc/release-shared/moc_qabstractitemview.cpp:345
#43 0xb6a1c93c in QAbstractItemView::mouseReleaseEvent (this=0x8feb608, event=0xbff98364) at itemviews/qabstractitemview.cpp:1796
#44 0xb6a3a161 in QListView::mouseReleaseEvent (this=0x8feb608, e=0xbff98364) at itemviews/qlistview.cpp:796
#45 0xb64d55b0 in QWidget::event (this=0x8feb608, event=0xbff98364) at kernel/qwidget.cpp:8200
#46 0xb68e3ed5 in QFrame::event (this=0x8feb608, e=0xbff98364) at widgets/qframe.cpp:557
#47 0xb69758a1 in QAbstractScrollArea::viewportEvent (this=0x8feb608, e=0xbff98364) at widgets/qabstractscrollarea.cpp:1043
#48 0xb6a19ad4 in QAbstractItemView::viewportEvent (this=0x8feb608, event=0xbff98364) at itemviews/qabstractitemview.cpp:1619
#49 0xb6978196 in viewportEvent (this=0x83bddb0, o=0x9058060, e=0xbff98364) at widgets/qabstractscrollarea_p.h:100
#50 QAbstractScrollAreaFilter::eventFilter (this=0x83bddb0, o=0x9058060, e=0xbff98364) at widgets/qabstractscrollarea_p.h:116
#51 0xb6f6e176 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8104688, receiver=0x9058060, event=0xbff98364) at kernel/qcoreapplication.cpp:847
#52 0xb647a3e4 in QApplicationPrivate::notify_helper (this=0x8104688, receiver=0x9058060, e=0xbff98364) at kernel/qapplication.cpp:4441
#53 0xb6483c20 in QApplication::notify (this=0xbff9807c, receiver=0x9058060, e=0xbff98364) at kernel/qapplication.cpp:4006
#54 0xb75c81f1 in KApplication::notify (this=0x80fda90, receiver=0x9058060, event=0xbff98364) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#55 0xb6f6dfde in QCoreApplication::notifyInternal (this=0x80fda90, receiver=0x9058060, event=0xbff98364) at kernel/qcoreapplication.cpp:732
#56 0xb647b45c in sendSpontaneousEvent (receiver=0x9058060, event=0xbff98364, alienWidget=0x9058060, nativeWidget=0x90f2e40, buttonDown=0xb6decc00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#57 QApplicationPrivate::sendMouseEvent (receiver=0x9058060, event=0xbff98364, alienWidget=0x9058060, nativeWidget=0x90f2e40, buttonDown=0xb6decc00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#58 0xb6507030 in QETWidget::translateMouseEvent (this=0x90f2e40, event=0xbff9887c) at kernel/qapplication_x11.cpp:4438
#59 0xb650613e in QApplication::x11ProcessEvent (this=0x80fda90, event=0xbff9887c) at kernel/qapplication_x11.cpp:3442
#60 0xb6530960 in x11EventSourceDispatch (s=0x8105570, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#61 0xb5c1d509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#62 0xb5c1dd10 in ?? () from /lib/libglib-2.0.so.0
#63 0xb5c1dfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#64 0xb6f9c76b in QEventDispatcherGlib::processEvents (this=0x80ed9a8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#65 0xb653055a in QGuiEventDispatcherGlib::processEvents (this=0x80ed9a8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#66 0xb6f6d2bd in QEventLoop::processEvents (this=0xbff98b34, flags=...) at kernel/qeventloop.cpp:149
#67 0xb6f6d4e9 in QEventLoop::exec (this=0xbff98b34, flags=...) at kernel/qeventloop.cpp:201
#68 0xb6f71f90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#69 0xb6478104 in QApplication::exec () at kernel/qapplication.cpp:3719
#70 0xb0f258aa in kdemain (argc=1, argv=0x80e0bf0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#71 0x0804e531 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2011-04-20 02:02:58 UTC

*** This bug has been marked as a duplicate of bug 251719 ***