Bug 270917 - Fails at KDE start
Summary: Fails at KDE start
Status: RESOLVED DUPLICATE of bug 253795
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 07:29 UTC by abenson
Modified: 2011-12-10 04:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abenson 2011-04-14 07:29:39 UTC
Application: krunner (0.1)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.11-83.fc14.i686.PAE i686
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed: Starting KDE - plasma won't start and everything crashes. Happens every time.

-- Backtrace:
Application: Run Command Interface (krunner), signal: Bus error
[KCrash Handler]
#7  clearInternalTables (this=0x43f97000, index=5903) at /usr/src/debug/kdelibs-4.6.1/kdecore/util/kshareddatacache.cpp:439
#8  SharedMemory::removeEntry (this=0x43f97000, index=5903) at /usr/src/debug/kdelibs-4.6.1/kdecore/util/kshareddatacache.cpp:1257
#9  0x041633ab in KSharedDataCache::insert (this=0x9856e78, key=..., data=...) at /usr/src/debug/kdelibs-4.6.1/kdecore/util/kshareddatacache.cpp:1367
#10 0x41a47a03 in KImageCache::insertImage (this=0x9856e78, key=..., image=...) at /usr/src/debug/kdelibs-4.6.1/kdeui/util/kimagecache.cpp:103
#11 0x41a47e49 in KImageCache::insertPixmap (this=0x9856e78, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.6.1/kdeui/util/kimagecache.cpp:119
#12 0x04e5158f in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x98491b0) at /usr/src/debug/kdelibs-4.6.1/plasma/theme.cpp:302
#13 0x04e54dc4 in Plasma::Theme::qt_metacall (this=0x9825670, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfa24afc) at /usr/src/debug/kdelibs-4.6.1/i686-redhat-linux-gnu/plasma/theme.moc:119
#14 0x03ad0beb in QMetaObject::metacall (object=0x9825670, cl=QMetaObject::InvokeMetaMethod, idx=9, argv=0xbfa24afc) at kernel/qmetaobject.cpp:237
#15 0x03ae00c7 in QMetaObject::activate (sender=0x985fc10, m=0x3c06ac4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3272
#16 0x03b2e828 in QTimer::timeout (this=0x985fc10) at .moc/release-shared/moc_qtimer.cpp:134
#17 0x03ae6d1e in QTimer::timerEvent (this=0x985fc10, e=0xbfa2502c) at kernel/qtimer.cpp:271
#18 0x03adfa24 in QObject::event (this=0x985fc10, e=0xbfa2502c) at kernel/qobject.cpp:1175
#19 0x021ee26c in QApplicationPrivate::notify_helper (this=0x978bf30, receiver=0x985fc10, e=0xbfa2502c) at kernel/qapplication.cpp:4445
#20 0x021f2ed2 in QApplication::notify (this=0x9783b48, receiver=0x985fc10, e=0xbfa2502c) at kernel/qapplication.cpp:3845
#21 0x419d292b in KApplication::notify (this=0x9783b48, receiver=0x985fc10, event=0xbfa2502c) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#22 0x03aca3b3 in QCoreApplication::notifyInternal (this=0x9783b48, receiver=0x985fc10, event=0xbfa2502c) at kernel/qcoreapplication.cpp:732
#23 0x03afad31 in sendEvent (this=0x978e8c4) at kernel/qcoreapplication.h:215
#24 QTimerInfoList::activateTimers (this=0x978e8c4) at kernel/qeventdispatcher_unix.cpp:603
#25 0x03af7945 in timerSourceDispatch (source=0x978e890) at kernel/qeventdispatcher_glib.cpp:184
#26 0x00981192 in g_main_dispatch (context=0x978d710) at gmain.c:2149
#27 g_main_context_dispatch (context=0x978d710) at gmain.c:2702
#28 0x00981978 in g_main_context_iterate (context=0x978d710, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#29 0x00981c35 in g_main_context_iteration (context=0x978d710, may_block=1) at gmain.c:2843
#30 0x03af80ad in QEventDispatcherGlib::processEvents (this=0x9766a08, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#31 0x022a1406 in QGuiEventDispatcherGlib::processEvents (this=0x9766a08, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#32 0x03ac954a in QEventLoop::processEvents (this=0xbfa252d4, flags=...) at kernel/qeventloop.cpp:149
#33 0x03ac97fa in QEventLoop::exec (this=0xbfa252d4, flags=...) at kernel/qeventloop.cpp:201
#34 0x03ace3a7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#35 0x021ec078 in QApplication::exec () at kernel/qapplication.cpp:3719
#36 0x02ce4919 in kdemain () from /usr/lib/libkdeinit4_krunner.so
#37 0x0804878c in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-14 12:42:31 UTC
[Comment from a bug triager]
This is probably related to this KSharedDataCache crash: bug 253795.
Regards
Comment 2 Jekyll Wu 2011-12-10 04:39:17 UTC

*** This bug has been marked as a duplicate of bug 253795 ***