Bug 270327 - Plasma shell crashes on system startup each time since 4.6.2 (related to MicroBlog) [QGraphicsItemPrivate::setVisibleHelper, QGraphicsItem::setVisible, hide, MicroBlog::downloadHistory, MicroBlog::configChanged]
Summary: Plasma shell crashes on system startup each time since 4.6.2 (related to Micr...
Status: RESOLVED DOWNSTREAM
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-microblogging (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash with 51 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 270346 270357 270374 270378 270444 270452 270495 270551 270651 271081 271121 271179 271510 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-07 15:21 UTC by Robby Engelmann
Modified: 2011-05-06 17:12 UTC (History)
44 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.75 KB, text/plain)
2011-04-07 19:35 UTC, cvpunk76
Details
New crash information added by DrKonqi (7.21 KB, text/plain)
2011-04-07 21:10 UTC, Nick
Details
New crash information added by DrKonqi (11.88 KB, text/plain)
2011-04-07 21:41 UTC, Samuel Suther
Details
New crash information added by DrKonqi (6.99 KB, text/plain)
2011-04-07 23:12 UTC, Oliver Wieland
Details
New crash information added by DrKonqi (4.64 KB, text/plain)
2011-04-08 00:12 UTC, Alex Lowe
Details
New crash information added by DrKonqi (6.01 KB, text/plain)
2011-04-08 01:07 UTC, soyanede
Details
New crash information added by DrKonqi (8.20 KB, text/plain)
2011-04-08 06:16 UTC, Tonatiuh Miramontes Pérez
Details
New crash information added by DrKonqi (6.88 KB, text/plain)
2011-04-08 09:55 UTC, Luke
Details
New crash information added by DrKonqi (6.50 KB, text/plain)
2011-04-08 13:40 UTC, Felix Zesch
Details
New crash information added by DrKonqi (7.92 KB, text/plain)
2011-04-08 18:10 UTC, Shakapon
Details
New crash information added by DrKonqi (8.57 KB, text/plain)
2011-04-09 06:36 UTC, Pablo PDA
Details
New crash information added by DrKonqi (6.29 KB, text/plain)
2011-04-09 06:47 UTC, Belomir
Details
my activities problem (94.99 KB, image/jpeg)
2011-04-09 22:35 UTC, jajaX
Details
New crash information added by DrKonqi (7.80 KB, text/plain)
2011-04-10 09:46 UTC, egoitza
Details
New crash information added by DrKonqi (15.10 KB, text/plain)
2011-04-10 20:24 UTC, D3XXX
Details
New crash information added by DrKonqi (6.54 KB, text/plain)
2011-04-11 19:33 UTC, abyss.andrey
Details
New crash information added by DrKonqi (7.46 KB, text/plain)
2011-04-12 03:31 UTC, Michael Sadick
Details
New crash information added by DrKonqi (7.76 KB, text/plain)
2011-04-12 13:09 UTC, baton2030
Details
New crash information added by DrKonqi (6.65 KB, text/plain)
2011-04-12 14:18 UTC, baton2030
Details
New crash information added by DrKonqi (7.21 KB, text/plain)
2011-04-12 20:15 UTC, Matt Harris
Details
New crash information added by DrKonqi (7.37 KB, text/plain)
2011-04-13 16:02 UTC, Alvaro Cabana
Details
New crash information added by DrKonqi (4.98 KB, text/plain)
2011-04-15 15:42 UTC, Marcus Harrison
Details
New crash information added by DrKonqi (5.08 KB, text/plain)
2011-04-15 17:43 UTC, abyss.andrey
Details
New crash information added by DrKonqi (7.34 KB, text/plain)
2011-04-19 09:54 UTC, Dennis
Details
New crash information added by DrKonqi (6.69 KB, text/plain)
2011-04-22 10:44 UTC, Ironfortv
Details
New crash information added by DrKonqi (7.58 KB, text/plain)
2011-04-26 18:56 UTC, andyhubbert
Details
since kde 4.6.2 the plasma ( panel and desktop crashes ) (2.82 KB, application/octet-stream)
2011-05-06 11:30 UTC, lcn.mustard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robby Engelmann 2011-04-07 15:21:21 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Plasma shell crashes immediately after login. I have set automatic login to my default user. I can see the splash screen, after that no desktop appear but plasma shell crashes each time. I can use ALT+F2 to start applications and ALT+TAB to switch windows. Thats all I can do.

The problem appeared since first new login after update to 4.6.2

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7758ad0 (LWP 2070))]

Thread 3 (Thread 0xaf3ffb70 (LWP 2073)):
#0  0x00efde36 in clock_gettime (clock_id=15736820, tp=0xaf3fef80) at ../sysdeps/unix/clock_gettime.c:100
#1  0x05f6b50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x060426e5 in QTimerInfoList::updateCurrentTime (this=0xaf401334) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0604272a in QTimerInfoList::timerWait (this=0xaf401334, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x060407a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf3ff0ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0604083d in timerSourcePrepare (source=0x0, timeout=0xf01ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0629fe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x062a0279 in ?? () from /lib/libglib-2.0.so.0
#9  0x062a0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0604059f in QEventDispatcherGlib::processEvents (this=0x92e7248, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x06010609 in QEventLoop::processEvents (this=0xaf3ff280, flags=) at kernel/qeventloop.cpp:149
#12 0x06010a8a in QEventLoop::exec (this=0xaf3ff280, flags=...) at kernel/qeventloop.cpp:201
#13 0x05f0cb7e in QThread::exec (this=0x92e6a10) at thread/qthread.cpp:490
#14 0x05fef35b in QInotifyFileSystemWatcherEngine::run (this=0x92e6a10) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x05f0fdf9 in QThreadPrivate::start (arg=0x92e6a10) at thread/qthread_unix.cpp:266
#16 0x02b63cc9 in start_thread (arg=0xaf3ffb70) at pthread_create.c:304
#17 0x0076f69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xadcb8b70 (LWP 2074)):
#0  0x0077cf3b in pthread_mutex_lock (mutex=0x93c6064) at forward.c:182
#1  0x0629fb68 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x062a045e in ?? () from /lib/libglib-2.0.so.0
#3  0x062a0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0604059f in QEventDispatcherGlib::processEvents (this=0x93c5b78, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x06010609 in QEventLoop::processEvents (this=0xadcb8280, flags=) at kernel/qeventloop.cpp:149
#6  0x06010a8a in QEventLoop::exec (this=0xadcb8280, flags=...) at kernel/qeventloop.cpp:201
#7  0x05f0cb7e in QThread::exec (this=0x93c3b58) at thread/qthread.cpp:490
#8  0x05fef35b in QInotifyFileSystemWatcherEngine::run (this=0x93c3b58) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x05f0fdf9 in QThreadPrivate::start (arg=0x93c3b58) at thread/qthread_unix.cpp:266
#10 0x02b63cc9 in start_thread (arg=0xadcb8b70) at pthread_create.c:304
#11 0x0076f69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7758ad0 (LWP 2070)):
[KCrash Handler]
#7  q_func (this=0xd74ffff, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0xd74ffff, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x0542c308 in QGraphicsItem::setVisible (this=0x6f007c, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x06446bf1 in hide (this=0x9183b38) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0x9183b38) at ../../../applets/microblog/microblog.cpp:839
#12 0x064492ec in MicroBlog::configChanged (this=0x9183b38) at ../../../applets/microblog/microblog.cpp:368
#13 0x064439ab in MicroBlog::init (this=0x9183b38) at ../../../applets/microblog/microblog.cpp:88
#14 0x00c4ad3c in Plasma::ContainmentPrivate::initApplets (this=0x90ab9d0) at ../../plasma/containment.cpp:463
#15 0x00c60fff in Plasma::CoronaPrivate::importLayout (this=0x8ba3108, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
#16 0x00c61bec in Plasma::Corona::loadLayout (this=0x8c4ba48, configName=...) at ../../plasma/corona.cpp:494
#17 0x00c627ee in Plasma::Corona::initializeLayout (this=0x8c4ba48, configName=...) at ../../plasma/corona.cpp:397
#18 0x0066452a in PlasmaApp::corona (this=0x8b8bee0) at ../../../../plasma/desktop/shell/plasmaapp.cpp:797
#19 0x0066490b in PlasmaApp::setupDesktop (this=0x8b8bee0) at ../../../../plasma/desktop/shell/plasmaapp.cpp:299
#20 0x00667677 in PlasmaApp::qt_metacall (this=0x8b8bee0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8bf5970) at ./plasmaapp.moc:155
#21 0x060178ca in QMetaObject::metacall (object=0x8b8bee0, cl=105181745, idx=45, argv=0x8bf5970) at kernel/qmetaobject.cpp:237
#22 0x06022df6 in QMetaCallEvent::placeMetaCall (this=0x8c05510, object=0x8b8bee0) at kernel/qobject.cpp:534
#23 0x060246a2 in QObject::event (this=0x8b8bee0, e=0x0) at kernel/qobject.cpp:1219
#24 0x060119db in QCoreApplication::event (this=0x8b8bee0, e=0x8c05510) at kernel/qcoreapplication.cpp:1561
#25 0x04d884d4 in QApplication::event (this=0x8b8bee0, e=0x8c05510) at kernel/qapplication.cpp:2439
#26 0x04d84fdc in QApplicationPrivate::notify_helper (this=0x8b9b580, receiver=0x8b8bee0, e=0x8c05510) at kernel/qapplication.cpp:4396
#27 0x04d8b04e in QApplication::notify (this=0x8b8bee0, receiver=0x8b8bee0, e=0x8c05510) at kernel/qapplication.cpp:3798
#28 0x0111582a in KApplication::notify (this=0x8b8bee0, receiver=0x8b8bee0, event=0x8c05510) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x06011b3b in QCoreApplication::notifyInternal (this=0x8b8bee0, receiver=0x8b8bee0, event=0x8c05510) at kernel/qcoreapplication.cpp:732
#30 0x06014d8b in sendEvent (receiver=0x0, event_type=0, data=0x8b58300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8b58300) at kernel/qcoreapplication.cpp:1373
#32 0x06014f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#33 0x06040a74 in sendPostedEvents (s=0x8b9c620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x8b9c620) at kernel/qeventdispatcher_glib.cpp:277
#35 0x0629c855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x062a0668 in ?? () from /lib/libglib-2.0.so.0
#37 0x062a0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x06040565 in QEventDispatcherGlib::processEvents (this=0x8b57fc0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#39 0x04e46be5 in QGuiEventDispatcherGlib::processEvents (this=0x8b57fc0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x06010609 in QEventLoop::processEvents (this=0xbfe4a894, flags=) at kernel/qeventloop.cpp:149
#41 0x06010a8a in QEventLoop::exec (this=0xbfe4a894, flags=...) at kernel/qeventloop.cpp:201
#42 0x0601500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#43 0x04d83e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#44 0x006461e7 in kdemain (argc=1, argv=0xbfe4aaa4) at ../../../../plasma/desktop/shell/main.cpp:118
#45 0x080485bb in main (argc=1, argv=0xbfe4aaa4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 248399.

Reported using DrKonqi
Comment 1 Robby Engelmann 2011-04-07 18:14:38 UTC
Add:
I  created a new user with a virgin profile. Here this problem cannot be found. Thus I remove some plasma-setting files from ~/.kde/share/config and my normal account works again, but I lost my settings for all activities :-( (I knew before deletion :-)).
I saved the setting files, thus if desired I can attach...
Comment 2 Alishams Hassam 2011-04-07 19:16:07 UTC
*** Bug 270346 has been marked as a duplicate of this bug. ***
Comment 3 Alishams Hassam 2011-04-07 19:17:54 UTC
Happened to me as well. Can confirm moving plasma* files in ~/.kde/share/config lets plasma-desktop continue but obviously settings lost.
Comment 4 cvpunk76 2011-04-07 19:35:21 UTC
Created attachment 58681 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

Upgraded to KDE 4.6.2  After reboot, plasma crashes.

-- Backtrace (Reduced):
#6  QGraphicsItemPrivate::setVisibleHelper (this=0x28cfd00, newVisible=false, explicitly=64, update=true) at graphicsview/qgraphicsitem.cpp:2251
[...]
#10 0x00007fd8b8b65cc0 in Plasma::ContainmentPrivate::initApplets (this=0x28d4aa0) at ../../plasma/containment.cpp:463
#11 0x00007fd8b8b7ac8c in Plasma::CoronaPrivate::importLayout (this=0x21680a0, conf=<value optimized out>, mergeConfig=<value optimized out>) at ../../plasma/corona.cpp:566
#12 0x00007fd8b8b7b793 in Plasma::Corona::loadLayout (this=0x215b8f0, configName=...) at ../../plasma/corona.cpp:494
#13 0x00007fd8b8b7c283 in Plasma::Corona::initializeLayout (this=0x215b8f0, configName=...) at ../../plasma/corona.cpp:397
Comment 5 Robby Engelmann 2011-04-07 20:47:21 UTC
Is the problem Kubuntu-specific? I saw another problem: shutdown did not work last time I tried.
As I remember it wouldn't be the first time when kubuntu packages were broken...
Comment 6 Nick 2011-04-07 21:10:40 UTC
Created attachment 58684 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed: this problem affect me too after upgrade to 4.6.2. I removed ~/kde and problem is gone, but after some time the crashes repeat(sorry for bad english)

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x70002f00530064, visible=false) at graphicsview/qgraphicsitem.cpp:2438
#7  0x00007f6ed64cc3ea in hide (this=0x114bf60) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x114bf60) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f6ed64cf13b in MicroBlog::configChanged (this=0x114bf60) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f6ed64c9cb7 in MicroBlog::init (this=0x114bf60) at ../../../applets/microblog/microblog.cpp:88
Comment 7 Samuel Suther 2011-04-07 21:41:53 UTC
Created attachment 58685 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

I have check the files in .kde/share/config and find out, that the problem cause in the file plasma-desktop-appletrc.

I delete it and start plasma to create a new one. Then i compare it step by step with my old one and move the source bit by bit to the new created.
Some things works well, but if i copy the following code from the old to my newone, plasma crash. Here is the diff of the two files:

cat ./old/plasmaError_diff 
25c25
< screen=0
---
> screen=-1
75c75
< [Containments][12]
---
> [Containments][100]
85a86
> mainGroup=6
87c88
< screen=-1
---
> screen=1
92,132c93,97
< [Containments][12][Wallpaper][image]
< slideTimer=10
< slidepaths=/usr/share/wallpapers/
< userswallpapers=
< wallpaper=/usr/share/wallpapers/Horos
< wallpapercolor=0,0,0
< wallpaperposition=0
< 
< [Containments][14]
< ActionPluginsSource=Global
< activity=
< activityId=
< desktop=-1
< formfactor=0
< geometry=-100663290,-16777215,1920,1080
< immutability=1
< lastDesktop=-1
< lastScreen=-1
< location=0
< plugin=desktopDashboard
< screen=-1
< wallpaperplugin=image
< wallpaperpluginmode=SingleImage
< zvalue=0
< 
< [Containments][15]
< ActionPluginsSource=Global
< activity=Kommunikation
< activityId=911f0077-6368-4fb8-a5ef-37767932a68c
< desktop=-1
< formfactor=0
< geometry=0,1236,1920,1080
< immutability=1
< lastDesktop=-1
< lastScreen=0
< location=0
< plugin=desktop
< screen=-1
< wallpaperplugin=image
< wallpaperpluginmode=SingleImage
< zvalue=0
---
> [Containments][100][Applets][69]
> geometry=84,171,468,724
> immutability=2
> plugin=twitter
> zvalue=71
134,140c99,110
< [Containments][15][Wallpaper][image]
< slideTimer=10
< slidepaths=/usr/share/wallpapers/
< userswallpapers=
< wallpaper=/usr/share/wallpapers/Horos
< wallpapercolor=0,0,0
< wallpaperposition=0
---
> [Containments][100][Applets][69][Configuration]
> Share=false
> historyRefresh=5
> historySize=20
> includeFriends=true
> serviceUrl=https://twitter.com/
> username=xstable
> 
> [Containments][100][Applets][69][GroupInformation]
> Group=9
> Position=-4
> Size=378
142,157c112,114
< [Containments][16]
< ActionPluginsSource=Global
< activity=Multimedia
< activityId=d57d8d45-b20c-43cb-917d-285d19641e4f
< desktop=-1
< formfactor=0
< geometry=1926,1236,1920,1080
< immutability=1
< lastDesktop=-1
< lastScreen=0
< location=0
< plugin=desktop
< screen=-1
< wallpaperplugin=image
< wallpaperpluginmode=SingleImage
< zvalue=0
---
> [Containments][100][Applets][69][LayoutInformation]
> Column=0
> Order=0
159,165c116,120
< [Containments][16][Wallpaper][image]
< slideTimer=10
< slidepaths=/usr/share/wallpapers/
< userswallpapers=
< wallpaper=/usr/share/wallpapers/Horos
< wallpapercolor=0,0,0
< wallpaperposition=0
---
> [Containments][100][Applets][70]
> geometry=563,172,464,725
> immutability=2
> plugin=twitter
> zvalue=70
167,182c122,133
< [Containments][17]
< ActionPluginsSource=Global
< activity=Multimedia
< activityId=d57d8d45-b20c-43cb-917d-285d19641e4f
< desktop=-1
< formfactor=0
< geometry=0,2472,1280,1024
< immutability=1
< lastDesktop=-1
< lastScreen=1
< location=0
< plugin=desktop
< screen=-1
< wallpaperplugin=image
< wallpaperpluginmode=SingleImage
< zvalue=0
---
> [Containments][100][Applets][70][Configuration]
> Share=false
> historyRefresh=5
> historySize=20
> includeFriends=true
> serviceUrl=https://twitter.com/
> username=erfolgsbeginn
> 
> [Containments][100][Applets][70][GroupInformation]
> Group=9
> Position=378
> Size=403
184,190c135,137
< [Containments][17][Wallpaper][image]
< slideTimer=10
< slidepaths=/usr/share/wallpapers/
< userswallpapers=
< wallpaper=/usr/share/wallpapers/Horos
< wallpapercolor=0,0,0
< wallpaperposition=0
---
> [Containments][100][Applets][70][LayoutInformation]
> Column=0
> Order=1
192,207c139,156
< [Containments][18]
< ActionPluginsSource=Global
< activity=HOME
< activityId=c0373675-0930-4855-8c0e-edc7be319d57
< desktop=-1
< formfactor=0
< geometry=1286,2472,1280,1024
< immutability=1
< lastDesktop=-1
< lastScreen=1
< location=0
< plugin=desktop
< screen=1
< wallpaperplugin=image
< wallpaperpluginmode=SingleImage
< zvalue=0
---
> [Containments][100][Groups][6]
> geometry=0,0,1280,1024
> plugin=floating
> zvalue=0
> 
> [Containments][100][Groups][9]
> geometry=1566,457,1029,778
> plugin=flow
> zvalue=2
> 
> [Containments][100][Groups][9][GroupInformation]
> Group=6
> Position=1566,457
> 
> [Containments][100][Wallpaper][color]
> backgroundMode=6
> color1=0,0,0
> color2=156,156,156
209c158
< [Containments][18][Wallpaper][image]
---
> [Containments][100][Wallpaper][image]
235c184
< geometry=1466,1,322,34
---
> geometry=1488,1,322,34
244c193
< geometry=29,1,24,24
---
> geometry=55,1,24,24
264c213
< geometry=4,32,24,24
---
> geometry=4,60,24,24
296,297c245,246
< DialogHeight=126
< DialogWidth=235
---
> DialogHeight=154
> DialogWidth=304
300c249
< geometry=1830,1,68,34
---
> geometry=1852,1,68,34
341c290
< geometry=1792,1,34,34
---
> geometry=1814,1,34,34
404c353
< geometry=191,1,1271,34
---
> geometry=191,1,1293,34

-- Backtrace (Reduced):
#7  q_func (this=0xc2950f08, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0xc2950f08, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x01b81308 in QGraphicsItem::setVisible (this=0x6e0071, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
[...]
#13 0x00dc0d3c in Plasma::ContainmentPrivate::initApplets (this=0xa7a0c18) at ../../plasma/containment.cpp:463
#14 0x00dd6fff in Plasma::CoronaPrivate::importLayout (this=0xa0b3cc0, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
Comment 8 Samuel Suther 2011-04-07 22:12:29 UTC
Have solve it now. The Problem is the KDE-MicroBlog Plugin.

I have delete this lines in .kde/share/config/plasma-desktop-appletsrc, and my Plasma still works again:


[Containments][100][Applets][69]
geometry=84,171,468,724
immutability=2
plugin=twitter
zvalue=71

[Containments][100][Applets][69][Configuration]
Share=false
historyRefresh=5
historySize=20
includeFriends=true
serviceUrl=https://twitter.com/
username=xstable

[Containments][100][Applets][69][GroupInformation]
Group=9
Position=-4
Size=378

[Containments][100][Applets][69][LayoutInformation]
Column=0
Order=0

[Containments][100][Applets][70]
geometry=563,172,464,725
immutability=2
plugin=twitter
zvalue=70

[Containments][100][Applets][70][Configuration]
Share=false
historyRefresh=5
historySize=20
includeFriends=true
serviceUrl=https://twitter.com/
username=erfolgsbeginn

[Containments][100][Applets][70][GroupInformation]
Group=9
Position=378
Size=403

[Containments][100][Applets][70][LayoutInformation]
Column=0
Order=1




Additional BUG i've found : Plugin Google Translator.-.. if it try to connect, i got thousend of this messages on the console:

QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted


Hope it help to fix this problem for next release
Comment 9 Oliver Wieland 2011-04-07 23:12:38 UTC
Created attachment 58692 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

Plasma crashes every time KDE starts. This happens since I installed KDE SC4.6.2

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x6f74706f746b7375, visible=false) at graphicsview/qgraphicsitem.cpp:2411
[...]
#10 0x00007ff0d1d33cc0 in Plasma::ContainmentPrivate::initApplets (this=0x2b203e0) at ../../plasma/containment.cpp:463
#11 0x00007ff0d1d48c8c in Plasma::CoronaPrivate::importLayout (this=0x26890d0, conf=<value optimized out>, mergeConfig=<value optimized out>) at ../../plasma/corona.cpp:566
#12 0x00007ff0d1d49793 in Plasma::Corona::loadLayout (this=0x2773d70, configName=...) at ../../plasma/corona.cpp:494
#13 0x00007ff0d1d4a283 in Plasma::Corona::initializeLayout (this=0x2773d70, configName=...) at ../../plasma/corona.cpp:397
Comment 10 Nicolas L. 2011-04-07 23:29:02 UTC
*** Bug 270357 has been marked as a duplicate of this bug. ***
Comment 11 Nicolas L. 2011-04-07 23:29:09 UTC
*** Bug 270374 has been marked as a duplicate of this bug. ***
Comment 12 Alex Lowe 2011-04-08 00:12:07 UTC
Created attachment 58695 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- Custom settings of the application:

I have 3 activities: The first contains the KDE microblogger and a launcher for Chrome. The second contains two quicklaunch panels and the Amarok plasmoid. The third contains a quicklaunch, a folder view, weather and perhaps one or two other widgets (that they are escapes me).

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x62696c2f736c743f, visible=false) at graphicsview/qgraphicsitem.cpp:2438
#7  0x00007f5fb0a653ea in hide (this=0xd59fa0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0xd59fa0) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f5fb0a6813b in MicroBlog::configChanged (this=0xd59fa0) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f5fb0a62cb7 in MicroBlog::init (this=0xd59fa0) at ../../../applets/microblog/microblog.cpp:88
Comment 13 soyanede 2011-04-08 01:07:45 UTC
Created attachment 58697 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

The same with others users. Crash after login.

(Sorry for my few english :( )

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x65656130300a707f, visible=false) at graphicsview/qgraphicsitem.cpp:2411
#7  0x00007f230eaea6df in hide (this=0x10b94a0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x10b94a0) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f230eaecb40 in MicroBlog::configChanged (this=0x10b94a0) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f230eae7957 in MicroBlog::init (this=0x10b94a0) at ../../../applets/microblog/microblog.cpp:88
Comment 14 Lamarque V. Souza 2011-04-08 01:22:44 UTC
*** Bug 270378 has been marked as a duplicate of this bug. ***
Comment 15 Tonatiuh Miramontes Pérez 2011-04-08 06:16:57 UTC
Created attachment 58701 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
Plasma crashed just after login.  Splash screen showed up and then plasma crash error rised. I can execute programs with Alt+F2 and Yakuake works fine (F12). 
- Custom settings of the application:
Kubuntu 10.10 Maverick, with Kubuntu members, updates, etc, repositories enabled. 
I've got a couple plasmoids on my desktop; Microblogging, Google translate, File view, Network load, Calendar, and I use Smooth Tasks and Fancy Tasks.

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0xd80, visible=false) at graphicsview/qgraphicsitem.cpp:2411
#7  0x00007f804b2546df in hide (this=0x28db2c0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x28db2c0) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f804b256b40 in MicroBlog::configChanged (this=0x28db2c0) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f804b251957 in MicroBlog::init (this=0x28db2c0) at ../../../applets/microblog/microblog.cpp:88
Comment 16 Luke 2011-04-08 09:55:08 UTC
Created attachment 58704 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
Starting KDE. The splash screen appears on boot up and then Plasma crashes. I have normal functionality without the Plasma desktop. Started occurring immediately after 4.6.2 update and is 100% repeatable.

-- Backtrace (Reduced):
#7  0x0200bed7 in QGraphicsItemPrivate::setVisibleHelper (this=0x4ec83dc, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2239
#8  0x0200c308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#9  0x04a78bf1 in hide (this=0x97ca268) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#10 MicroBlog::downloadHistory (this=0x97ca268) at ../../../applets/microblog/microblog.cpp:839
#11 0x04a7b2ec in MicroBlog::configChanged (this=0x97ca268) at ../../../applets/microblog/microblog.cpp:368
Comment 17 Luke 2011-04-08 10:45:19 UTC
As suggested by Samuel (Comment #8) removing lines in .kde/share/config/plasma-desktop-appletsrc related to KDE MicroBlog (search for Twitter) fixed this issue for me.
Comment 18 Michal Breškovec 2011-04-08 11:59:48 UTC
I have the same issue on Kubuntu 10.10 after upgrade to KDE 4.6.2. After removing MicroBlog widget from  ~/.kde/share/config/plasma-desktop-appletsrc Plasma start working OK.
Comment 19 Felix Zesch 2011-04-08 13:40:50 UTC
Created attachment 58709 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
first login after update to 4.6.2

- Custom settings of the application:
several widgets on plasma: microblogging, wheather

-- Backtrace (Reduced):
#7  0xb61d82fd in QGraphicsItem::setVisible (this=0x61636f74, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#8  0xadb10bf1 in hide (this=0xa19d0a0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#9  MicroBlog::downloadHistory (this=0xa19d0a0) at ../../../applets/microblog/microblog.cpp:839
#10 0xadb132ec in MicroBlog::configChanged (this=0xa19d0a0) at ../../../applets/microblog/microblog.cpp:368
#11 0xadb0d9ab in MicroBlog::init (this=0xa19d0a0) at ../../../applets/microblog/microblog.cpp:88
Comment 20 Bart Cerneels 2011-04-08 14:52:03 UTC
I can confirm this bug, backtrace identical and clearly in the microblog code. I can help test fixes, have the appletsrc file backed up.
Comment 21 Oliver Wieland 2011-04-08 16:19:41 UTC
Same for me: After I deleted the microblog code from plasma-desktop-appletsrc the error didn't occure anymore.
Comment 22 Shakapon 2011-04-08 18:10:57 UTC
Created attachment 58715 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

Every login time, I got a message as a crash report at Kubuntu 11.04 Alpha3. This crash do not occured during first several times, but continue this message for first login crash message.

-- Backtrace (Reduced):
#6  QGraphicsItemPrivate::setVisibleHelper (this=0x7f74f924, newVisible=false, explicitly=true, update=true) at .moc/release-shared/moc_qgraphicsitem.cpp:373
#7  0x00007f74e12b83ea in hide (this=0x2507930) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x2507930) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f74e12bb13b in MicroBlog::configChanged (this=0x2507930) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f74e12b5cb7 in MicroBlog::init (this=0x2507930) at ../../../applets/microblog/microblog.cpp:88
Comment 23 Pablo PDA 2011-04-09 06:36:52 UTC
Created attachment 58733 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

 What I was doing when the application crashed:
Plasma shell crashes immediately after login. I have set automatic login to my default user. I can see the splash screen, after that no desktop appear but plasma shell crashes each time. I can use ALT+F2 to start applications and ALT+TAB to switch windows. Thats all I can do.

The problem appeared since first new login after update to 4.6.2

The crash can be reproduced every time.

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x303020702d2d7230, visible=false) at graphicsview/qgraphicsitem.cpp:2411
#7  0x00007f983f5746df in hide (this=0x1620f70) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x1620f70) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f983f576b40 in MicroBlog::configChanged (this=0x1620f70) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f983f571957 in MicroBlog::init (this=0x1620f70) at ../../../applets/microblog/microblog.cpp:88
Comment 24 Belomir 2011-04-09 06:47:31 UTC
Created attachment 58734 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

Just log in. Plasma crashes and cant't be restarted — after launcing plasma-desktop on F2 it crashes again emmediately.
It happens next start after upgrade to 4.6.2 from backports.

-- Backtrace (Reduced):
#7  q_func (this=0xa486, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0xa486, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x027ca308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
[...]
#13 0x003c4d3c in Plasma::ContainmentPrivate::initApplets (this=0x890ec78) at ../../plasma/containment.cpp:463
#14 0x003dafff in Plasma::CoronaPrivate::importLayout (this=0x822cbf8, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
Comment 25 Alex Lowe 2011-04-09 08:34:32 UTC
It appears this bug was Kubuntu-specific. It has been resolved for me with an update of the 4.6.2 packages (Natty).
Comment 26 Dario Andres 2011-04-09 13:57:32 UTC
*** Bug 270444 has been marked as a duplicate of this bug. ***
Comment 27 Dario Andres 2011-04-09 13:57:34 UTC
*** Bug 270452 has been marked as a duplicate of this bug. ***
Comment 28 Dario Andres 2011-04-09 13:57:36 UTC
*** Bug 270495 has been marked as a duplicate of this bug. ***
Comment 29 Dario Andres 2011-04-09 13:57:58 UTC
[Comment from a bug triager]
- Can anyone else confirm that this crash dissapear with the latest Kubuntu packages updates ?
Regards
Comment 30 Nick 2011-04-09 17:12:50 UTC
after last upgrade in natty the problem is solved for me, thanks! can you fix it in maverick?
Comment 31 jajaX 2011-04-09 22:33:45 UTC
(In reply to comment #29)
> [Comment from a bug triager]
> - Can anyone else confirm that this crash dissapear with the latest Kubuntu
> packages updates ?
> Regards

Hi !

yes I have got this bug too in kubuntu 10.10 (64 bits) and 4.6.2 updates backports ppa packages. But now, after deleting plasma-desktop-appletsrc, I have got a new problem with activities !

see screenshot !! (I make a new post in kde forum now)
Comment 32 jajaX 2011-04-09 22:35:01 UTC
Created attachment 58749 [details]
my activities problem

just for you see, that's all ! I make a new post in kde forum ;)
Comment 33 egoitza 2011-04-10 09:46:01 UTC
Created attachment 58760 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

On startup, KDE crashes, but it's posible to open Chrome or this asistent for reporting errors.

-- Backtrace (Reduced):
#6  q_func (this=0x7f9256e4, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#7  QGraphicsItemPrivate::setVisibleHelper (this=0x7f9256e4, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#8  0x00007f923c5526df in hide (this=0x162e220) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#9  MicroBlog::downloadHistory (this=0x162e220) at ../../../applets/microblog/microblog.cpp:839
#10 0x00007f923c554b40 in MicroBlog::configChanged (this=0x162e220) at ../../../applets/microblog/microblog.cpp:368
Comment 34 Dario Andres 2011-04-10 13:10:58 UTC
*** Bug 270551 has been marked as a duplicate of this bug. ***
Comment 35 D3XXX 2011-04-10 20:24:13 UTC
Created attachment 58779 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb28bead0 (LWP 3438))]

Thread 3 (Thread 0xaa76bb70 (LWP 3448)):
#0  0xb3745e36 in clock_gettime (clock_id=-1284202508, tp=0xaa76af80) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb650e50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb65e56e5 in QTimerInfoList::updateCurrentTime (this=0x89e8b94) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb65e572a in QTimerInfoList::timerWait (this=0x89e8b94, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb65e37a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaa76b0ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb65e383d in timerSourcePrepare (source=0x0, timeout=0xb3749ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb36b3e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb36b4279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb36b4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb65e359f in QEventDispatcherGlib::processEvents (this=0x8a27160, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb65b3609 in QEventLoop::processEvents (this=0xaa76b280, flags=) at kernel/qeventloop.cpp:149
#12 0xb65b3a8a in QEventLoop::exec (this=0xaa76b280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb64afb7e in QThread::exec (this=0x8a27118) at thread/qthread.cpp:490
#14 0xb659235b in QInotifyFileSystemWatcherEngine::run (this=0x8a27118) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb64b2df9 in QThreadPrivate::start (arg=0x8a27118) at thread/qthread_unix.cpp:266
#16 0xb3756cc9 in start_thread (arg=0xaa76bb70) at pthread_create.c:304
#17 0xb76a569e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa8451b70 (LWP 3451)):
#0  0xb3745e36 in clock_gettime (clock_id=-1284202508, tp=0xa8450f80) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb650e50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb65e56e5 in QTimerInfoList::updateCurrentTime (this=0x8a533b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb65e572a in QTimerInfoList::timerWait (this=0x8a533b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb65e37a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa84510ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb65e383d in timerSourcePrepare (source=0x0, timeout=0xb3749ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb36b3e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb36b4279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb36b4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb65e359f in QEventDispatcherGlib::processEvents (this=0x8a34d90, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb65b3609 in QEventLoop::processEvents (this=0xa8451280, flags=) at kernel/qeventloop.cpp:149
#12 0xb65b3a8a in QEventLoop::exec (this=0xa8451280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb64afb7e in QThread::exec (this=0x87b51b8) at thread/qthread.cpp:490
#14 0xb659235b in QInotifyFileSystemWatcherEngine::run (this=0x87b51b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb64b2df9 in QThreadPrivate::start (arg=0x87b51b8) at thread/qthread_unix.cpp:266
#16 0xb3756cc9 in start_thread (arg=0xa8451b70) at pthread_create.c:304
#17 0xb76a569e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb28bead0 (LWP 3438)):
[KCrash Handler]
#7  0xb615b2fd in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#8  0xafd04bf1 in hide (this=0x88e4c30) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#9  MicroBlog::downloadHistory (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:839
#10 0xafd072ec in MicroBlog::configChanged (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:368
#11 0xafd019ab in MicroBlog::init (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:88
#12 0xb73dfd3c in Plasma::ContainmentPrivate::initApplets (this=0x88a71c8) at ../../plasma/containment.cpp:463
#13 0xb73f5fff in Plasma::CoronaPrivate::importLayout (this=0x84b4970, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
#14 0xb73f6bec in Plasma::Corona::loadLayout (this=0x84b3cf8, configName=...) at ../../plasma/corona.cpp:494
#15 0xb73f77ee in Plasma::Corona::initializeLayout (this=0x84b3cf8, configName=...) at ../../plasma/corona.cpp:397
#16 0xb779f52a in PlasmaApp::corona (this=0x84a7550) at ../../../../plasma/desktop/shell/plasmaapp.cpp:797
#17 0xb779f90b in PlasmaApp::setupDesktop (this=0x84a7550) at ../../../../plasma/desktop/shell/plasmaapp.cpp:299
#18 0xb77a2677 in PlasmaApp::qt_metacall (this=0x84a7550, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8522070) at ./plasmaapp.moc:155
#19 0xb65ba8ca in QMetaObject::metacall (object=0x84a7550, cl=2949698097, idx=45, argv=0x8522070) at kernel/qmetaobject.cpp:237
#20 0xb65c5df6 in QMetaCallEvent::placeMetaCall (this=0x8521d80, object=0x84a7550) at kernel/qobject.cpp:534
#21 0xb65c76a2 in QObject::event (this=0x84a7550, e=0x1) at kernel/qobject.cpp:1219
#22 0xb65b49db in QCoreApplication::event (this=0x84a7550, e=0x8521d80) at kernel/qcoreapplication.cpp:1561
#23 0xb5ab74d4 in QApplication::event (this=0x84a7550, e=0x8521d80) at kernel/qapplication.cpp:2439
#24 0xb5ab3fdc in QApplicationPrivate::notify_helper (this=0x84b51b8, receiver=0x84a7550, e=0x8521d80) at kernel/qapplication.cpp:4396
#25 0xb5aba04e in QApplication::notify (this=0x84a7550, receiver=0x84a7550, e=0x8521d80) at kernel/qapplication.cpp:3798
#26 0xb6c1682a in KApplication::notify (this=0x84a7550, receiver=0x84a7550, event=0x8521d80) at ../../kdeui/kernel/kapplication.cpp:311
#27 0xb65b4b3b in QCoreApplication::notifyInternal (this=0x84a7550, receiver=0x84a7550, event=0x8521d80) at kernel/qcoreapplication.cpp:732
#28 0xb65b7d8b in sendEvent (receiver=0x0, event_type=0, data=0x8479318) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8479318) at kernel/qcoreapplication.cpp:1373
#30 0xb65b7f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#31 0xb65e3a74 in sendPostedEvents (s=0x84b4f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=0x84b4f10) at kernel/qeventdispatcher_glib.cpp:277
#33 0xb36b0855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0xb36b4668 in ?? () from /lib/libglib-2.0.so.0
#35 0xb36b4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0xb65e3565 in QEventDispatcherGlib::processEvents (this=0x8478fd8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#37 0xb5b75be5 in QGuiEventDispatcherGlib::processEvents (this=0x8478fd8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0xb65b3609 in QEventLoop::processEvents (this=0xbf84e064, flags=) at kernel/qeventloop.cpp:149
#39 0xb65b3a8a in QEventLoop::exec (this=0xbf84e064, flags=...) at kernel/qeventloop.cpp:201
#40 0xb65b800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#41 0xb5ab2e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#42 0xb77811e7 in kdemain (argc=1, argv=0xbf84e274) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x080485bb in main (argc=1, argv=0xbf84e274) at plasma-desktop_dummy.cpp:3

-- Backtrace (Reduced):
#7  0xb615b2fd in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#8  0xafd04bf1 in hide (this=0x88e4c30) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#9  MicroBlog::downloadHistory (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:839
#10 0xafd072ec in MicroBlog::configChanged (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:368
#11 0xafd019ab in MicroBlog::init (this=0x88e4c30) at ../../../applets/microblog/microblog.cpp:88
Comment 36 Nicolas L. 2011-04-11 10:09:36 UTC
*** Bug 270651 has been marked as a duplicate of this bug. ***
Comment 37 D3XXX 2011-04-11 15:06:55 UTC
Thank you very much. I solved it after two hours of brainstorming!

See you!





________________________________
De: Beat Wolf <asraniel@fryx.ch>
Para: estabacantao@yahoo.es
Enviado: lun,11 abril, 2011 14:11
Asunto: [Bug 270327] Plasma shell crashes on system startup each time since 
4.6.2 (related to MicroBlog) [QGraphicsItemPrivate::setVisibleHelper, 
QGraphicsItem::setVisible,  hide, MicroBlog::downloadHistory, 
MicroBlog::configChanged]

https://bugs.kde.org/show_bug.cgi?id=270327


Beat Wolf <asraniel@fryx.ch> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |asraniel@fryx.ch
          Component|general                     |widget-microblogging
Comment 38 Beat Wolf 2011-04-11 15:12:53 UTC
You fixed the bug? i'm not sure i understand your comment
Comment 39 abyss.andrey 2011-04-11 19:33:28 UTC
Created attachment 58802 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

I added microblog plasmoid with twitter account.
Restart session and got crashe on start.
Removing microblog plasmoid from plasma-desktop-appletrc makes plasma startable.

-- Backtrace (Reduced):
#7  q_func (this=0xfe94958b, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0xfe94958b, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x01ae6308 in QGraphicsItem::setVisible (this=0x610075, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
[...]
#13 0x0095cd3c in Plasma::ContainmentPrivate::initApplets (this=0x8fb82d0) at ../../plasma/containment.cpp:463
#14 0x00972fff in Plasma::CoronaPrivate::importLayout (this=0x8a3e200, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
Comment 40 Michael Sadick 2011-04-12 03:31:03 UTC
Created attachment 58816 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
Starting up Kubuntu 10.10 with KDE SC 4.6.2
- Unusual behavior I noticed:
Plasma consistently crashing.  Problem was solved by reading a related bug report and removing references to KDE Microblog Plasmoid

-- Backtrace (Reduced):
#6  QGraphicsItemPrivate::setVisibleHelper (this=0x36b48d0, newVisible=false, explicitly=64, update=true) at graphicsview/qgraphicsitem.cpp:2251
#7  0x00007fa609cf06df in hide (this=0x2d23bc0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x2d23bc0) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007fa609cf2b40 in MicroBlog::configChanged (this=0x2d23bc0) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007fa609ced957 in MicroBlog::init (this=0x2d23bc0) at ../../../applets/microblog/microblog.cpp:88
Comment 41 Pablo PDA 2011-04-12 04:31:42 UTC
I'm using plasma-netbook (alt+F2 and there plasma-netbook ) until
plasma-desktop bug is fixed.
Just in case it can help some one.
Comment 42 baton2030 2011-04-12 13:09:07 UTC
Created attachment 58822 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
Nothing. Failure of plasma occurred immediately after login

-- Backtrace (Reduced):
#7  q_func (this=0x820527f3, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0x820527f3, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x070b5308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x056b3bf1 in hide (this=0x91f03f0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0x91f03f0) at ../../../applets/microblog/microblog.cpp:839
Comment 43 baton2030 2011-04-12 14:18:23 UTC
Created attachment 58833 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
Plasma occured immideatly after startup
- Custom settings of the application:
Just do apt-get dist-upgrade and reboot

-- Backtrace (Reduced):
#7  q_func (this=0x46e9ffff, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0x46e9ffff, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x04748308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x06305bf1 in hide (this=0x9b47210) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0x9b47210) at ../../../applets/microblog/microblog.cpp:839
Comment 44 Matt Harris 2011-04-12 20:15:55 UTC
Created attachment 58858 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

Same as the others;  Logging in, with the microblogging plasma widget on the desktop.  Boom.

- Custom settings of the application:
I had the microblogging widget set up to use twitter instead of the default.

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x6b2f62696c2f7283, visible=false) at graphicsview/qgraphicsitem.cpp:2411
#7  0x00007f57bf2bf6df in hide (this=0x1182c70) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x1182c70) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007f57bf2c1b40 in MicroBlog::configChanged (this=0x1182c70) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007f57bf2bc957 in MicroBlog::init (this=0x1182c70) at ../../../applets/microblog/microblog.cpp:88
Comment 45 Bart Cerneels 2011-04-13 12:17:08 UTC
(In reply to comment #29)
> [Comment from a bug triager]
> - Can anyone else confirm that this crash dissapear with the latest Kubuntu
> packages updates ?
> Regards

No, it doesn't.
Comment 46 Alvaro Cabana 2011-04-13 16:02:06 UTC
Created attachment 58892 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

I just logged in after updating to kde 4.6.2. Then plasma crashes .

- Unusual behavior I noticed:

There's no desktop. I can start applications with alt+f2, everything non-plasma seems to work fine.
I've seen this bug is microblogging-related, I'll try to log in with a different user and/or remove the mublog widget and see what happens.

-- Backtrace (Reduced):
#6  QGraphicsItem::setVisible (this=0x303331322032304a, visible=false) at graphicsview/qgraphicsitem.cpp:2411
#7  0x00007fe2468ed6df in hide (this=0x13e61a0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#8  MicroBlog::downloadHistory (this=0x13e61a0) at ../../../applets/microblog/microblog.cpp:839
#9  0x00007fe2468efb40 in MicroBlog::configChanged (this=0x13e61a0) at ../../../applets/microblog/microblog.cpp:368
#10 0x00007fe2468ea957 in MicroBlog::init (this=0x13e61a0) at ../../../applets/microblog/microblog.cpp:88
Comment 47 Alvaro Cabana 2011-04-13 16:51:41 UTC
I confirm that by commenting the lines in "~/.kde/share/config/plasma-desktop-appletsrc" that set up and configure the microblogging widget (plugin=twitter), plasma starts normally.
Comment 48 Rohan Garg 2011-04-13 20:06:08 UTC
Hi
I can't seem to reproduce this crash on Kubuntu Natty with KDE 4.6.2 and Qt 4.7.2
Comment 49 Marcus Harrison 2011-04-15 15:42:58 UTC
Created attachment 59010 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

Same crash here. Crashes on start-up, seems like a regression of a previous bug I witnessed. However, it doesn't seem to matter whether the widget is configured for Twitter or Identi.ca: if it's configured at all, the desktop will crash. Note that it doesn't crash if using Kubuntu's default configuration, which includes a microblog widget that simply has, "kubuntu" as the username, for a identi.ca account.

-- Backtrace (Reduced):
#7  q_func (this=0x24870ff0, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0x24870ff0, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x01ba5308 in QGraphicsItem::setVisible (this=0x730076, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x06afabf1 in hide (this=0xa35c468) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0xa35c468) at ../../../applets/microblog/microblog.cpp:839
Comment 50 abyss.andrey 2011-04-15 17:43:59 UTC
Created attachment 59015 [details]
New crash information added by DrKonqi

plasma-netbook (0.2) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:

I updated to 4.6.2 when reboot.
Plasma crashes after logon, removing microblog plasmoid helps.

-- Backtrace (Reduced):
#7  0x04aaaed7 in QGraphicsItemPrivate::setVisibleHelper (this=0x8e82404, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2239
#8  0x04aab308 in QGraphicsItem::setVisible (this=0x74006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#9  0x0983bbf1 in hide (this=0xa0e8778) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#10 MicroBlog::downloadHistory (this=0xa0e8778) at ../../../applets/microblog/microblog.cpp:839
#11 0x0983e2ec in MicroBlog::configChanged (this=0xa0e8778) at ../../../applets/microblog/microblog.cpp:368
Comment 51 Dario Andres 2011-04-16 12:22:24 UTC
*** Bug 271081 has been marked as a duplicate of this bug. ***
Comment 52 Dario Andres 2011-04-16 22:33:08 UTC
*** Bug 271121 has been marked as a duplicate of this bug. ***
Comment 53 Dennis 2011-04-19 09:54:09 UTC
Created attachment 59121 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:I startup my computer and the computer crashed. I had only a black screen.

- Unusual behavior I notice: I can only open applications with alt-F2.

- Custom settings of the application:I opened the systemsettings and change the settings from desktop to netbook and now i my computer works good.

-- Backtrace (Reduced):
#7  q_func (this=0xcf81cf31, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0xcf81cf31, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x0735d308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x03245bf1 in hide (this=0xa3986a0) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0xa3986a0) at ../../../applets/microblog/microblog.cpp:839
Comment 54 Ironfortv 2011-04-22 10:44:32 UTC
Created attachment 59202 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- Custom settings of the application:
ejecutable : plasma desktop PID :1723, señal: segmentation fault (11)
despues de configurar microblogin y propiedades de ventanias y apariencias del tema.

-- Backtrace (Reduced):
#7  q_func (this=0x46000000, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0x46000000, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x03483308 in QGraphicsItem::setVisible (this=0x610075, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
#10 0x0451abf1 in hide (this=0x9dcbf70) at /usr/include/qt4/QtGui/qgraphicsitem.h:221
#11 MicroBlog::downloadHistory (this=0x9dcbf70) at ../../../applets/microblog/microblog.cpp:839
Comment 55 Dario Andres 2011-04-22 22:23:39 UTC
*** Bug 271510 has been marked as a duplicate of this bug. ***
Comment 56 Dario Andres 2011-04-22 22:24:18 UTC
[Comment from a bug triager]
From bug 271179:
- Unusual behavior I noticed:
I configure the microblogging application with my username and password and
everything is ok. After I logout and log in  again the plasma desktop doesn't
start and crashes with a segmentation fault. If I don't configure de
microblogging widget, it doesn't happen.
Comment 57 Dario Andres 2011-04-22 22:24:29 UTC
*** Bug 271179 has been marked as a duplicate of this bug. ***
Comment 58 andyhubbert 2011-04-26 18:56:58 UTC
Created attachment 59335 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
logging onto dektop
- Custom settings of the application:
the latest packages from kubuntu

-- Backtrace (Reduced):
#7  q_func (this=0x89c7899c, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem_p.h:160
#8  QGraphicsItemPrivate::setVisibleHelper (this=0x89c7899c, newVisible=false, explicitly=true, update=true) at graphicsview/qgraphicsitem.cpp:2235
#9  0x01bbf308 in QGraphicsItem::setVisible (this=0x73006d, visible=<value optimized out>) at graphicsview/qgraphicsitem.cpp:2411
[...]
#13 0x001d7d3c in Plasma::ContainmentPrivate::initApplets (this=0x88ddaf8) at ../../plasma/containment.cpp:463
#14 0x001edfff in Plasma::CoronaPrivate::importLayout (this=0x83add30, conf=..., mergeConfig=false) at ../../plasma/corona.cpp:566
Comment 59 Marcus Harrison 2011-04-30 13:33:30 UTC
Can confirm that this bug does not occur with the Oxygen plasma theme or Aya plasma theme. It seems to be an issue with the Air plasma theme.
Comment 60 lcn.mustard 2011-05-06 11:30:49 UTC
Created attachment 59687 [details]
since kde 4.6.2 the plasma ( panel and desktop crashes )

since kde 4.6.2, the plasma had been instaled ( panel and desktop crashes ) with kubuntu 10.10/ kde 4.6.2 theme air
Comment 61 lcn.mustard 2011-05-06 11:31:55 UTC
same problem here
Comment 62 lcn.mustard 2011-05-06 12:26:23 UTC
I tested this with various themes and got the same result with the microblogging installed: black screen (plasma-desktop crashes). Without the microblog plasma-desktop starts ok. A very bad bug since the very use microblogging and I'll have to go back to 10.04.
Comment 63 Aaron J. Seigo 2011-05-06 13:42:31 UTC
this is due to a patch authored by and shipped with Kubuntu:

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/natty/kdeplasma-addons/natty/view/head:/debian/patches/kubuntu_02_microblog_default_configuration.diff

it's crashing in the call to m_headerFrame->hide(); in downloadHistory()

this should be reported to Kubuntu developers.
Comment 64 Scott Kitterman 2011-05-06 14:07:07 UTC
This was with unofficial test packages that some Kubuntu developers provide for users on earlier releases.  This patch is not enabled in our official release of Kubuntu 11.04 (with KDE SC 4.6.2).  I've just uploaded a new package to the test repository where this problem was found and so once the update has had a chance to build it should be resolved for the reporter.