Bug 270216 - selecting multiple lines for later pasting is broken by adding garbage spaces
Summary: selecting multiple lines for later pasting is broken by adding garbage spaces
Status: RESOLVED DUPLICATE of bug 188528
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-06 13:16 UTC by Marc Schiffbauer
Modified: 2011-04-06 13:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2011-04-06 13:16:38 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Since some time, konsole or yakuake behave very bad when selecting text to be pasted somewhere else later:

They copy trailing space after lineendings as whitespace make every single line as long as the size of the current window.


Reproducible: Sometimes

Steps to Reproduce:
1. do "ls -l" or "vi somefile" or "mutt"
2. select some lines (more than 20)
3. paste them into another konsole window with a running "vi bar"

Now many of the lines have many spaces after the last character of the line.

A bit strange though: When I do that with a "ls -l" here first few lines will be copied correct and then starting with some (random?) line all the rest of the lines has the trailing whitespace.
Comment 1 Marc Schiffbauer 2011-04-06 13:19:04 UTC
Additional Info: It does not happen with gnome-terminal, so I assume it must be something within some part that yakuake and konsole are sharing...
Comment 2 Eike Hein 2011-04-06 13:23:51 UTC

*** This bug has been marked as a duplicate of bug 188528 ***