Bug 270161 - Unclear how to get rid of tags
Summary: Unclear how to get rid of tags
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 2.0.0
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-05 16:58 UTC by Rinus Bakker
Modified: 2012-06-27 10:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rinus Bakker 2011-04-05 16:58:51 UTC
Version:           2.0.0 (using KDE 4.6.1) 
OS:                Linux

It looks like I have sometimes to click on "remove this tag" and some other times on the tagname itself. Sometimes the parents go with their children, somtimes the children with there parents, sometimes I have to click a lot because a lot of clicks to not lead to any performed action at all before the whole tagtree is removed. 

I think this need to be improved.
this referes to rightclick on thump ¨remove tag¨.

My thought: To start with, in the unfolding tag structure, either ¨remove this tag¨ or the tagname itself should be not highlighted or not clickeble.

Besides that:
I wood strongly plea for a rightclick option menu
- remove tag
- remove tag with children
- remove tag with parents

as well as a function in the thumbnail window rightclick "copy tag" and
"past tag"

Reproducible: Always

Steps to Reproduce:
as in details

Actual Results:  
as in details
Comment 1 Rinus Bakker 2011-05-22 18:42:11 UTC
(In reply to comment #0)
> Version:           2.0.0 (using KDE 4.6.1) 
> OS:                Linux
> 
> It looks like I have sometimes to click on "remove this tag" and some other
> times on the tagname itself. Sometimes the parents go with their children,
> somtimes the children with there parents, sometimes I have to click a lot
> because a lot of clicks to not lead to any performed action at all before the
> whole tagtree is removed. 
> 
> I think this need to be improved.
> this referes to rightclick on thump ¨remove tag¨.
> 
> My thought: To start with, in the unfolding tag structure, either ¨remove this
> tag¨ or the tagname itself should be not highlighted or not clickeble.
> 

> 
> Reproducible: Always
> 
> Steps to Reproduce:
> as in details
> 
> Actual Results:  
> as in details

After discovering the ¨Tags already assigned¨ icon I consider part of the initial report superfluous. That part is removed in this remark.
Rinus
Comment 2 Marcel Wiesweg 2011-05-30 22:14:46 UTC
Short summary: The "Remove tag" submenu in the context menu is cumbersome and could be improved
Comment 3 Marcel Wiesweg 2011-07-11 17:03:02 UTC
Git commit 7148336e23cd95382333d76b33c7a13eb6802712 by Marcel Wiesweg.
Committed on 03/07/2011 at 12:30.
Pushed by mwiesweg into branch 'master'.

Fix some annoyances with the Remove Tag submenu.
- for less than 10 assigend tags, offer a flat list without the need to go to
  a hierarchy of tags
- in the hierarchical menu, do not show "Remove this tag" if the tag is a
  parent tag and not at all assigned
- if no checkbox is drawn, do not reserve space for it

BUG: 270161

M  +81   -25   digikam/tags/tagspopupmenu.cpp     
M  +1    -0    digikam/tags/tagspopupmenu.h     

http://commits.kde.org/digikam/7148336e23cd95382333d76b33c7a13eb6802712