Bug 270030 - Knemo text or netload theme causes pixmap leak in plasma
Summary: Knemo text or netload theme causes pixmap leak in plasma
Status: RESOLVED UNMAINTAINED
Alias: None
Product: knemo
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: John Stamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-03 21:55 UTC by Simeon Bird
Modified: 2018-10-29 22:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simeon Bird 2011-04-03 21:55:52 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

When using the knemo system tray icon, knemo 0.7.1, I see a pixmap leak in plasma using xrestop, with the text or netload themes. The increase in pixmaps is on roughly the same frequency as the text updates.

Thanks

Reproducible: Always

Steps to Reproduce:
1. Start knemo to system tray
2. Change to netload or text theme
3. Start xrestop


Actual Results:  
I observe that the "Pxms" column increases by two every few seconds for plasma-desktop, as does "Pxm mem", without user activity. This stops when changing the knemo theme. 

Expected Results:  
Pixmap usage may fluctuate a little, but does not increase without limit.

Xorg 1.9.4.901, kernel 2.6.37.5
Comment 1 John Stamp 2011-04-12 01:30:03 UTC
SVN commit 1227676 by jstamp:

Clear QPixmapCache since we're never going to reuse the generated icons

BUG:270030

 M  +3 -0      interfaceicon.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1227676
Comment 2 Andrew Crouthamel 2018-10-29 22:08:19 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I will be closing this bug.