Bug 269891 - kwin crashes when I try to dismiss the screensaver
Summary: kwin crashes when I try to dismiss the screensaver
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-01 19:37 UTC by barrettmccormick
Modified: 2011-04-01 19:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description barrettmccormick 2011-04-01 19:37:44 UTC
Application: kwin (4.6.1 (4.6.1))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:  I was away from the computer for several hours during which time the screensaver was active.  After this happened several times with kscreensaver, I installed xscreensaver and the same thing happened again.

- Unusual behavior I noticed:  The display is corrupted.  The logon dialogue seems to be displayed, but at first won't accept input to the password field.  Some regions on the screen display information from inappropriate windows.  Portions of the logon dialog window may intermittently disappear.  Switching to a console and killing the screensaver may or may not solve the problem.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb29ca720 (LWP 27926))]

Thread 3 (Thread 0xad9dcb70 (LWP 27932)):
#0  0xb395ce36 in clock_gettime () from /lib/librt.so.1
#1  0xb64d050b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb65a76e5 in QTimerInfoList::updateCurrentTime (this=0x8a81d28) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb65a772a in QTimerInfoList::timerWait (this=0x8a81d28, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb65a8cab in QEventDispatcherUNIX::processEvents (this=0x89a0890, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0xb6575609 in QEventLoop::processEvents (this=0xad9dc280, flags=) at kernel/qeventloop.cpp:149
#7  0xb6575a8a in QEventLoop::exec (this=0xad9dc280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6471b7e in QThread::exec (this=0x88bedd8) at thread/qthread.cpp:490
#9  0xb655435b in QInotifyFileSystemWatcherEngine::run (this=0x88bedd8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6474df9 in QThreadPrivate::start (arg=0x88bedd8) at thread/qthread_unix.cpp:266
#11 0xb39f0cc9 in start_thread () from /lib/libpthread.so.0
#12 0xb766e69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xad1dbb70 (LWP 27933)):
#0  0xb783a424 in __kernel_vsyscall ()
#1  0xb39f54dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb767bd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb6da0877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6e9f1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6da08c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6e9f1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb39f0cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb766e69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb29ca720 (LWP 27926)):
[KCrash Handler]
#7  0xaf8afee0 in ?? () from /usr/lib/dri/i965_dri.so
#8  0xaf8a2687 in ?? () from /usr/lib/dri/i965_dri.so
#9  0xaf8a4b27 in ?? () from /usr/lib/dri/i965_dri.so
#10 0xaf914fba in ?? () from /usr/lib/dri/i965_dri.so
#11 0xb77eba9b in KWin::SceneOpenGL::paintBackground (this=0x8344120, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0xb77de672 in KWin::Scene::paintGenericScreen (this=0x8344120, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:188
#13 0xb77ebca5 in KWin::SceneOpenGL::paintGenericScreen (this=0x8344120, mask=<value optimized out>, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0xb77db6c0 in KWin::Scene::finalPaintScreen (this=0x8344120, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0xb77ff3dc in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0xaf1aadb9 in KWin::StartupFeedbackEffect::paintScreen (this=0x89ef860, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0xb6ba1846 in KWin::Effect::paintScreen (this=0x893cb50, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0xaf13f336 in KWin::LogoutEffect::paintScreen (this=0x8944d40, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0xaf162b0f in KWin::ShadowEffect::paintScreen (this=0x8c2bf30, mask=<value optimized out>, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0xaf1781c3 in KWin::BlurEffect::paintScreen (this=0x88afcb0, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0xaf1457af in KWin::PresentWindowsEffect::paintScreen (this=0x8c4b168, mask=32, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0xb6ba1846 in KWin::Effect::paintScreen (this=0x88bb250, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8b314d8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8c5cd00, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8bf36b8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8640db8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0xb6ba1846 in KWin::Effect::paintScreen (this=0x88a1688, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#39 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0xaf127c32 in KWin::DesktopGridEffect::paintScreen (this=0x8c37288, mask=32, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#41 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0xaf189374 in KWin::CubeEffect::paintScreen (this=0x88b14c0, mask=32, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0xb6ba1846 in KWin::Effect::paintScreen (this=0x893c150, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0xb6ba1846 in KWin::Effect::paintScreen (this=0x89d8390, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0xaf190cd3 in KWin::CubeSlideEffect::paintScreen (this=0x88c1c38, mask=32, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#49 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8a31700, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8aa45f0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0xaf17f90c in KWin::CoverSwitchEffect::paintScreen (this=0x8bccde0, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#55 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0xb6ba1846 in KWin::Effect::paintScreen (this=0x89349c8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0xb6ba1846 in KWin::Effect::paintScreen (this=0x88bdf98, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#59 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0xb6ba1846 in KWin::Effect::paintScreen (this=0x8be8720, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#61 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#62 0xaf174d99 in KWin::ZoomEffect::paintScreen (this=0x8bc99d8, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#63 0xb77ff460 in KWin::EffectsHandlerImpl::paintScreen (this=0x863b8b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#64 0xb77dcea4 in KWin::Scene::paintScreen (this=0x8344120, mask=0xbffe0554, region=0xbffe0600) at ../../kwin/scene.cpp:137
#65 0xb77f384a in KWin::SceneOpenGL::paint (this=0x8344120, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#66 0xb77d7bf7 in KWin::Workspace::performCompositing (this=0x82ec230) at ../../kwin/composite.cpp:448
#67 0xb6589504 in QObject::event (this=0x82ec230, e=0x83104d0) at kernel/qobject.cpp:1183
#68 0xb5a75fdc in QApplicationPrivate::notify_helper (this=0x8251aa0, receiver=0x82ec230, e=0xbffe0b40) at kernel/qapplication.cpp:4396
#69 0xb5a7c04e in QApplication::notify (this=0xbffe0e64, receiver=0x82ec230, e=0xbffe0b40) at kernel/qapplication.cpp:3798
#70 0xb73ae7da in KApplication::notify (this=0xbffe0e64, receiver=0x82ec230, event=0xbffe0b40) at ../../kdeui/kernel/kapplication.cpp:311
#71 0xb7760d0f in KWin::Application::notify (this=0xbffe0e64, o=0x82ec230, e=0xbffe0b40) at ../../kwin/main.cpp:376
#72 0xb6576b3b in QCoreApplication::notifyInternal (this=0xbffe0e64, receiver=0x82ec230, event=0xbffe0b40) at kernel/qcoreapplication.cpp:732
#73 0xb65a8ad6 in sendEvent (this=0x8252228) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QTimerInfoList::activateTimers (this=0x8252228) at kernel/qeventdispatcher_unix.cpp:602
#75 0xb65a8c37 in QEventDispatcherUNIX::processEvents (this=0x8233ba0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#76 0xb5b390d2 in QEventDispatcherX11::processEvents (this=0x8233ba0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#77 0xb6575609 in QEventLoop::processEvents (this=0xbffe0d94, flags=) at kernel/qeventloop.cpp:149
#78 0xb6575a8a in QEventLoop::exec (this=0xbffe0d94, flags=...) at kernel/qeventloop.cpp:201
#79 0xb657a00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#80 0xb5a74e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#81 0xb7763d00 in kdemain (argc=3, argv=0xbffe10e4) at ../../kwin/main.cpp:542
#82 0x080485ab in main (argc=3, argv=0xbffe10e4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 269889, bug 269314, bug 268589, bug 268321, bug 268027.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-01 19:39:38 UTC
driver bug, do not use 2 OpenGL contexts at the same time on that driver or try
forcing indirect rendering "export LIBGL_ALWAYS_INDIRECT=1"

*** This bug has been marked as a duplicate of bug 252817 ***