Bug 269807 - Kontact startup without sycoca database shows disfunctional window
Summary: Kontact startup without sycoca database shows disfunctional window
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: enterprise
Platform: Unlisted Binaries Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-31 09:33 UTC by Andre Heinecke
Modified: 2011-05-18 18:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Picture of Kontact without sycoca (159.36 KB, image/png)
2011-04-18 14:44 UTC, Andre Heinecke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Heinecke 2011-03-31 09:33:49 UTC
Version:           enterprise (using Devel) 
OS:                MS Windows

When starting Kontact on Windows before akonadi was started sometimes there is only a window shown like a Kontact without any plugins.

Reproducible: Didn't try

Steps to Reproduce:
1) Have everything deleted, have a slow system
2) Start Kontact without starting akonadi first



I've seen this occur mainly on slow systems during the initial start.
Comment 1 Andre Heinecke 2011-04-15 12:47:11 UTC
The problem is a missing ksycoca database, since kbuildsycoca4 places the database into the users directory Kontact should wait until the database is generated.
Comment 2 Andre Heinecke 2011-04-18 14:44:54 UTC
Created attachment 59096 [details]
Picture of Kontact without sycoca
Comment 3 Andre Heinecke 2011-04-27 15:58:02 UTC
SVN commit 1229531 by aheinecke:

Add a patch to avoid a race condition during the first
startup of Kontact.

This Patch is added first to emerge for testing and not
yet in kdepim git.
CCBUG: 269807


 M  +2 -1      kdepim-e5-20110117.py  
 A             wait-for-KSycoca-to-become-available.patch  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1229531
Comment 4 Andre Heinecke 2011-05-18 18:54:06 UTC
Git commit f99de48495add01200a0434d99b080318eedb254 by Andre Heinecke.
Committed on 18/05/2011 at 18:52.
Pushed by aheinecke into branch 'master'.

Add a blocking waitForKSycoca function

    When Kontact is started on a system where no kded was ever
    started before there is a race condition between kontact querying
    the KSycoca database and the creation of that database.
    This caused Kontact not load any plugins in that case.

    This Patch causes Kontact to block for up to 10 seconds while
    waiting for KSycoca to become available.

    BUG: 269807

M  +29   -0    kontact/src/mainwindow.cpp     
M  +1    -0    kontact/src/mainwindow.h     

http://commits.kde.org/kdepim/f99de48495add01200a0434d99b080318eedb254