Bug 269800 - Kwin crashes when Compiz settings or KDE appearance settings are altered.
Summary: Kwin crashes when Compiz settings or KDE appearance settings are altered.
Status: RESOLVED DUPLICATE of bug 268027
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-31 04:59 UTC by Devlin
Modified: 2011-03-31 13:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devlin 2011-03-31 04:59:17 UTC
Application: kwin (4.6.1 (4.6.1))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-7-generic x86_64
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
Kwin crashes when Compiz settings or KDE appearance settings are altered. This has also happened at random. See attached info for details. Natty Narwhal 64bit AMD64 system.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5e79f237a0 (LWP 18659))]

Thread 3 (Thread 0x7f5e5da21700 (LWP 18665)):
#0  0x00007f5e75b1e6c1 in QMetaObject::activate (sender=0x1660640, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3331
#1  0x00007f5e75b36fce in QEventDispatcherUNIX::processEvents (this=0x1660640, flags=...) at kernel/qeventdispatcher_unix.cpp:890
#2  0x00007f5e75b08882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007f5e75b08abc in QEventLoop::exec (this=0x7f5e5da20db0, flags=...) at kernel/qeventloop.cpp:201
#4  0x00007f5e75a1f924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#5  0x00007f5e75aeac2f in QInotifyFileSystemWatcherEngine::run (this=0x1620f10) at io/qfilesystemwatcher_inotify.cpp:248
#6  0x00007f5e75a22175 in QThreadPrivate::start (arg=0x1620f10) at thread/qthread_unix.cpp:320
#7  0x00007f5e7011cd8c in start_thread (arg=0x7f5e5da21700) at pthread_create.c:304
#8  0x00007f5e79759f7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5e5d210700 (LWP 18666)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5e785ba2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f5e788d3180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f5e785ba2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f5e788e1254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f5e7011cd8c in start_thread (arg=0x7f5e5d210700) at pthread_create.c:304
#4  0x00007f5e79759f7d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5e79f237a0 (LWP 18659)):
[KCrash Handler]
#6  0x00007f5e611d5bfe in r600_bo (radeon=0x927900, size=64, alignment=4096, binding=32, usage=0) at r600_bo.c:43
#7  0x00007f5e611cb2f9 in r600_buffer_create (screen=0x927a70, templ=0x7fff1eef3520) at r600_buffer.c:62
#8  0x00007f5e6131d156 in pipe_buffer_create (st=0x1f71e00, params=0x1fa9440, shader_type=0) at ../../src/gallium/auxiliary/util/u_inlines.h:183
#9  st_upload_constants (st=0x1f71e00, params=0x1fa9440, shader_type=0) at state_tracker/st_atom_constbuf.c:80
#10 0x00007f5e6131c83c in st_validate_state (st=0x1f71e00) at state_tracker/st_atom.c:172
#11 0x00007f5e61322d7a in st_Clear (ctx=0xb58a50, mask=2) at state_tracker/st_cb_clear.c:469
#12 0x00007f5e79ae1af7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#13 0x00007f5e79ad969f in KWin::Scene::paintGenericScreen (this=0x138d370, orig_mask=552) at ../../kwin/scene.cpp:188
#14 0x00007f5e79ad6a8a in KWin::Scene::finalPaintScreen (this=0x138d370, mask=552, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#15 0x00007f5e79af4d29 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#16 0x00007f5e5fe09fb6 in KWin::StartupFeedbackEffect::paintScreen (this=0x12e3b70, mask=552, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#18 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=552, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#20 0x00007f5e5fdb12dd in KWin::LogoutEffect::paintScreen (this=0x1b4b420, mask=552, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#22 0x00007f5e5fdcc40b in KWin::ShadowEffect::paintScreen (this=0x1ea86b0, mask=552, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#24 0x00007f5e5fdde878 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=552, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#26 0x00007f5e5fdb5e4d in KWin::PresentWindowsEffect::paintScreen (this=0x217cf10, mask=520, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#28 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#30 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#32 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#34 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#36 0x00007f5e5fd9d325 in KWin::DesktopGridEffect::paintScreen (this=0x20932e0, mask=520, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#38 0x00007f5e5fd96b9d in KWin::BoxSwitchEffect::paintScreen (this=0x205a1b0, mask=520, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#39 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#40 0x00007f5e5fdecc66 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#41 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#42 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#43 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#44 0x00007f5e5fdf69b4 in KWin::CubeSlideEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#45 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#46 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#48 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#50 0x00007f5e5fde5796 in KWin::CoverSwitchEffect::paintScreen (this=0x1f76100, mask=520, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#52 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#54 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#56 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#58 0x00007f5e77ba4a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#59 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#60 0x00007f5e5fddbdab in KWin::ZoomEffect::paintScreen (this=0x202f8c0, mask=520, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#61 0x00007f5e79af4db3 in KWin::EffectsHandlerImpl::paintScreen (this=0x15bc530, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#62 0x00007f5e79ad8ebf in KWin::Scene::paintScreen (this=0x138d370, mask=0x7fff1eef531c, region=0x7fff1eef5400) at ../../kwin/scene.cpp:137
#63 0x00007f5e79aecd03 in KWin::SceneOpenGL::paint (this=0x138d370, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#64 0x00007f5e79ad4085 in KWin::Workspace::performCompositing (this=0xef8ac0) at ../../kwin/composite.cpp:442
#65 0x00007f5e75b1d1c9 in QObject::event (this=0xef8ac0, e=<value optimized out>) at kernel/qobject.cpp:1190
#66 0x00007f5e74eca9e4 in QApplicationPrivate::notify_helper (this=0x7fbc10, receiver=0xef8ac0, e=0x7fff1eef5b70) at kernel/qapplication.cpp:4462
#67 0x00007f5e74ecf3aa in QApplication::notify (this=<value optimized out>, receiver=0xef8ac0, e=0x7fff1eef5b70) at kernel/qapplication.cpp:4341
#68 0x00007f5e79255866 in KApplication::notify (this=0x7fff1eef5f70, receiver=0xef8ac0, event=0x7fff1eef5b70) at ../../kdeui/kernel/kapplication.cpp:311
#69 0x00007f5e75b0949c in QCoreApplication::notifyInternal (this=0x7fff1eef5f70, receiver=0xef8ac0, event=0x7fff1eef5b70) at kernel/qcoreapplication.cpp:731
#70 0x00007f5e75b36f12 in sendEvent (this=0x7fc760) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QTimerInfoList::activateTimers (this=0x7fc760) at kernel/qeventdispatcher_unix.cpp:604
#72 0x00007f5e75b3705b in QEventDispatcherUNIX::processEvents (this=0x7a6340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#73 0x00007f5e74f72c0c in QEventDispatcherX11::processEvents (this=0x7a6340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#74 0x00007f5e75b08882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#75 0x00007f5e75b08abc in QEventLoop::exec (this=0x7fff1eef5eb0, flags=...) at kernel/qeventloop.cpp:201
#76 0x00007f5e75b0cecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#77 0x00007f5e79a71ffc in kdemain (argc=<value optimized out>, argv=0x7fff1eef6608) at ../../kwin/main.cpp:542
#78 0x00007f5e79692eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff1eef6608, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff1eef65f8) at libc-start.c:226
#79 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 265365.

Possible duplicates by query: bug 268179, bug 268027, bug 267759, bug 265365.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-03-31 13:57:51 UTC
driver bug

*** This bug has been marked as a duplicate of bug 268027 ***