Bug 269612 - KTorrent 4.1.0 randomly crashed
Summary: KTorrent 4.1.0 randomly crashed
Status: RESOLVED DUPLICATE of bug 270127
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-28 15:46 UTC by EGD
Modified: 2011-04-08 12:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.43 KB, text/plain)
2011-04-01 08:08 UTC, littlebean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description EGD 2011-03-28 15:46:56 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

KTorrent it is launched all time. One-twice a day its operation is completed by
an error. Backtrace it is applied.

Reproducible: Didn't try




Application: KTorrent (ktorrent), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4558930 (LWP 22229))]

Thread 5 (Thread 0xb14ffb70 (LWP 22232)):
[KCrash Handler]
#7  0xb78200d8 in QHash<unsigned short, QHashDummyValue>::findNode (this=0x8a3a0d8, akey=@0xb14fea3e, ahp=0x0) at /usr/include/QtCore/qhash.h:885
#8  0xb781bf81 in contains (this=0x8194568, conn=..., readable=true, writeable=false) at /usr/include/QtCore/qhash.h:872
#9  contains (this=0x8194568, conn=..., readable=true, writeable=false) at /usr/include/QtCore/qset.h:86
#10 polling (this=0x8194568, conn=..., readable=true, writeable=false) at /usr/src/debug/libktorrent-1.1.0/src/utp/pollpipe.h:56
#11 utp::UTPServer::Private::wakeUpPollPipes (this=0x8194568, conn=..., readable=true, writeable=false) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserver.cpp:193
#12 0xb781c0ba in utp::UTPServer::stateChanged (this=0x820e240, conn=..., readable=true, writeable=false) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserver.cpp:476
#13 0xb7824193 in utp::Connection::checkState (this=0xa76f0dd0) at /usr/src/debug/libktorrent-1.1.0/src/utp/connection.cpp:284
#14 0xb78242ee in utp::Connection::handleTimeout (this=0xa76f0dd0) at /usr/src/debug/libktorrent-1.1.0/src/utp/connection.cpp:641
#15 0xb781e1c8 in utp::UTPServer::timerEvent (this=0x820e240, ev=0xb14ff08c) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserver.cpp:577
#16 0xb6986c04 in QObject::event (this=0x820e240, e=0xb14ff08c) at kernel/qobject.cpp:1181
#17 0xb5e7a684 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0xb5e83427 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x0807cb27 in kt::App::notify (this=0xbfb21ce0, receiver=0x820e240, event=0xb14ff08c) at /usr/src/debug/ktorrent-4.1.0/ktorrent/app.cpp:97
#20 0xb697178e in QCoreApplication::notifyInternal (this=0xbfb21ce0, receiver=0x820e240, event=0xb14ff08c) at kernel/qcoreapplication.cpp:731
#21 0xb69a2b89 in sendEvent (this=0x81be3f4) at kernel/qcoreapplication.h:215
#22 QTimerInfoList::activateTimers (this=0x81be3f4) at kernel/qeventdispatcher_unix.cpp:619
#23 0xb699f885 in timerSourceDispatch (source=0x8195300) at kernel/qeventdispatcher_glib.cpp:184
#24 idleTimerSourceDispatch (source=0x8195300) at kernel/qeventdispatcher_glib.cpp:231
#25 0xb4ec0509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0xb4ec0d10 in ?? () from /lib/libglib-2.0.so.0
#27 0xb4ec0fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0xb699ff7b in QEventDispatcherGlib::processEvents (this=0x81b9f88, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#29 0xb6970a6d in QEventLoop::processEvents (this=0xb14ff2e0, flags=...) at kernel/qeventloop.cpp:149
#30 0xb6970c99 in QEventLoop::exec (this=0xb14ff2e0, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6871d49 in QThread::exec (this=0x81b7e78) at thread/qthread.cpp:492
#32 0xb7821a7d in utp::UTPServerThread::run (this=0x81b7e78) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserverthread.cpp:41
#33 0xb6874993 in QThreadPrivate::start (arg=0x81b7e78) at thread/qthread_unix.cpp:320
#34 0xb67f8b05 in start_thread () from /lib/libpthread.so.0
#35 0xb5b69d5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xadf82b70 (LWP 22248)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb67fd105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb687393c in QMutexPrivate::wait (this=0x8126de8, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0xb686fe6a in QMutex::lock (this=0x8126dd0) at thread/qmutex.cpp:167
#4  0xb777423e in net::SocketMonitor::lock (this=0x811db00) at /usr/src/debug/libktorrent-1.1.0/src/net/socketmonitor.cpp:108
#5  0xb7775d01 in net::DownloadThread::update (this=0x8126ed8) at /usr/src/debug/libktorrent-1.1.0/src/net/downloadthread.cpp:51
#6  0xb7775f78 in net::NetworkThread::run (this=0x8126ed8) at /usr/src/debug/libktorrent-1.1.0/src/net/networkthread.cpp:48
#7  0xb6874993 in QThreadPrivate::start (arg=0x8126ed8) at thread/qthread_unix.cpp:320
#8  0xb67f8b05 in start_thread () from /lib/libpthread.so.0
#9  0xb5b69d5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xad781b70 (LWP 22249)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb67fd105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb687393c in QMutexPrivate::wait (this=0x81bc880, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0xb686fe6a in QMutex::lock (this=0x8194584) at thread/qmutex.cpp:167
#4  0xb781f477 in QMutexLocker (this=0x820e240, p=0x8127268, mode=net::Poll::OUTPUT, conn=...) at /usr/include/QtCore/qmutex.h:102
#5  utp::UTPServer::preparePolling (this=0x820e240, p=0x8127268, mode=net::Poll::OUTPUT, conn=...) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserver.cpp:452
#6  0xb7827de9 in utp::UTPSocket::prepare (this=0xb15c5770, p=0x8127268, mode=net::Poll::OUTPUT) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpsocket.cpp:212
#7  0xb77753a3 in net::UploadThread::waitForSocketsReady (this=0x8127260) at /usr/src/debug/libktorrent-1.1.0/src/net/uploadthread.cpp:124
#8  0xb77754ce in net::UploadThread::update (this=0x8127260) at /usr/src/debug/libktorrent-1.1.0/src/net/uploadthread.cpp:45
#9  0xb7775f78 in net::NetworkThread::run (this=0x8127260) at /usr/src/debug/libktorrent-1.1.0/src/net/networkthread.cpp:48
#10 0xb6874993 in QThreadPrivate::start (arg=0x8127260) at thread/qthread_unix.cpp:320
#11 0xb67f8b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5b69d5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xacf80b70 (LWP 22250)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb67fd105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6875080 in wait (this=0x8998ca4, mutex=0x8998ca0, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8998ca4, mutex=0x8998ca0, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb7779390 in net::ReverseResolverThread::run (this=0x8998c98) at /usr/src/debug/libktorrent-1.1.0/src/net/reverseresolver.cpp:123
#5  0xb6874993 in QThreadPrivate::start (arg=0x8998c98) at thread/qthread_unix.cpp:320
#6  0xb67f8b05 in start_thread () from /lib/libpthread.so.0
#7  0xb5b69d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4558930 (LWP 22229)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb67fd105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb687393c in QMutexPrivate::wait (this=0x81bc880, timeout=-1) at thread/qmutex_unix.cpp:84
#3  0xb686fe6a in QMutex::lock (this=0x8194584) at thread/qmutex.cpp:167
#4  0xb781c95f in QMutexLocker (this=0x820e240, addr=...) at /usr/include/QtCore/qmutex.h:102
#5  utp::UTPServer::connectTo (this=0x820e240, addr=...) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpserver.cpp:413
#6  0xb78274fe in utp::UTPSocket::connectTo (this=0xa7edc270, addr=...) at /usr/src/debug/libktorrent-1.1.0/src/utp/utpsocket.cpp:98
#7  0xb777c1eb in mse::StreamSocket::connectTo (this=0xae1ca1b8, addr=...) at /usr/src/debug/libktorrent-1.1.0/src/mse/streamsocket.cpp:212
#8  0xb77800a3 in bt::Authenticate::Authenticate (this=0xa6ef0760, ip=..., port=51413, proto=bt::UTP, info_hash=..., peer_id=..., pcon=...) at /usr/src/debug/libktorrent-1.1.0/src/peer/authenticate.cpp:68
#9  0xb777d697 in mse::EncryptedAuthenticate::EncryptedAuthenticate (this=0xa6ef0760, ip=..., port=51413, proto=bt::UTP, info_hash=..., peer_id=..., pcon=...) at /usr/src/debug/libktorrent-1.1.0/src/mse/encryptedauthenticate.cpp:46
#10 0xb7799b60 in bt::PeerConnector::Private::start (this=0xa84f8c18, method=bt::PeerConnector::UTP_WITH_ENCRYPTION) at /usr/src/debug/libktorrent-1.1.0/src/peer/peerconnector.cpp:179
#11 0xb7799d39 in bt::PeerConnector::acquired (this=0xae3ed288) at /usr/src/debug/libktorrent-1.1.0/src/peer/peerconnector.cpp:108
#12 0xb776a8e9 in bt::ResourceManager::update (this=0xb78ad884) at /usr/src/debug/libktorrent-1.1.0/src/util/resourcemanager.cpp:109
#13 0xb776ae9f in bt::ResourceManager::add (this=0xb78ad884, r=0xae3ed288) at /usr/src/debug/libktorrent-1.1.0/src/util/resourcemanager.cpp:63
#14 0xb7799605 in bt::PeerConnector::start (this=0xae3ed288) at /usr/src/debug/libktorrent-1.1.0/src/peer/peerconnector.cpp:93
#15 0xb77903aa in bt::PeerManager::Private::connectToPeers (this=0x8230210) at /usr/src/debug/libktorrent-1.1.0/src/peer/peermanager.cpp:858
#16 0xb779058e in bt::PeerManager::connectToPeers (this=0x81bec60) at /usr/src/debug/libktorrent-1.1.0/src/peer/peermanager.cpp:320
#17 0xb77c8609 in bt::TorrentControl::update (this=0x81bed88) at /usr/src/debug/libktorrent-1.1.0/src/torrent/torrentcontrol.cpp:171
#18 0x0806e4ce in kt::Core::update (this=0xb1502b18) at /usr/src/debug/ktorrent-4.1.0/ktorrent/core.cpp:1052
#19 0x08075cd0 in kt::Core::qt_metacall (this=0xb1502b18, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb2148c) at /usr/src/debug/ktorrent-4.1.0/build/ktorrent/core.moc:164
#20 0xb697807d in QMetaObject::metacall (object=0xb1502b18, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbfb2148c) at kernel/qmetaobject.cpp:237
#21 0xb69874cc in QMetaObject::activate (sender=0xb1502b2c, m=0xb6aac5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#22 0xb69d76a5 in QTimer::timeout (this=0xb1502b2c) at .moc/release-shared/moc_qtimer.cpp:134
#23 0xb698e856 in QTimer::timerEvent (this=0xb1502b2c, e=0xbfb219ac) at kernel/qtimer.cpp:271
#24 0xb6986c04 in QObject::event (this=0xb1502b2c, e=0xbfb219ac) at kernel/qobject.cpp:1181
#25 0xb5e7a684 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb5e83427 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0x0807cb27 in kt::App::notify (this=0xbfb21ce0, receiver=0xb1502b2c, event=0xbfb219ac) at /usr/src/debug/ktorrent-4.1.0/ktorrent/app.cpp:97
#28 0xb697178e in QCoreApplication::notifyInternal (this=0xbfb21ce0, receiver=0xb1502b2c, event=0xbfb219ac) at kernel/qcoreapplication.cpp:731
#29 0xb69a2b89 in sendEvent (this=0x81647fc) at kernel/qcoreapplication.h:215
#30 QTimerInfoList::activateTimers (this=0x81647fc) at kernel/qeventdispatcher_unix.cpp:619
#31 0xb699f885 in timerSourceDispatch (source=0x8164830) at kernel/qeventdispatcher_glib.cpp:184
#32 idleTimerSourceDispatch (source=0x8164830) at kernel/qeventdispatcher_glib.cpp:231
#33 0xb4ec0509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0xb4ec0d10 in ?? () from /lib/libglib-2.0.so.0
#35 0xb4ec0fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0xb699ff7b in QEventDispatcherGlib::processEvents (this=0x8125a50, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#37 0xb5f311da in ?? () from /usr/lib/libQtGui.so.4
#38 0xb6970a6d in QEventLoop::processEvents (this=0xbfb21c54, flags=...) at kernel/qeventloop.cpp:149
#39 0xb6970c99 in QEventLoop::exec (this=0xbfb21c54, flags=...) at kernel/qeventloop.cpp:201
#40 0xb6975740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#41 0xb5e783d4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#42 0x0806ba41 in main (argc=) at /usr/src/debug/ktorrent-4.1.0/ktorrent/main.cpp:177
Comment 1 littlebean 2011-04-01 08:08:54 UTC
Created attachment 58493 [details]
New crash information added by DrKonqi

Prodotto: ktorrent (general)
Descrizione dell'errore
Application: ktorrent (4.0.1)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.7-desktop-2mnb i686
Distribution: Mandriva 2010.2

-- Information about the crash:
Machine left on overnight downloading and ktorrent crashed sometime during the night with no other access or use of the machine going on.

KTorrent 4.1.0 randomly crashed

KTorrent it is launched all time. One-twice a day its operation is completed by
an error.

Reproducible: yes
Comment 2 EGD 2011-04-07 17:32:51 UTC
If unset 'Use muTP protocol' bug not reproduced
Comment 3 Joris Guisson 2011-04-08 12:18:40 UTC

*** This bug has been marked as a duplicate of bug 270127 ***