Bug 269504 - Kwin crashes always after resuming from am Open GL screensaver
Summary: Kwin crashes always after resuming from am Open GL screensaver
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-27 00:52 UTC by someone
Modified: 2011-03-27 08:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description someone 2011-03-27 00:52:37 UTC
Application: kwin (4.6.1 (4.6.1) "release 390")
KDE Platform Version: 4.6.1 (4.6.1) "release 390"
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- Custom settings of the application: as this crash appeared, I was trying and testing the screensaver Euphoria. After ending this test, Kwin crashed. 
Also, when an Open GL screensaver is set in systemsettings and it is activated, Kwin crashes after resuming.
The same goes for waking up from Hibernate and Standby. 

Never happens with other (non Open GL) screensavers

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc6c06dd760 (LWP 2009))]

Thread 2 (Thread 0x7fc6a2df6700 (LWP 2014)):
#0  0x00007fc6bbfaa38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc6beda8004 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fc6bf0c1180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fc6beda8039 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fc6bf0cf254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fc6bbfa5a3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc6bff3a67d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc6c06dd760 (LWP 2009)):
[KCrash Handler]
#6  0x00007fc6a81c0ab0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007fc6a81b42d4 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007fc6a81b67da in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007fc6c029f725 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/scene_opengl.cpp:921
#10 0x00007fc6c0296e96 in KWin::Scene::paintGenericScreen (this=0x765fe0, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/scene.cpp:188
#11 0x00007fc6c0293fea in KWin::Scene::finalPaintScreen (this=0x765fe0, mask=32, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/scene.cpp:178
#12 0x00007fc6c02b148f in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:173
#13 0x00007fc6a357a1ab in KWin::StartupFeedbackEffect::paintScreen (this=0x1e01080, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#15 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#16 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#17 0x00007fc6a352136f in KWin::LogoutEffect::paintScreen (this=0x1ea7830, mask=32, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/logout/logout.cpp:207
#18 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#19 0x00007fc6a353bfa2 in KWin::ShadowEffect::paintScreen (this=0x1b05450, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/shadow/shadow.cpp:189
#20 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#21 0x00007fc6a354e92e in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/blur/blur.cpp:230
#22 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#23 0x00007fc6a3525df2 in KWin::PresentWindowsEffect::paintScreen (this=0x1ea9840, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#25 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#26 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#27 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#28 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#29 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#30 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#31 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#32 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#33 0x00007fc6a350c653 in KWin::DesktopGridEffect::paintScreen (this=0x1ec98a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#35 0x00007fc6a354277d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/slide/slide.cpp:86
#36 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#37 0x00007fc6a3505ed2 in KWin::BoxSwitchEffect::paintScreen (this=0x1ea0970, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#39 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#40 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#41 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#42 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#43 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#44 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#45 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#46 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#47 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#48 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#49 0x00007fc6be397f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/lib/kwineffects.cpp:227
#50 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#51 0x00007fc6a354bfaf in KWin::ZoomEffect::paintScreen (this=0x1eabb80, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects/zoom/zoom.cpp:341
#52 0x00007fc6c02b151c in KWin::EffectsHandlerImpl::paintScreen (this=0xa95350, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/effects.cpp:169
#53 0x00007fc6c02950a5 in KWin::Scene::paintScreen (this=0x765fe0, mask=0x7fff1d4be1dc, region=0x7fff1d4be2d0) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/scene.cpp:137
#54 0x00007fc6c02a95e9 in KWin::SceneOpenGL::paint (this=0x765fe0, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/scene_opengl.cpp:772
#55 0x00007fc6c02917c7 in KWin::Workspace::performCompositing (this=0xa9d520) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/composite.cpp:448
#56 0x00007fc6bc3330a9 in QObject::event (this=0xa9d520, e=<value optimized out>) at kernel/qobject.cpp:1181
#57 0x00007fc6bb4ca144 in QApplicationPrivate::notify_helper (this=0x634fc0, receiver=0xa9d520, e=0x7fff1d4beb10) at kernel/qapplication.cpp:4462
#58 0x00007fc6bb4d26fa in QApplication::notify (this=<value optimized out>, receiver=0xa9d520, e=0x7fff1d4beb10) at kernel/qapplication.cpp:4341
#59 0x00007fc6bf9b2d46 in KApplication::notify (this=0x7fff1d4beff0, receiver=0xa9d520, event=0x7fff1d4beb10) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#60 0x00007fc6bc31f47c in QCoreApplication::notifyInternal (this=0x7fff1d4beff0, receiver=0xa9d520, event=0x7fff1d4beb10) at kernel/qcoreapplication.cpp:731
#61 0x00007fc6bc34cdf8 in sendEvent (this=0x6359d0) at kernel/qcoreapplication.h:215
#62 QTimerInfoList::activateTimers (this=0x6359d0) at kernel/qeventdispatcher_unix.cpp:619
#63 0x00007fc6bc34d500 in QEventDispatcherUNIX::processEvents (this=0x612390, flags=...) at kernel/qeventdispatcher_unix.cpp:938
#64 0x00007fc6bb5709cc in QEventDispatcherX11::processEvents (this=0x612390, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#65 0x00007fc6bc31e8d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#66 0x00007fc6bc31eae5 in QEventLoop::exec (this=0x7fff1d4beee0, flags=...) at kernel/qeventloop.cpp:201
#67 0x00007fc6bc322f2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#68 0x00007fc6c022fc8a in kdemain (argc=<value optimized out>, argv=0x7fff1d4bf050) at /usr/src/debug/kdebase-workspace-4.6.1/kwin/main.cpp:542
#69 0x00007fc6bfe85bfd in __libc_start_main () from /lib64/libc.so.6
#70 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 269314, bug 268589, bug 268394, bug 268321, bug 268027.

Reported using DrKonqi
Comment 1 someone 2011-03-27 05:04:26 UTC
I was testing the screensaver in systemsettings (Button "test").
Comment 2 Martin Flöser 2011-03-27 08:30:53 UTC
best don't use OpenGL screensavers when using Intel drivers.

*** This bug has been marked as a duplicate of bug 252817 ***