Bug 269454 - increase the size of the musicbrainz dialog, because it is way to small
Summary: increase the size of the musicbrainz dialog, because it is way to small
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Metadata Editing and Reading (show other bugs)
Version: 2.4.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-26 11:26 UTC by andreaswuest
Modified: 2013-05-14 20:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments
musizbrainz dialog with default size -> is just too small to be usable (25.86 KB, image/png)
2011-03-26 11:26 UTC, andreaswuest
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreaswuest 2011-03-26 11:26:07 UTC
Created attachment 58350 [details]
musizbrainz dialog with default size -> is just too small to be usable

Version:           2.4.0 (using KDE 4.5.1) 
OS:                Linux

Hi,

please increase the size of the musicbrainz dialog, because the default size
is way to small to be usable. you always have to increase the size to be able to read the found tracks (and to differentiate them). each of the columns then also needs a new sensible width.

additionally the displayed tree (if results are found) should be open (not closed) so the user can immediately see the found results. otherwise you always have to open the tree by clicking on the result. 


Reproducible: Always
Comment 1 Myriam Schweingruber 2011-03-26 12:24:52 UTC
You can change the size of the window yourself, just point your mouse to the window border and change it, ditto for the columns in the window. Not a bug.

Also please do not report two items per bug, but file a different one or each.
Comment 2 andreaswuest 2011-03-26 13:07:18 UTC
first of all. it is not a bug, it is a wish. and imho a sensible usability improvement. 

second. i know how to resize the dialog! the problem is, that the dialog is so small that it is just not usable (because you cannot read the information that is displayed!). every time (!) i open that dialog i have to resize it to make it usable (readable) which is super-annoying. opening the dialog with a more sensible size would improve my (and probably other people's) life.

for example: if amarok would always start with a fixed size of 100x50 pixel, amarok would not be usable. you would have to resize it manually to a more sensible size, to make it usable. i am sure you would not be happy if you had to resize the amarok window every time you start the application.

=> i am reopening the issue.

sorry for ranting.
Comment 3 Matěj Laitl 2013-05-14 20:21:40 UTC
Git commit 0fbb6236d70334c6e05ee1041cc704edf2f9e1a4 by Matěj Laitl.
Committed on 14/05/2013 at 14:10.
Pushed by laitl into branch 'master'.

MusicBrainzTagger: remember dialog size

BUGFIXES:
 * Fix suboptimal initial MusicBrainz tag dialog size by remembering it
FIXED-IN: 2.8
CCMAIL: Alberto Villa <avilla@freebsd.org>

M  +1    -0    ChangeLog
M  +4    -0    src/dialogs/MusicBrainzTagger.cpp

http://commits.kde.org/amarok/0fbb6236d70334c6e05ee1041cc704edf2f9e1a4