Bug 269333 - MozillaFirefox not found
Summary: MozillaFirefox not found
Status: RESOLVED DOWNSTREAM
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-24 19:44 UTC by bkorb
Modified: 2011-04-02 17:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bkorb 2011-03-24 19:44:20 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

The /usr/share/applications file name is "firefox.desktop",
not "MozillaFirefox.desktop".  linking the latter to the
former fixes it, but it should get installed correctly.

Reproducible: Didn't try

Steps to Reproduce:
Install openSuSE 11.4

Actual Results:  
Download a desktop image that requires firing up a browser and have firefox
be your default browser.

Expected Results:  
It would work correctly.  Instead, it cannot find "MozillaFirefox".
It needs to be looking for "firefox".  And, yes, "firefox" has been
set to be the default browser.  That's why it's looking for
MozillaFirefox.  There be a disconnect.
Comment 1 Christoph Feck 2011-03-24 20:54:48 UTC
Please report this to the bug tracker of your distribution at https://bugzilla.novell.com/
Comment 2 Thorsten Staerk 2011-04-02 11:07:56 UTC
what's this about? You report

The /usr/share/applications file name is "firefox.desktop",
not "MozillaFirefox.desktop".  linking the latter to the
former fixes it, but it should get installed correctly.

fixes what? You do not describe a problem at all.
Comment 3 bkorb 2011-04-02 17:23:14 UTC
The problem is that when you invoke some application (like wall paper downloading) that wants to fire up your browser, it tries to kick off "MozillaFirefox".  To do this, it looks for a file named, "MozillaFirefox.desktop" in the /usr/share/applications directory.  There is no such file.  There is, however, a file named, "firefox.desktop".  How that all really works is black magic to me.  All I know is that if I go in as  root and link these two together, then all is fine.  Same problem with MozillaThunderbird.