Bug 269321 - konsole adds spaces to end of certain lines when copying text from mutt
Summary: konsole adds spaces to end of certain lines when copying text from mutt
Status: RESOLVED DUPLICATE of bug 188528
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-24 17:45 UTC by Bo Milvang-Jensen
Modified: 2011-10-16 06:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bo Milvang-Jensen 2011-03-24 17:45:50 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

After switching from RedHat 4 (KDE 3.x?) to Kubuntu 10.10 (KDE 4.6.1), I have a problem with Terminal when I use the terminal-based e-mail client mutt [version 1.5.20] ( http://www.mutt.org/ ): when I copy an e-mail displayed in mutt, the "header" lines (those starting with Date:, From:, Subject:) get padded with spaces at the end, to the width of the terminal. This only happens to the displayed header lines and not to the displayed lines of the body of the e-mail! I do not have this problem if I use gnome-terminal and xterm.

Note: the problem relates to the terminal in which mutt is run and from which the text is copied, not to the terminal in which I run vim and into which the text is pasted.

Note: the unwanted spaces are easily seen if pasting into vim and then doing :set list

This bug looks similar to "Bug 188528 -  konsole's history adds spaces to end of lines when copying text", but I cannot reproduce the example in that bug.

Reproducible: Always

Steps to Reproduce:
See above.



OS: Linux (x86_64) release 2.6.35-28-generic
Compiler: cc
Comment 1 Jekyll Wu 2011-10-15 09:05:26 UTC
I think this is actually a duplicate of bug #188528. See its comment #50, #58, and #74. 

That report actually tracks two different but related problems. The first problem(in the original report) has been fixed, but the fix is not perfect and causes the second problem(since comment #44 )
Comment 2 Jekyll Wu 2011-10-16 06:21:54 UTC

*** This bug has been marked as a duplicate of bug 188528 ***