Bug 269301 - does not detect NFS file systems or ZFS file systems
Summary: does not detect NFS file systems or ZFS file systems
Status: RESOLVED DOWNSTREAM
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid-udisks (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lukáš Tinkl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-24 11:41 UTC by Manuel Amador (Rudd-O)
Modified: 2011-11-07 22:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Amador (Rudd-O) 2011-03-24 11:41:15 UTC
Version:           unspecified
OS:                Linux

As per the debugging info here:

https://bugs.kde.org/show_bug.cgi?id=249760

you can see my fstab (note the nfs filesystem)


proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda1 on /boot type ext4 (rw,noatime)
tmpfs on /tmp type tmpfs (rw,noexec,nosuid,noatime)
cgroup on /sys/fs/cgroup type proc (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/proc/bus/usb on /proc/bus/usb type usbfs (rw,devgid=1011,devmode=664)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/rudd-o/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=rudd-o)
laptop on / type zfs (rw)
laptop/home on /home type zfs (rw)
laptop/home/rudd-o on /home/rudd-o type zfs (rw)
laptop/home/rudd-o/.wine on /home/rudd-o/.wine type zfs (rw)
laptop/home/rudd-o/Imagenes on /home/rudd-o/Imágenes type zfs (rw)
laptop/home/rudd-o/Personal on /home/rudd-o/Personal type zfs (rw)
laptop/home/rudd-o/Projects on /home/rudd-o/Projects type zfs (rw)
laptop/home/rudd-o/Virtual machines on /home/rudd-o/Virtual machines type zfs (rw)
laptop/home/rudd-o/download on /home/rudd-o/download type zfs (rw)
laptop/home/rudd-o/tmp on /home/rudd-o/tmp type zfs (rw)
laptop/opt on /opt type zfs (rw)
laptop/usr/local on /usr/local type zfs (rw)
laptop/usr/share/doc on /usr/share/doc type zfs (rw)
laptop/usr/share/javadoc on /usr/share/javadoc type zfs (rw)
laptop/usr/src on /usr/src type zfs (rw)
laptop/var/cache on /var/cache type zfs (rw)
laptop/var/spool on /var/spool type zfs (rw)
laptop/usr/lib/debug on /usr/lib/debug type zfs (rw)
paola.local:/export/shared on /var/shared type nfs (rw,sync,noatime,fsc,vers=3,retry=0,bg,addr=10.254.102.1)
/dev/zd0 on /var/cache/fscache type ext4 (rw,noatime,user_xattr,nobh,barrier=0,data=writeback)

and then


solid-hardware list
udi = '/org/kde/solid/udev/sys/devices/LNXSYSTM:00/LNXCPU:00'
udi = '/org/kde/solid/udev/sys/devices/LNXSYSTM:00/LNXCPU:01'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.0/video4linux/video0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/hwC0D0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D0c'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/pcmC0D0p'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/controlC0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/net/eth0'
udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/net/wlan0'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS0'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS1'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS2'
udi = '/org/kde/solid/udev/sys/devices/platform/serial8250/tty/ttyS3'
udi = '/org/kde/solid/udev/sys/devices/virtual/net/lo'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/seq'
udi = '/org/kde/solid/udev/sys/devices/virtual/sound/timer'
udi = '/org/freedesktop/UDisks'
udi = '/org/freedesktop/UDisks/devices/sda3'
udi = '/org/freedesktop/UDisks/devices/zd0'
udi = '/org/freedesktop/UDisks/devices/sda'
udi = '/org/freedesktop/UDisks/devices/sr0'
udi = '/org/freedesktop/UDisks/devices/sda1'
udi = '/org/freedesktop/UDisks/devices/sdb'
udi = '/org/freedesktop/UDisks/devices/sda2'
udi = '/org/freedesktop/UPower'
udi = '/org/freedesktop/UPower/devices/line_power_ADP0'
udi = '/org/freedesktop/UPower/devices/battery_BAT0'

the NFS volume is nowhere to be found.  This makes amarok think that the music is directly on the root volume.

In addition to that, the root file system is on a ZFS dataset, and, of course, solid is unaware of it.  Therefore, this makes Amarok think that there are no volumes.

End result is that Amarok does not register any devices, the music is stored in the database with a fake ID -1 for a device, and the removable / network collection feature just does not work.

I am sure other applications that use solid to determine the availability of volumes and identification of files per volume will be afflicted with the same malady.

Reproducible: Didn't try



Expected Results:  
Have solid tell client applications of both ZFS file systems and NFS network file systems known to the system / mounted on the system.
Comment 1 Manuel Amador (Rudd-O) 2011-04-06 16:03:20 UTC
What is going on with this bug?
Comment 2 Manuel Amador (Rudd-O) 2011-07-11 12:42:55 UTC
What is going on?
Comment 3 Manuel Amador (Rudd-O) 2011-07-28 06:48:04 UTC
Hello?

If it helps, the systemsettings service manager shows Hardware Detection on-demand service shows as Not Running.

Help?
Comment 4 Manuel Amador (Rudd-O) 2011-08-27 23:10:27 UTC
Bug CONTINUES:


~@karen.dragonfear α:
solid-hardware query 'IS StorageAccess'
udi = '/org/freedesktop/UDisks/devices/sda1'


--------------------


~@karen.dragonfear α:
rpm -q kdelibs
kdelibs-4.6.5-2.fc15.x86_64

~@karen.dragonfear α:
Comment 5 Manuel Amador (Rudd-O) 2011-08-28 00:08:21 UTC
Same problem, 4.7.0

~@karen.dragonfear α:
rpm -q kdelibs
kdelibs-4.7.0-1.fc15.x86_64

~@karen.dragonfear α:
Comment 6 Manuel Amador (Rudd-O) 2011-11-07 20:56:31 UTC
For comparison, on Ubuntu (Kubuntu kde packages, latest release):

------------------------------


~@arianna.company α:
solid-hardware query 'IS StorageAccess'
udi = '/org/freedesktop/UDisks/devices/sda4'
udi = '/org/freedesktop/UDisks/devices/dm_2d2'
udi = '/org/freedesktop/UDisks/devices/sda1'
udi = '/org/freedesktop/UDisks/devices/sda2'
udi = '/org/freedesktop/UDisks/devices/sda3'
udi = '/org/kde/fstab///10.254.102.1/shared'
udi = '/org/kde/fstab///172.16.1.185/sdcard' <-!!!! SEE?

What is going on with fedora then?
Comment 7 Manuel Amador (Rudd-O) 2011-11-07 21:04:42 UTC
On Fedora:

----------------------------


[testuser@karen ~]$ strace -ff -efile solid-hardware query 'IS StorageAccess' 2>&1 | grep -v ENOENT | grep open | grep -v /lib ; solid-hardware query 'IS StorageAccess'
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/proc/filesystems", O_RDONLY)     = 3
open("/etc/localtime", O_RDONLY)        = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/etc/nsswitch.conf", O_RDONLY)    = 3
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/kde-settings/kde-profile/default/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/etc/udev/udev.conf", O_RDONLY|O_CLOEXEC) = 7
open("/dev/urandom", O_RDONLY|O_CLOEXEC) = 9
open("/proc/stat", O_RDONLY|O_CLOEXEC)  = 10
open("/proc/stat", O_RDONLY|O_CLOEXEC)  = 13
udi = '/org/freedesktop/UDisks/devices/sda1'
Comment 8 Manuel Amador (Rudd-O) 2011-11-07 21:04:59 UTC
On Ubuntu:

-----------------------------

~@arianna.twilio α:
strace -ff -efile solid-hardware query 'IS StorageAccess' 2>&1 | grep -v ENOENT | grep open | grep -v /lib ; solid-hardware query 'IS StorageAccess'
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/etc/localtime", O_RDONLY)        = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/home/rudd-o/.kde/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/etc/kde4rc", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/kubuntu-default-settings/kde4-profile/default/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/home/rudd-o/.kde/share/config/kdeglobals", O_RDONLY|O_CLOEXEC) = 3
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/etc/udev/udev.conf", O_RDONLY|O_CLOEXEC) = 6
open("/etc/fstab", O_RDONLY)            = 7
[pid 24130] open("/proc/stat", O_RDONLY|O_CLOEXEC) = 10
udi = '/org/freedesktop/UDisks/devices/sda4'
udi = '/org/freedesktop/UDisks/devices/dm_2d2'
udi = '/org/freedesktop/UDisks/devices/sda1'
udi = '/org/freedesktop/UDisks/devices/sda2'
udi = '/org/freedesktop/UDisks/devices/sda3'
udi = '/org/kde/fstab///10.254.102.1/shared'
udi = '/org/kde/fstab///172.16.1.185/sdcard'
Comment 9 Kevin Kofler 2011-11-07 22:01:32 UTC
Caused by a Fedora patch, moving downstream:
https://bugzilla.redhat.com/show_bug.cgi?id=751879