Bug 269276 - remove private class documentation
Summary: remove private class documentation
Status: RESOLVED WORKSFORME
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-24 02:39 UTC by sacha schutz
Modified: 2015-01-27 22:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sacha schutz 2011-03-24 02:39:01 UTC
Version:           unspecified
OS:                Linux

In the api.kde.org, we can see Private Class documentation.. That's ugly and not easy to find usefull information.
For example : Who need this information ?
http://api.kde.org/4.x-api/kdelibs-apidocs/knewstuff/html/classKNS3_1_1DownloadWidgetPrivate.html

Reproducible: Didn't try


Actual Results:  
Private class are shown in api.kde.org

Expected Results:  
only public class like qt documentation

example : 

http://api.kde.org/4.x-api/kdelibs-apidocs/knewstuff/html/classKNS3_1_1DownloadWidgetPrivate.html
Comment 1 Allen Winter 2013-08-27 23:01:14 UTC
easy enough to fix.  and we already exclude  *_p.cpp files

so I'm trying to remember why we don't also exclude *_p.h
there must have been a good reason, but I can't remember 


might be something like this:  we want _p.h files to be properly documented, so we want our tools to process them.  but then again we don't necessarily need the documentation publicly available on api.kde.org.  so quandry.
Comment 2 Will Entriken 2015-01-27 22:17:17 UTC
I believe this is set up properly now. Example:

This class is documented with its public parts:
http://api.kde.org/4.x-api/kdelibs-apidocs/knewstuff/html/classKNS3_1_1UploadDialog.html

Its private parts are documented on this page:
http://api.kde.org/4.x-api/kdelibs-apidocs/knewstuff/html/classKNS3_1_1UploadDialog_1_1Private.html

The example you show is unfortunate because it is a class NAMED private but which actually has public parts. That was probably unintuitive, but I'm not really in that project, not trying to talk shit.
Comment 3 Will Entriken 2015-01-27 22:17:30 UTC
As such, recommend to close this bug.
Comment 4 Ben Cooksley 2015-01-27 22:33:07 UTC
I see it as the responsibility of developers, not the web team to determine what gets documented (and thus shown on api.kde.org) in any event.