Bug 269176 - kmix don't show some channels and switches in Configure channels | Available channels in ALSA mode
Summary: kmix don't show some channels and switches in Configure channels | Available ...
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Christian Esken
Depends on:
Reported: 2011-03-22 21:01 UTC by Alexander
Modified: 2012-11-19 10:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:

Output of "amixer -c 0" command (7.86 KB, application/octet-stream)
2011-03-22 21:01 UTC, Alexander
kmixctrlrc (5.86 KB, text/plain)
2011-05-23 03:20 UTC, orionbelt2
amixer output (6.91 KB, text/plain)
2011-05-23 03:23 UTC, orionbelt2
kmixrc (3.11 KB, text/plain)
2011-05-23 03:25 UTC, orionbelt2

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2011-03-22 21:01:13 UTC
Created attachment 58262 [details]
Output of "amixer -c 0" command

Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

I have a Creative SoundBlaster Audigy4 (Audigy2) card.
Kmix don't show some channels and switches in Configure channels | Available channels in ALSA mode. For example missing switches for "Tone", "Audigy Analog/Digital Output Jack", "IEC958 Optical Raw", but presented and worked in alsamixer correctly.
I am tried to erase kmix config and profile files, but nothing changes.

As result i have no sound (needs to switch sound card from digital to analog mode, via muting "IEC958 Optical Raw")

Linux Mint 10 KDE
KDE 4.6.0
Kmix 3.8

PS Sorry for my english

Reproducible: Always

Steps to Reproduce:
I am testing on LiveDVD (Linux Mint 10 KDE)

1. Close Kmix application
2. kill and remove pulseaudio
3. Configure phonon to use Alsa
4. Start Kmix
5. Open Configure channels

Actual Results:  
I am not found needed channels and switches

Expected Results:  
There should better work with available channels list

In previous versions kmix worked very well.

Kmix hardware information:
Sound drivers supported: PulseAudio + ALSA + OSS
Sound drivers used: ALSA

cat /proc/asound/cards
 0 [Audigy2        ]: Audigy2 - SB Audigy 4 [SB0610]
                      SB Audigy 4 [SB0610] (rev.0, serial:0x10211102) at 0xd800, irq 17
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10
 2 [U0x46d0x81b    ]: USB-Audio - USB Device 0x46d:0x81b
                      USB Device 0x46d:0x81b at usb-0000:00:02.2-3, high speed

Built-in sound card is off in bios, because it's damaged
Comment 1 orionbelt2 2011-05-23 03:20:05 UTC
Created attachment 60230 [details]
Comment 2 orionbelt2 2011-05-23 03:21:00 UTC
Hello there,

I am having the same problem with my older Audigy card as soon as i upgraded from KDE 4.4 to 4.6: All items that appear as switches on alsamixer, and which amixer reports as "Capabilities: pswitch", do not show up on kmix *even though* they are listed in kmixctrlrc! Here is an example with the "Tone" switch mentioned above:

Simple mixer control 'Tone',0
  Capabilities: pswitch penum
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]


Yet, "Tone" does not show up on kmix's GUI as an option.

Gentoo Linux
KDE 4.6.2
Kmix 4.6.2

% cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff8000 irq 22
 1 [Audigy         ]: Audigy - SB Audigy 1 [SB0092]
                      SB Audigy 1 [SB0092] (rev.3, serial:0x531102) at 0xe880, irq 17

Many thanks for looking into this... It is quite important to fix because it has side-effects such as that the keyboard shortcut for "mute" no longer works!
Comment 3 orionbelt2 2011-05-23 03:23:29 UTC
Created attachment 60231 [details]
amixer output
Comment 4 orionbelt2 2011-05-23 03:25:50 UTC
Created attachment 60232 [details]
Comment 5 Christian Esken 2011-09-09 21:20:42 UTC
Thanks for the report and the amixer output. I see there are actually unsupported control types:

a) Simple mixer control 'Tone',0
  Capabilities: pswitch penum

I would guess that KMix shows the "enum" but not the "switch"

b) Simple mixer control 'Audigy Analog/Digital Output Jack',0
  Capabilities: pswitch pswitch-joined penum

Again, only "enum" is shown.

c) "IEC958 Optical Raw"
  Same as a)
Comment 6 Christian Esken 2011-09-09 21:21:41 UTC
Can you confirm that the "enum" is shown and the switch is not?
Comment 7 Christian Esken 2011-12-30 18:44:44 UTC
Fixed in KDE4.8
Comment 8 orionbelt2 2012-11-19 10:02:42 UTC
Hi Christian,

Sorry for not checking out your work earlier......

The problem has been partly solved, in the sense that the switches now do appear under the "available channels" in kmix's channel configuration window, and i can select them.

However, when i define the mute button in the "configure shortcuts" window, it does not work: It *is* accepted in the configuration window as a global shortcut, but when i push the button it does nothing.

I note that, by contrast, the "increase volume" and "decrease volume" keyboard shortcuts do work. Apparently kmix fails to identify the mute functionality with the "Audigy Analog/Digital Output Jack", which is the name of the switch that seems to mute the card's output.