Bug 269175 - Doodle webpage does not work
Summary: Doodle webpage does not work
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: 4.6.0
Platform: Unlisted Binaries Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-22 20:58 UTC by Albert Astals Cid
Modified: 2011-08-25 20:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch (929 bytes, patch)
2011-04-02 17:13 UTC, Maksim Orlovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2011-03-22 20:58:08 UTC
Version:           4.6.0
OS:                Linux

Go to http://www.doodle.com/polls/wizard.html see how the wizard is not loaded

Reproducible: Always




OS: Linux (x86_64) release 2.6.37-ARCH
Compiler: gcc
Comment 1 Maksim Orlovich 2011-03-22 23:00:40 UTC
Looks like jQuery detects 'noCloneChecked' = false for us (see http://api.jquery.com/jQuery.support/) and then hits some IE-specific path, which blows up. Sounds important.
Comment 2 Christian Boltz 2011-04-02 01:58:01 UTC
Workaround: disable JavaScript for the .doodle.com domain in the Konqueror settings. Doodle will then offer a link to the "mobile version", which is basically the old doodle design - and works.
Comment 3 Maksim Orlovich 2011-04-02 17:13:44 UTC
Created attachment 58520 [details]
patch

This should fix it, I think.
Comment 4 Andrea Iacovitti 2011-04-03 16:01:36 UTC
(In reply to comment #3)
> Created an attachment (id=58520) [details]
> patch
> 
> This should fix it, I think.

I can confirm the patch fix the page http://www.doodle.com/polls/wizard.html

but if you click the Next button at bottom of page, without filling any form input, konqueror hangs entering in a loop. Below debugging lines that are continuously printed in the konsole:

konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: current redirectURL= ""  with delay  0
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection:  d->m_bComplete= true
konqueror(2270)/khtml (part) KHTMLPart::slotRedirect: KHTMLPart(0x8ea2838)
konqueror(2270)/khtml (part) KHTMLPart::urlSelected: KHTMLPart(0x8ea2838) complete URL: "http://www.doodle.com/polls/wizard.html" target= "_self"
konqueror(2270)/khtml (jscript) KJS::Window::goURL: Window::goURL dstUrl= "http://www.doodle.com/polls/wizard.html"
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: delay= -1  url= "http://www.doodle.com/polls/wizard.html"  from= KUrl("http://www.doodle.com/polls/wizard.html#dates") parent= QObject(0x0)
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: current redirectURL= ""  with delay  0
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection:  d->m_bComplete= true
konqueror(2270)/khtml (part) KHTMLPart::slotRedirect: KHTMLPart(0x8ea2838)
konqueror(2270)/khtml (part) KHTMLPart::urlSelected: KHTMLPart(0x8ea2838) complete URL: "http://www.doodle.com/polls/wizard.html" target= "_self"
konqueror(2270)/khtml (jscript) KJS::Window::goURL: Window::goURL dstUrl= "http://www.doodle.com/polls/wizard.html"
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: delay= -1  url= "http://www.doodle.com/polls/wizard.html"  from= KUrl("http://www.doodle.com/polls/wizard.html#dates") parent= QObject(0x0)
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: current redirectURL= ""  with delay  0
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection:  d->m_bComplete= true
konqueror(2270)/khtml (part) KHTMLPart::slotRedirect: KHTMLPart(0x8ea2838)
konqueror(2270)/khtml (part) KHTMLPart::urlSelected: KHTMLPart(0x8ea2838) complete URL: "http://www.doodle.com/polls/wizard.html" target= "_self"
konqueror(2270)/khtml (jscript) KJS::Window::goURL: Window::goURL dstUrl= "http://www.doodle.com/polls/wizard.html"
konqueror(2270)/khtml (part) KHTMLPart::scheduleRedirection: delay= -1  url= "http://www.doodle.com/polls/wizard.html"  from= KUrl("http://www.doodle.com/polls/wizard.html#dates") parent= QObject(0x0)
....
....
....
Comment 5 Maksim Orlovich 2011-05-17 14:35:42 UTC
Git commit 6f6a4933975e85ebbee2c3354096c1c3a4889a3f by Maks Orlovich.
Committed on 17/05/2011 at 14:34.
Pushed by orlovich into branch 'KDE/4.6'.

Fix cloning of checkboxes.

... And with it element-cloning method in jQuery 1.5, which was
making us hit IE-specific path due to the bug. Showed up in particular
on Doodle wizard, and kde-look thumbs.

CCBUG:269175
BUG:272208

M  +3    -0    khtml/html/html_formimpl.cpp     

http://commits.kde.org/kdelibs/6f6a4933975e85ebbee2c3354096c1c3a4889a3f
Comment 6 Maksim Orlovich 2011-05-17 14:46:33 UTC
Git commit d22393aecc062ef4ab8bc9692911a4ec828f7007 by Maks Orlovich.
Committed on 02/04/2011 at 17:16.
Pushed by orlovich into branch 'master'.

Fix cloning of checkboxes.

... And with it element-cloning method in jQuery 1.5, which was
making us hit IE-specific path due to the bug. Showed up in particular
on Doodle wizard, and kde-look thumbs.

CCBUG:269175
BUG:272208

M  +3    -0    khtml/html/html_formimpl.cpp     

http://commits.kde.org/kdelibs/d22393aecc062ef4ab8bc9692911a4ec828f7007
Comment 7 Albert Astals Cid 2011-08-25 20:36:01 UTC
Works for me now, closing the bug.