Bug 269173 - kmail-crash, kontact-crash
Summary: kmail-crash, kontact-crash
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.13.5
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 273384 276976 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-22 20:47 UTC by UliS
Modified: 2011-07-03 00:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description UliS 2011-03-22 20:47:51 UTC
Application: kmail (1.13.5)
KDE Platform Version: 4.6.1 (4.6.1) (Compiled from sources)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

i started kmail, than it crashed. The same problem i have with kontact. 
ubuntu 10.10

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb788c780 (LWP 5841))]

Thread 3 (Thread 0xb74d8b70 (LWP 5842)):
#0  0x021dc511 in ?? () from /lib/libglib-2.0.so.0
#1  0x021dcba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#2  0x037a49c4 in ?? () from /usr/lib/libgio-2.0.so.0
#3  0x0220348f in ?? () from /lib/libglib-2.0.so.0
#4  0x00cb5cc9 in start_thread (arg=0xb74d8b70) at pthread_create.c:304
#5  0x0021069e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb1a88b70 (LWP 5855)):
#0  0x0021df7b in pthread_mutex_unlock (mutex=0x861e53c) at forward.c:184
#1  0x021dbb34 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x021dc45e in ?? () from /lib/libglib-2.0.so.0
#3  0x021dc848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x015ea59f in QEventDispatcherGlib::processEvents (this=0x8582720, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x015ba609 in QEventLoop::processEvents (this=0xb1a88220, flags=) at kernel/qeventloop.cpp:149
#6  0x015baa8a in QEventLoop::exec (this=0xb1a88220, flags=...) at kernel/qeventloop.cpp:201
#7  0x014b6b7e in QThread::exec (this=0x8676c58) at thread/qthread.cpp:490
#8  0x0159935b in QInotifyFileSystemWatcherEngine::run (this=0x8676c58) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x014b9df9 in QThreadPrivate::start (arg=0x8676c58) at thread/qthread_unix.cpp:266
#10 0x00cb5cc9 in start_thread (arg=0xb1a88b70) at pthread_create.c:304
#11 0x0021069e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb788c780 (LWP 5841)):
[KCrash Handler]
#7  QString::operator= (this=0x10, other=...) at tools/qstring.cpp:1324
#8  0x03e9c29f in KPIM::ProgressItem::setStatus (this=0x0, v=...) at ../../libkdepim/progressmanager.cpp:118
#9  0x00f81697 in KMail::PopAccount::slotData (this=0x8396da8, job=0x88a8780, data=...) at ../../kmail/popaccount.cpp:962
#10 0x00f82976 in KMail::PopAccount::qt_metacall (this=0x8396da8, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbfe967c4) at ./popaccount.moc:91
#11 0x015c18ca in QMetaObject::metacall (object=0x8396da8, cl=2728896, idx=13, argv=0xbfe967c4) at kernel/qmetaobject.cpp:237
#12 0x015d46ad in QMetaObject::activate (sender=0x88a8780, m=0x1b31ef0, local_signal_index=0, argv=0x88ac5c0) at kernel/qobject.cpp:3280
#13 0x01972709 in KIO::TransferJob::data(KIO::Job*, QByteArray const&) () from /usr/lib/libkio.so.5
#14 0x01975552 in KIO::TransferJob::slotData(QByteArray const&) () from /usr/lib/libkio.so.5
#15 0x01979345 in KIO::TransferJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#16 0x015c18ca in QMetaObject::metacall (object=0x88a8780, cl=2728896, idx=143295320, argv=0x88a8780) at kernel/qmetaobject.cpp:237
#17 0x015d46ad in QMetaObject::activate (sender=0x86745f0, m=0x1b346c4, local_signal_index=0, argv=0x88ac5c0) at kernel/qobject.cpp:3280
#18 0x01a37a33 in KIO::SlaveInterface::data(QByteArray const&) () from /usr/lib/libkio.so.5
#19 0x01a3b16e in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#20 0x01a37dd3 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#21 0x01a2a728 in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#22 0x01a2a933 in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#23 0x015c18ca in QMetaObject::metacall (object=0x86745f0, cl=2728896, idx=140985840, argv=0xbfe96af8) at kernel/qmetaobject.cpp:237
#24 0x015d46ad in QMetaObject::activate (sender=0x8590458, m=0x1b31440, local_signal_index=0, argv=0x88ac5c0) at kernel/qobject.cpp:3280
#25 0x01940d87 in KIO::Connection::readyRead() () from /usr/lib/libkio.so.5
#26 0x019430ee in ?? () from /usr/lib/libkio.so.5
#27 0x0194321e in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#28 0x015c18ca in QMetaObject::metacall (object=0x8590458, cl=2728896, idx=141045888, argv=0x8590458) at kernel/qmetaobject.cpp:237
#29 0x015ccdf6 in QMetaCallEvent::placeMetaCall (this=0x88a5fe8, object=0x8590458) at kernel/qobject.cpp:534
#30 0x015ce6a2 in QObject::event (this=0x8590458, e=0x8396d01) at kernel/qobject.cpp:1219
#31 0x04d10fdc in QApplicationPrivate::notify_helper (this=0x815cff8, receiver=0x8590458, e=0x88a5fe8) at kernel/qapplication.cpp:4396
#32 0x04d1704e in QApplication::notify (this=0xbfe97660, receiver=0x8590458, e=0x88a5fe8) at kernel/qapplication.cpp:3798
#33 0x005427da in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#34 0x015bbb3b in QCoreApplication::notifyInternal (this=0xbfe97660, receiver=0x8590458, event=0x88a5fe8) at kernel/qcoreapplication.cpp:732
#35 0x015bed8b in sendEvent (receiver=0x0, event_type=0, data=0x810e008) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x810e008) at kernel/qcoreapplication.cpp:1373
#37 0x015bef4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#38 0x015eaa74 in sendPostedEvents (s=0x815f108) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x815f108) at kernel/qeventdispatcher_glib.cpp:277
#40 0x021d8855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0x021dc668 in ?? () from /lib/libglib-2.0.so.0
#42 0x021dc848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0x015ea565 in QEventDispatcherGlib::processEvents (this=0x810daf8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0x04dd2be5 in QGuiEventDispatcherGlib::processEvents (this=0x810daf8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x015ba609 in QEventLoop::processEvents (this=0xbfe97514, flags=) at kernel/qeventloop.cpp:149
#46 0x015baa8a in QEventLoop::exec (this=0xbfe97514, flags=...) at kernel/qeventloop.cpp:201
#47 0x015bf00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0x04d0fe07 in QApplication::exec () at kernel/qapplication.cpp:3672
#49 0x0804a88e in main (argc=3, argv=0xbfe97824) at ../../kmail/main.cpp:156

Possible duplicates by query: bug 248697.

Reported using DrKonqi
Comment 1 Laurent Montel 2011-03-29 13:14:42 UTC
Git commit 815d2f420a96254153aec0ef28c840c1c8d517be by Montel Laurent.
Committed on 29/03/2011 at 13:16.
Pushed by mlaurent into branch '4.4'.

Fix potential crash bug #269173
BUG: 269173

M  +7    -5    kmail/popaccount.cpp     

http://commits.kde.org/kdepim/815d2f420a96254153aec0ef28c840c1c8d517be
Comment 2 Christophe Giboudeaux 2011-05-18 12:23:39 UTC
*** Bug 273384 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2011-07-03 00:19:20 UTC
*** Bug 276976 has been marked as a duplicate of this bug. ***