Bug 269157 - Amarok crashed when adding custom cover
Summary: Amarok crashed when adding custom cover
Status: RESOLVED DUPLICATE of bug 262902
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-22 17:38 UTC by Aaron Hamilton
Modified: 2011-03-22 22:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash Report (27.30 KB, application/octet-stream)
2011-03-22 17:38 UTC, Aaron Hamilton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Hamilton 2011-03-22 17:38:27 UTC
Created attachment 58257 [details]
Crash Report

Version:           2.4.0 (using KDE 4.5.1) 
OS:                Linux

Amarok crashed when trying to apply a custom cover from google source.

Reproducible: Didn't try
Comment 1 Myriam Schweingruber 2011-03-22 22:37:55 UTC
Backtrace from attachement. Please always paste the backtrace inline, else it is not searchable.


Thread 1 (Thread 0xb0f06780 (LWP 3468)):
[KCrash Handler]
#7  QPixmap::operator= (this=0x28, pixmap=...) at image/qpixmap.cpp:430
#8  0xb6f9c2b3 in setBigPix (this=0xa874c78, url=..., data=..., e=...) at ../../src/covermanager/CoverFoundDialog.h:174
#9  CoverFoundDialog::handleFetchResult (this=0xa874c78, url=..., data=..., e=...) at ../../src/covermanager/CoverFoundDialog.cpp:456
#10 0xb6fa4fe7 in CoverFoundDialog::qt_metacall (this=0xa874c78, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfa2738c) at ./CoverFoundDialog.moc:125
#11 0xb5b538ca in QMetaObject::metacall (object=0xa874c78, cl=3045979072, idx=81, argv=0xbfa2738c) at kernel/qmetaobject.cpp:237
#12 0xb5b57352 in QMetaMethod::invoke (this=0xbfa274ec, object=0xa874c78, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#13 0xb6df7a69 in invoke (this=0xa01e320) at /usr/include/qt4/QtCore/qmetaobject.h:119
#14 NetworkAccessManagerProxy::NetworkAccessManagerProxyPrivate::_replyFinished (this=0xa01e320) at ../../src/network/NetworkAccessManagerProxy.cpp:98
#15 0xb6df651b in NetworkAccessManagerProxy::qt_metacall (this=0xa017310, _c=QMetaObject::InvokeMetaMethod, _id=19, _a=0xbfa2767c) at ./NetworkAccessManagerProxy.moc:86
#16 0xb5b538ca in QMetaObject::metacall (object=0xa017310, cl=3045979072, idx=19, argv=0xbfa2767c) at kernel/qmetaobject.cpp:237
#17 0xb5b666ad in QMetaObject::activate (sender=0xa8b6d00, m=0xb556748c, local_signal_index=1, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#18 0xb55263e7 in QNetworkReply::finished (this=0xa8b6d00) at .moc/release-shared/moc_qnetworkreply.cpp:152
#19 0xb516b0c5 in KDEPrivate::AccessManagerReply::jobDone (this=0xa8b6d00, kJob=0xa758800) at ../../kio/kio/accessmanagerreply_p.cpp:248
#20 0xb516b96f in KDEPrivate::AccessManagerReply::qt_metacall (this=0xa8b6d00, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbfa27958) at ./accessmanagerreply_p.moc:83
#21 0xb5b538ca in QMetaObject::metacall (object=0xa8b6d00, cl=3045979072, idx=17, argv=0xbfa27958) at kernel/qmetaobject.cpp:237
#22 0xb5b666ad in QMetaObject::activate (sender=0xa758800, m=0xb5f00b48, local_signal_index=3, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#23 0xb5d8d8a3 in KJob::result (this=0xa758800, _t1=0xa758800) at ./kjob.moc:194
#24 0xb5d8dc08 in KJob::emitResult (this=0xa758800) at ../../kdecore/jobs/kjob.cpp:312
#25 0xb51ad480 in KIO::SimpleJob::slotFinished (this=0xa758800) at ../../kio/kio/job.cpp:522
#26 0xb51ad960 in KIO::TransferJob::slotFinished (this=0xa758800) at ../../kio/kio/job.cpp:1111
#27 0xb51ab453 in KIO::TransferJob::qt_metacall (this=0xa758800, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfa27bfc) at ./jobclasses.moc:367
#28 0xb5b538ca in QMetaObject::metacall (object=0xa758800, cl=3045979072, idx=47, argv=0xbfa27bfc) at kernel/qmetaobject.cpp:237
#29 0xb5b666ad in QMetaObject::activate (sender=0xa86d168, m=0xb535c944, local_signal_index=4, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#30 0xb5265fc7 in KIO::SlaveInterface::finished (this=0xa86d168) at ./slaveinterface.moc:171
#31 0xb5269768 in KIO::SlaveInterface::dispatch (this=0xa86d168, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#32 0xb5266483 in KIO::SlaveInterface::dispatch (this=0xa86d168) at ../../kio/kio/slaveinterface.cpp:91
#33 0xb5258fe8 in KIO::Slave::gotInput (this=0xa86d168) at ../../kio/kio/slave.cpp:344
#34 0xb52591f3 in KIO::Slave::qt_metacall (this=0xa86d168, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfa27f1c) at ./slave.moc:82
#35 0xb5b538ca in QMetaObject::metacall (object=0xa86d168, cl=3045979072, idx=30, argv=0xbfa27f1c) at kernel/qmetaobject.cpp:237
#36 0xb5b666ad in QMetaObject::activate (sender=0xa4848f8, m=0xb5359500, local_signal_index=0, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#37 0xb5172e17 in KIO::Connection::readyRead (this=0xa4848f8) at ./connection.moc:92
#38 0xb517517e in KIO::ConnectionPrivate::dequeue (this=0x99ff3e0) at ../../kio/kio/connection.cpp:82
#39 0xb51752ae in KIO::Connection::qt_metacall (this=0xa4848f8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xa07bc30) at ./connection.moc:79
#40 0xb5b538ca in QMetaObject::metacall (object=0xa4848f8, cl=3045979072, idx=5, argv=0xa07bc30) at kernel/qmetaobject.cpp:237
#41 0xb5b5edf6 in QMetaCallEvent::placeMetaCall (this=0xa6467b0, object=0xa4848f8) at kernel/qobject.cpp:534
#42 0xb5b606a2 in QObject::event (this=0xa4848f8, e=0x1) at kernel/qobject.cpp:1219
#43 0xb6033fdc in QApplicationPrivate::notify_helper (this=0x983ca20, receiver=0xa4848f8, e=0xa6467b0) at kernel/qapplication.cpp:4396
#44 0xb603a04e in QApplication::notify (this=0xbfa29c18, receiver=0xa4848f8, e=0xa6467b0) at kernel/qapplication.cpp:3798
#45 0xb758068a in KApplication::notify (this=0xbfa29c18, receiver=0xa4848f8, event=0xa6467b0) at ../../kdeui/kernel/kapplication.cpp:310
#46 0xb5b4db3b in QCoreApplication::notifyInternal (this=0xbfa29c18, receiver=0xa4848f8, event=0xa6467b0) at kernel/qcoreapplication.cpp:732
#47 0xb5b50d8b in sendEvent (receiver=0x0, event_type=0, data=0x9750d28) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#48 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9750d28) at kernel/qcoreapplication.cpp:1373
#49 0xb5b50f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#50 0xb5b7ca74 in sendPostedEvents (s=0x983ead8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#51 postEventSourceDispatch (s=0x983ead8) at kernel/qeventdispatcher_glib.cpp:277
#52 0xb45b7855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#53 0xb45bb668 in ?? () from /lib/libglib-2.0.so.0
#54 0xb45bb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#55 0xb5b7c565 in QEventDispatcherGlib::processEvents (this=0x97509e8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#56 0xb60f5be5 in QGuiEventDispatcherGlib::processEvents (this=0x97509e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb5b4c609 in QEventLoop::processEvents (this=0xbfa287d0, flags=) at kernel/qeventloop.cpp:149
#58 0xb5b4ca8a in QEventLoop::exec (this=0xbfa287d0, flags=...) at kernel/qeventloop.cpp:201
#59 0xb659e873 in QDialog::exec (this=0xa26d9f8) at dialogs/qdialog.cpp:552
#60 0xb6fa26b4 in CoverFoundDialog::fetchBigPix (this=0xa874c78) at ../../src/covermanager/CoverFoundDialog.cpp:495
#61 0xb6fa2d08 in CoverFoundDialog::slotButtonClicked (this=0xa874c78, button=4) at ../../src/covermanager/CoverFoundDialog.cpp:435
#62 0xb74cdb79 in KDialog::qt_metacall (this=0xa874c78, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0xbfa28a78) at ./kdialog.moc:190
#63 0xb6fa4e1a in CoverFoundDialog::qt_metacall (this=0xa874c78, _c=QMetaObject::InvokeMetaMethod, _id=69, _a=0xbfa28a78) at ./CoverFoundDialog.moc:112
#64 0xb5b538ca in QMetaObject::metacall (object=0xa874c78, cl=3045979072, idx=69, argv=0xbfa28a78) at kernel/qmetaobject.cpp:237
#65 0xb5b666ad in QMetaObject::activate (sender=0xa851e70, m=0xb5c7f0f8, local_signal_index=0, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#66 0xb5b695a3 in QSignalMapper::mapped (this=0xa851e70, _t1=4) at .moc/release-shared/moc_qsignalmapper.cpp:101
#67 0xb5b6a7ed in QSignalMapper::map (this=0xa851e70, sender=0xa47f9d0) at kernel/qsignalmapper.cpp:266
#68 0xb5b6a9ce in QSignalMapper::map (this=0xa851e70) at kernel/qsignalmapper.cpp:257
#69 0xb5b6aa9b in QSignalMapper::qt_metacall (this=0xa851e70, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfa28c18) at .moc/release-shared/moc_qsignalmapper.cpp:87
#70 0xb5b538ca in QMetaObject::metacall (object=0xa851e70, cl=3045979072, idx=8, argv=0xbfa28c18) at kernel/qmetaobject.cpp:237
#71 0xb5b666ad in QMetaObject::activate (sender=0xa47f9d0, m=0xb69c5704, local_signal_index=2, argv=0xbfa2722c) at kernel/qobject.cpp:3280
#72 0xb67a2019 in QAbstractButton::clicked (this=0xa47f9d0, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#73 0xb6461ff9 in QAbstractButtonPrivate::emitClicked (this=0xa460d50) at widgets/qabstractbutton.cpp:546
#74 0xb64636f4 in QAbstractButtonPrivate::click (this=0xa460d50) at widgets/qabstractbutton.cpp:539
#75 0xb64639ae in QAbstractButton::mouseReleaseEvent (this=0xa47f9d0, e=0xbfa29360) at widgets/qabstractbutton.cpp:1121
#76 0xb6091e08 in QWidget::event (this=0xa47f9d0, event=0xbfa29360) at kernel/qwidget.cpp:8187
#77 0xb6461e9e in QAbstractButton::event (this=0xa47f9d0, e=0x1) at widgets/qabstractbutton.cpp:1080
#78 0xb650fc22 in QPushButton::event (this=0xa47f9d0, e=0xbfa29360) at widgets/qpushbutton.cpp:683
#79 0xb6033fdc in QApplicationPrivate::notify_helper (this=0x983ca20, receiver=0xa47f9d0, e=0xbfa29360) at kernel/qapplication.cpp:4396
#80 0xb603ac2e in QApplication::notify (this=0xbfa29c18, receiver=0xa47f9d0, e=0xbfa29360) at kernel/qapplication.cpp:3959
#81 0xb758068a in KApplication::notify (this=0xbfa29c18, receiver=0xa47f9d0, event=0xbfa29360) at ../../kdeui/kernel/kapplication.cpp:310
#82 0xb5b4db3b in QCoreApplication::notifyInternal (this=0xbfa29c18, receiver=0xa47f9d0, event=0xbfa29360) at kernel/qcoreapplication.cpp:732
#83 0xb6039094 in sendEvent (receiver=0xa47f9d0, event=0xbfa29360, alienWidget=0xa47f9d0, nativeWidget=0xa874c78, buttonDown=0xb69ce3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#84 QApplicationPrivate::sendMouseEvent (receiver=0xa47f9d0, event=0xbfa29360, alienWidget=0xa47f9d0, nativeWidget=0xa874c78, buttonDown=0xb69ce3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#85 0xb60c7d10 in QETWidget::translateMouseEvent (this=0xa874c78, event=0xbfa2987c) at kernel/qapplication_x11.cpp:4403
#86 0xb60c7151 in QApplication::x11ProcessEvent (this=0xbfa29c18, event=0xbfa2987c) at kernel/qapplication_x11.cpp:3414
#87 0xb60f636a in x11EventSourceDispatch (s=0x983f7a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#88 0xb45b7855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#89 0xb45bb668 in ?? () from /lib/libglib-2.0.so.0
#90 0xb45bb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#91 0xb5b7c565 in QEventDispatcherGlib::processEvents (this=0x97509e8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#92 0xb60f5be5 in QGuiEventDispatcherGlib::processEvents (this=0x97509e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#93 0xb5b4c609 in QEventLoop::processEvents (this=0xbfa29b74, flags=) at kernel/qeventloop.cpp:149
#94 0xb5b4ca8a in QEventLoop::exec (this=0xbfa29b74, flags=...) at kernel/qeventloop.cpp:201
#95 0xb5b5100f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#96 0xb6032e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#97 0x08050e75 in main (argc=1, argv=0xbfa2a5d4) at ../../src/main.cpp:268

*** This bug has been marked as a duplicate of bug 262902 ***