Bug 268958 - KNotify crashes everytime
Summary: KNotify crashes everytime
Status: RESOLVED DUPLICATE of bug 259269
Alias: None
Product: phonon-backend-vlc
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 13:10 UTC by Michael Weber
Modified: 2011-05-01 15:31 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weber 2011-03-20 13:10:39 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: when I delete files, copy files, login, logout, receive messages via kopete or I execute any other application which prints out notifications via knotify, knotify crashes everytime

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f796e1ec760 (LWP 7507))]

Thread 2 (Thread 0x7f795e59d700 (LWP 7519)):
#0  0x00007f796b48d503 in poll () from /lib64/libc.so.6
#1  0x00007f7968a44114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f7968a44650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f796bbc5976 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f796bb9a052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f796bb9a265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f796baaf1e4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f796bb7b968 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f796bab1a5e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f79695a5a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f796b49667d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f796e1ec760 (LWP 7507)):
[KCrash Handler]
#6  module_list_get (n=0x0) at modules/modules.c:380
#7  0x00007f7957194375 in libvlc_audio_output_list_get (p_instance=<value optimized out>) at control/audio.c:72
#8  0x00007f79573b83f5 in Phonon::VLC::DeviceManager::updateDeviceList() () from /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
#9  0x00007f79573b8175 in Phonon::VLC::DeviceManager::DeviceManager(Phonon::VLC::Backend*) () from /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
#10 0x00007f79573b36f1 in Phonon::VLC::Backend::Backend(QObject*, QList<QVariant> const&) () from /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
#11 0x00007f79573b32ef in qt_plugin_instance () from /usr/lib64/kde4/plugins/phonon_backend/phonon_vlc.so
#12 0x00007f795db93622 in Phonon::KdePlatformPlugin::createBackend (this=<value optimized out>, newService=...) at /usr/src/debug/kdebase-runtime-4.6.0/phonon/platform_kde/kdeplatformplugin.cpp:149
#13 0x00007f795db9412b in Phonon::KdePlatformPlugin::createBackend (this=0x771fa0) at /usr/src/debug/kdebase-runtime-4.6.0/phonon/platform_kde/kdeplatformplugin.cpp:200
#14 0x00007f796d7a3466 in Phonon::FactoryPrivate::createBackend (this=0x771580) at /usr/src/debug/phonon-4.4.4/phonon/factory.cpp:119
#15 0x00007f796d7a3b8f in Phonon::Factory::backend (createWhenNull=<value optimized out>) at /usr/src/debug/phonon-4.4.4/phonon/factory.cpp:453
#16 0x00007f796d7a4670 in Phonon::Factory::createAudioOutput (parent=0x770670) at /usr/src/debug/phonon-4.4.4/phonon/factory.cpp:349
#17 0x00007f796d79c956 in Phonon::AudioOutputPrivate::createBackendObject (this=0x771200) at /usr/src/debug/phonon-4.4.4/phonon/audiooutput.cpp:134
#18 0x00007f796d799bd8 in Phonon::AudioOutputPrivate::init (this=0x771200, c=Phonon::NotificationCategory) at /usr/src/debug/phonon-4.4.4/phonon/audiooutput.cpp:107
#19 0x000000000040e771 in Player (this=0x716288) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/notifybysound.cpp:58
#20 PlayerPool::getPlayer (this=0x716288) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/notifybysound.cpp:98
#21 0x000000000040ecee in NotifyBySound::notify (this=0x726890, eventId=101, config=<value optimized out>) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/notifybysound.cpp:242
#22 0x000000000040ba51 in KNotify::emitEvent (this=0x7fffc037bf50, e=0x754eb0) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/knotify.cpp:230
#23 0x000000000040c863 in KNotify::event (this=0x7fffc037bf50, event=<value optimized out>, appname=..., contexts=<value optimized out>, title=<value optimized out>, text=<value optimized out>, image=..., actions=..., timeout=-1, winId=75501695) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/knotify.cpp:149
#24 0x000000000040cb88 in KNotifyAdaptor::event (this=0x709ad0, event=..., fromApp=..., contexts=<value optimized out>, title=..., text=..., image=..., actions=..., timeout=-1, winId=75501695) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/knotify.cpp:287
#25 0x000000000040cd4b in KNotifyAdaptor::qt_metacall (this=0x709ad0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffc037b200) at /usr/src/debug/kdebase-runtime-4.6.0/build/knotify/knotify.moc:227
#26 0x00007f796bef0b68 in ?? () from /usr/lib64/libQtDBus.so.4
#27 0x00007f796bef1505 in ?? () from /usr/lib64/libQtDBus.so.4
#28 0x00007f796bef1c9e in ?? () from /usr/lib64/libQtDBus.so.4
#29 0x00007f796bef1ed8 in ?? () from /usr/lib64/libQtDBus.so.4
#30 0x00007f796bbaea6a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#31 0x00007f796c7afd14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#32 0x00007f796c7b822a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#33 0x00007f796db5c9e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#34 0x00007f796bb9abfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#35 0x00007f796bb9e3f5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#36 0x00007f796bbc5783 in ?? () from /usr/lib64/libQtCore.so.4
#37 0x00007f7968a43bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#38 0x00007f7968a443b0 in ?? () from /lib64/libglib-2.0.so.0
#39 0x00007f7968a44650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#40 0x00007f796bbc591f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f796c854d8e in ?? () from /usr/lib64/libQtGui.so.4
#42 0x00007f796bb9a052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007f796bb9a265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x00007f796bb9e6ab in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#45 0x000000000040a12f in main (argc=1, argv=0x7fffc037c318) at /usr/src/debug/kdebase-runtime-4.6.0/knotify/main.cpp:73

Possible duplicates by query: bug 260925, bug 255644, bug 255608, bug 254887, bug 253760.

Reported using DrKonqi
Comment 1 Harald Sitter 2011-03-21 12:27:08 UTC
Howdy,
This is most definitely a VLC initialization problem.

It would be super awesome if you could find out what version of VLC/libvlc and Phonon-VLC are installed.

Additionally getting a debug log using the environment variables listed at [1] would be cool, that should give a good idea of what is going wrong.

[1] http://techbase.kde.org/Development/Tutorials/Debugging/Phonon
Comment 2 Myriam Schweingruber 2011-03-28 04:41:53 UTC
Setting status correctly
Comment 3 Michael Weber 2011-03-28 12:14:42 UTC
Bug was really caused by vlc and phonon. I deinstalled vlc 1.1.8 and also the related vlc-phonon-backend 0.3.2. I installed vlc 1.2 (beta release). Everything works now as usual.

Thanks a lot. 

Regards,
Michael
Comment 4 Christoph Feck 2011-04-01 00:12:03 UTC
Michael, which Phonon backend are you using now? If this bug only happens with VLC backend, switching away will of course work around the bug, but certainly not help fixing it.
Comment 5 Michael Weber 2011-04-01 02:49:05 UTC
Here is all information about my phonon-vlc-backend (I don't have it installed, 'cause then I would need to downgrade vlc):

phonon-backend-vlc - Phonon VLC Backend

Version:
0.3.2-1.pm.2.1
Build Time:
Fri 04 Mar 2011 09:28:31 AM CET
Package Group:
Development/Libraries/KDE
License:
LGPLv2.0+
Installed Size:
211.0 KiB
Download Size:
62.0 KiB
Distribution:

Vendor:
http://packman.links2linux.de
Packager:
packman@links2linux.de
Architecture:
x86_64
Build Host:

URL:
http://phonon.kde.org/
Source Package:
phonon-backend-vlc-0.3.2-1.pm.2.1
Media No.:
0
Authors:
Phonon and VLC teams
Comment 6 Myriam Schweingruber 2011-04-27 21:34:06 UTC
Reassigning to the new bugzilla product for better bug tracing of the various
backends. Sorry for the noise.
Comment 7 Harald Sitter 2011-05-01 15:31:33 UTC
After having refactored this code recently I can definitely say that...

#6  module_list_get (n=0x0) at modules/modules.c:380

this 0x0 clearly indicates that your libvlc did not initialize properly, which is usually the case when you do not have any VLC plugins installed, which is usually teh case when you do not have a package called 'vlc' or 'vlc-plugins' installed.

*** This bug has been marked as a duplicate of bug 259269 ***