Bug 268907 - kde4d eats one CPU core
Summary: kde4d eats one CPU core
Status: RESOLVED DUPLICATE of bug 178228
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: 0.1
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-19 18:12 UTC by Toralf Förster
Modified: 2011-03-22 13:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
gdb output (23.58 KB, text/plain)
2011-03-19 18:12 UTC, Toralf Förster
Details
gdb output (25.17 KB, text/plain)
2011-03-19 18:13 UTC, Toralf Förster
Details
gdb output (23.83 KB, text/plain)
2011-03-19 18:13 UTC, Toralf Förster
Details
gdb output (21.89 KB, text/plain)
2011-03-19 18:13 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2011-03-19 18:12:54 UTC
Created attachment 58169 [details]
gdb output

Version:           0.1 (using KDE 4.6.1) 
OS:                Linux

Today I had again the situation where kde4d uses up to 50% of my dual-core processor. The process list gave :

kded4(7106,tfoerste)─┬─{kded4}(7114)
                     └─{kded4}(7122)

I attached gdb to 7106 and killed the child process 122, howevere few minutes later the situation was the same. ThenI killed again a child, and finally I run a "kill -9 7106" the appropriate outputs of gdb are attached.

I attach the output of "gdb 2>&1 | tee -a gdbX.log" onto this bug report.

Reproducible: Didn't try




OS: Linux (i686) release 2.6.38
Compiler: i686-pc-linux-gnu-gcc
Comment 1 Toralf Förster 2011-03-19 18:13:15 UTC
Created attachment 58170 [details]
gdb output
Comment 2 Toralf Förster 2011-03-19 18:13:32 UTC
Created attachment 58171 [details]
gdb output
Comment 3 Toralf Förster 2011-03-19 18:13:50 UTC
Created attachment 58172 [details]
gdb output
Comment 4 Lamarque V. Souza 2011-03-19 21:20:26 UTC

*** This bug has been marked as a duplicate of bug 178228 ***
Comment 5 Toralf Förster 2011-03-19 21:46:19 UTC
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of bug 178228 ***
Sure, ?!
That mentioned bug was solved 1 year ago per SVN commit - but still happened in KDE 4.6.1 !
Comment 6 Lamarque V. Souza 2011-03-19 21:52:42 UTC
Bug 178228 is still open, your backtrace is similar to its, so the duplicate.