Bug 268795 - Crash during apt-get dist-upgrade
Summary: Crash during apt-get dist-upgrade
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 01:12 UTC by K
Modified: 2011-03-19 21:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description K 2011-03-18 01:12:26 UTC
Application: kded4 ($Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux 6.0.1 (squeeze)

-- Information about the crash:
I was upgrading my Debian squeeze as the screen blacked out for a while and then the bug report tool popped out.

 -- Backtrace:
Application: Δαίμονας του KDE (kded4), signal: Segmentation fault
[KCrash Handler]
#6  0x4b170af7 in QMetaObject::cast (this=<value optimized out>, obj=<value optimized out>) at kernel/qmetaobject.cpp:266
#7  0xb5863eae in ?? () from /usr/lib/libknmservice.so.4
#8  0xb5864171 in ?? () from /usr/lib/libknmservice.so.4
#9  0xb58643f2 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#10 0xb5852d03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb5853098 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb5857965 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#13 0xb58565a4 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#14 0xb5856f41 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) ()
   from /usr/lib/libknmservice.so.4
#15 0xb5853b0c in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0xb584e22b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0x4b170aca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#18 0x4b17f4db in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3295
#19 0x47c78ea3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#20 0x47c79916 in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0x47c79997 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0x4b170aca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#23 0x4b17f4db in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3295
#24 0xb58b1613 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0xb58b1efa in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0xb58b621d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x4b170aca in QMetaObject::metacall (object=<value optimized out>, cl=<value optimized out>, idx=<value optimized out>, argv=<value optimized out>) at kernel/qmetaobject.cpp:237
#28 0x4b17f4db in QMetaObject::activate (sender=<value optimized out>, m=<value optimized out>, local_signal_index=<value optimized out>, argv=<value optimized out>) at kernel/qobject.cpp:3295
#29 0xb58c0563 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#30 0xb58c0925 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x4accdf81 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=<value optimized out>, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:904
#32 0x4acd8d37 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#33 0x4b17c11e in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1248
#34 0x4b8155cc in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4302
#35 0x4b81c15e in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:3706
#36 0x473cfc0a in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x4b16b7eb in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:726
#38 0x4b16f24c in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1367
#40 0x4b16f3cd in QCoreApplication::sendPostedEvents (receiver=) at kernel/qcoreapplication.cpp:1260
#41 0x4b19789f in QCoreApplication::sendPostedEvents (s=) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#42 postEventSourceDispatch (s=) at kernel/qeventdispatcher_glib.cpp:276
#43 0x45fb8305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#44 0x45fbbfe8 in ?? () from /lib/libglib-2.0.so.0
#45 0x45fbc1c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#46 0x4b197395 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#47 0x4b8d3ed5 in QGuiEventDispatcherGlib::processEvents (this=) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x4b169e09 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#49 0x4b16a25a in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#50 0x4b16f48f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#51 0x4b815667 in QApplication::exec () at kernel/qapplication.cpp:3581
#52 0x479d8f6e in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:932
#53 0x080485fb in main (argc=1, argv=0xbf9df494) at kded4_dummy.cpp:3

This bug may be a duplicate of or related to bug 267287.

Possible duplicates by query: bug 267287.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-19 21:38:55 UTC

*** This bug has been marked as a duplicate of bug 210878 ***