Bug 268671 - kile crashes when closing terminal via Ctrl-D
Summary: kile crashes when closing terminal via Ctrl-D
Status: RESOLVED DUPLICATE of bug 263405
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-16 18:47 UTC by Felix Möller
Modified: 2011-03-21 12:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Möller 2011-03-16 18:47:33 UTC
Application: kile (2.0.86)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.11-83.fc14.i686.PAE i686
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:
writing a latex document in kile. kile crashes when closing terminal via Ctrl-D.

The crash can be reproduced every time.

-- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77df9b0 (LWP 21976))]

Thread 2 (Thread 0xb74f2b70 (LWP 21977)):
#0  0x00acc424 in __kernel_vsyscall ()
#1  0x00c5bc36 in __poll (fds=0xb6b029c0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0018ddac in g_poll (fds=0xb6b029c0, nfds=1, timeout=-1) at gpoll.c:132
#3  0x0017d8b7 in g_main_context_poll (context=0x8578098, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3093
#4  g_main_context_iterate (context=0x8578098, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
#5  0x0017e04b in g_main_loop_run (loop=0x8578118) at gmain.c:2988
#6  0x00ea1ed5 in gdbus_shared_thread_func (data=0x0) at gdbusprivate.c:277
#7  0x001a6bd0 in g_thread_create_proxy (data=0x8578128) at gthread.c:1897
#8  0x00d4ce99 in start_thread (arg=0xb74f2b70) at pthread_create.c:301
#9  0x00c66d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb77df9b0 (LWP 21976)):
[KCrash Handler]
#7  0x05bb6628 in typeinfo for QObjectUserData () from /usr/lib/libQtCore.so.4
#8  0x0825c6db in KileWidget::Konsole::slotDestroyed (this=0x89e7bf0) at /usr/src/debug/kile-2.1b5/src/widgets/konsolewidget.cpp:136
#9  0x0825c767 in KileWidget::Konsole::qt_metacall (this=0x89e7bf0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf816bd8) at /usr/src/debug/kile-2.1b5/i686-redhat-linux-gnu/src/konsolewidget.moc:79
#10 0x05a81beb in QMetaObject::metacall (object=0x89e7bf0, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbf816bd8) at kernel/qmetaobject.cpp:237
#11 0x05a910c7 in QMetaObject::activate (sender=0x89fa950, m=0x83ed7d0, local_signal_index=0, argv=0xbf816bd8) at kernel/qobject.cpp:3272
#12 0x05a91564 in QObject::destroyed (this=0x89fa950, _t1=0x89fa950) at .moc/release-shared/moc_qobject.cpp:149
#13 0x05a9384b in QObject::~QObject (this=0x89fa950, __in_chrg=<value optimized out>) at kernel/qobject.cpp:842
#14 0x04f55146 in KParts::Part::~Part (this=0x89fa950, __vtt_parm=0x57c67a8, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/kparts/part.cpp:189
#15 0x04f564ab in KParts::ReadOnlyPart::~ReadOnlyPart (this=0x89fa950, __vtt_parm=0x57c67a4, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/kparts/part.cpp:456
#16 0x057c299c in ?? () from /usr/lib/kde4/libkonsolepart.so
#17 0x057c2a23 in ?? () from /usr/lib/kde4/libkonsolepart.so
#18 0x05a8e356 in qDeleteInEventHandler (o=0x89fa950) at kernel/qobject.cpp:3980
#19 0x05a90c00 in QObject::event (this=0x89fa950, e=0x8e57180) at kernel/qobject.cpp:1194
#20 0x06a9b26c in QApplicationPrivate::notify_helper (this=0x85427d8, receiver=0x89fa950, e=0x8e57180) at kernel/qapplication.cpp:4445
#21 0x06a9fed2 in QApplication::notify (this=0xbf81758c, receiver=0x89fa950, e=0x8e57180) at kernel/qapplication.cpp:3845
#22 0x021daf7b in KApplication::notify (this=0xbf81758c, receiver=0x89fa950, event=0x8e57180) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#23 0x05a7b3b3 in QCoreApplication::notifyInternal (this=0xbf81758c, receiver=0x89fa950, event=0x8e57180) at kernel/qcoreapplication.cpp:732
#24 0x05a7f105 in sendEvent (receiver=0x0, event_type=0, data=0x8525a88) at kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8525a88) at kernel/qcoreapplication.cpp:1373
#26 0x05a7f2de in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#27 0x05aa8f35 in sendPostedEvents (s=0x8544b10) at kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x8544b10) at kernel/qeventdispatcher_glib.cpp:277
#29 0x0017d192 in g_main_dispatch (context=0x8544a90) at gmain.c:2149
#30 g_main_context_dispatch (context=0x8544a90) at gmain.c:2702
#31 0x0017d978 in g_main_context_iterate (context=0x8544a90, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#32 0x0017dc35 in g_main_context_iteration (context=0x8544a90, may_block=1) at gmain.c:2843
#33 0x05aa90ad in QEventDispatcherGlib::processEvents (this=0x8525780, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#34 0x06b4e406 in QGuiEventDispatcherGlib::processEvents (this=0x8525780, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#35 0x05a7a54a in QEventLoop::processEvents (this=0xbf8174d4, flags=...) at kernel/qeventloop.cpp:149
#36 0x05a7a7fa in QEventLoop::exec (this=0xbf8174d4, flags=...) at kernel/qeventloop.cpp:201
#37 0x05a7f3a7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x06a99078 in QApplication::exec () at kernel/qapplication.cpp:3719
#39 0x081d85c3 in main (argc=0, argv=0xbf816bf4) at /usr/src/debug/kile-2.1b5/src/main.cpp:166

Reported using DrKonqi
Comment 1 Michel Ludwig 2011-03-19 11:15:56 UTC
By default Ctrl + D is mapped to the "comment" action.

Did you press Ctrl + D while the cursor focus was on the Konsole embedded in Kile?
Comment 2 Felix Möller 2011-03-19 11:28:05 UTC
I did it while the focus was in the embedded konsole.

I can reproduce this every time.

kile-2.1-0.10.b5.fc14.i686
Comment 3 Michel Ludwig 2011-03-19 18:50:24 UTC
That's really weird as it doesn't want to crash here :)

Also, using KDE 4.5.5, but the latest Git version instead. Can you maybe try out the Git version as well? You can find compilation instructions here:

http://kile.sourceforge.net/developers.php#repository

Thanks.
Comment 4 Michel Ludwig 2011-03-19 18:53:16 UTC
Ah, yes, I remember now. This is probably a duplicate of bug 263405.
Comment 5 Rex Dieter 2011-03-21 12:59:20 UTC
the backtrace looks like a dup, yeah.

*** This bug has been marked as a duplicate of bug 263405 ***