Bug 268551 - Crtl + Shift + S clash with okularpart
Summary: Crtl + Shift + S clash with okularpart
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.13.2
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-15 11:00 UTC by Anders Lund
Modified: 2011-11-21 22:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
3 x CRTL + SHIFT + S standard shortcuts (65.27 KB, image/png)
2011-11-19 09:57 UTC, Anders Lund
Details
patch: don't abuse saveas standard action (655 bytes, patch)
2011-11-21 06:31 UTC, Anders Lund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2011-03-15 11:00:18 UTC
Version:           0.0.1 (using KDE 4.6.1) 
OS:                Linux

Trying to save a pdf file to disk from konqueror, I was greetet with one of my #1 dislikes: the dialog claiming that there is shortcut clashes, and that i should edit shortcuts.

Either konqueror (likely) or okular uses c-s-s for "save as"
Either konqueror or okular (likely) uses c-s-s for "save copy as"

Dear user of the "save copy as" action, you should change your shortcut, as you conflict with a kde standard action.

Assigning to konqueror, since this is where I experienced the problem. This issue happens quite often with konqueror, so maybe a there is a better way to handle it than asking the user to edit shortcuts - which is difficult and hard to gripe in this case. How about a menu offering all the choices, in addition to edit the shortcuts for just those actions, and a link to report the bug?

Reproducible: Always




OS: Linux (i686) release 2.6.37-ARCH
Compiler: gcc
Comment 1 Dawit Alemayehu 2011-11-19 07:43:55 UTC
Sorry, but in the stock KDE distribution (4.7 branch), neither Konqueror nor Okular assign "Ctrl+Shift+S" as a shortcut to anything. Are you sure you did not assign this shortcut yourself and forgotten about it ? Can you check to see which application has this shortcut assigned ? I checked both and neither one use this shortcut on my system by default.
Comment 2 Anders Lund 2011-11-19 09:57:14 UTC
Created attachment 65837 [details]
3 x CRTL + SHIFT + S standard shortcuts

As can be seen from this screenshot, khtml uses CTRL + SHIFT + S once (relevant when a pdf is opened in a frame (sic!)), and okular twice (!!) - okular is ALWAYS broken in this respect.
Comment 3 Anders Lund 2011-11-19 10:41:07 UTC
I can see that this is not so much a problem of konqueror, although it shows up there.

Of course I am sure that khtml as well as okular uses widget context for those actions ;)

So the problem must be in okular, and thus I redirect there.
Comment 4 Albert Astals Cid 2011-11-20 23:01:56 UTC
"Save As" has no standard shortcut as you can see in kstandardshortcut.cpp:152
    { SaveAs                   , "SaveAs"                   , I18N_NOOP2("@action", "Save As")                   , 0           , 0, KShortcut(), false },

You might want to use a proper distribution before filing bugs that contain !!!! in them

OTOH i seriously doubt there is any bug here (and if there is, it is due to Qt4 sucking in this regard, i'm sure with the QtProject they are waiting for your patches) and much more i doubt it's an Okular bug. What do you expect konqueror to do if you assing Ctrl+Shift+S to three different actions, read your mind?
Comment 5 Anders Lund 2011-11-21 00:21:11 UTC
Sure, being rude and patronizing towards me as well as the distribution I use is an execellent way of solving down problems. So pleasurable.

If you look at the screenshot, it should be obvious that those are set as standard.

It is set as standard, because I have set Ctrl + Shift + S as shortcut for "save as" in the systemsettings module for standard shortcuts. I assume we want to keep that configurability?

The bug is that you use "save as" twice in the same widget, so *you* force that problem on anyone wanting to have a shortcut for save as. Quite easy to fix, luckily.
Comment 6 Anders Lund 2011-11-21 06:31:49 UTC
Created attachment 65888 [details]
patch: don't abuse saveas standard action

Here is even a patch, untested though since i do not build kde here.
Comment 7 Albert Astals Cid 2011-11-21 22:32:31 UTC
Git commit 432b7376e8f9c8f1b77c6cb074ea828920167a81 by Albert Astals Cid.
Committed on 21/11/2011 at 23:31.
Pushed by aacid into branch 'KDE/4.7'.

Set the shortcut to false

Since we are going to use KStandardAction::saveAs again later for the "real" 'Save As...'.
This was working fine since there is no default shortcut for SaveAs but if the user sets one
in the global kde config then he gets duplicate shortcut problems
BUGS: 268551

M  +1    -0    part.cpp

http://commits.kde.org/okular/432b7376e8f9c8f1b77c6cb074ea828920167a81
Comment 8 Albert Astals Cid 2011-11-21 22:35:35 UTC
Git commit 395d7163f650654bb6424c098bd277a2848a67b8 by Albert Astals Cid.
Committed on 21/11/2011 at 23:34.
Pushed by aacid into branch 'master'.

Set an empty shortcut to Save copy as

Since we are going to use KStandardAction::saveAs again later for the "real" 'Save As...'.
This was working fine since there is no default shortcut for SaveAs but if the user sets one
in the global kde config then he gets duplicate shortcut problems
BUGS: 268551

M  +1    -0    part.cpp

http://commits.kde.org/okular/395d7163f650654bb6424c098bd277a2848a67b8