Bug 268533 - Dolphin crashed on inline rename after attempted drag
Summary: Dolphin crashed on inline rename after attempted drag
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords: reproducible
: 262675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-15 05:23 UTC by Gabe A
Modified: 2011-12-17 23:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments
New crash information added by DrKonqi (7.39 KB, text/plain)
2011-04-06 23:34 UTC, Vít Tuček
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabe A 2011-03-15 05:23:51 UTC
Application: dolphin (1.6.1)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-6-generic x86_64
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I had just copied some files from a zip to a deep folder on a mounted ntfs partition. Inline rename was enabled. Here's what I did:
1. Paste music file "01 - Mysong.mp3".
2. Highlight file and pressed F2.
3. Moved mouse to beginning of filename.
4. Attempted to select from M to 0.

Instead of performing the proper highlight, it attempted to drag the text within the filename, which became left-justified somehow, and/or drag the file itself. It breifly displayed a dialog about where I wanted to copy the file (while the inline rename was still active) and crashed shortly thereafter. 

I had 2 other tabs open; the first was the contents of a zip file from which I'd copied "01 - Mysong.mp3", the second was the ntfs folder into which I'd dragged the file, and the 3rd was an unrelated program files folder on the ntfs partition.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f96592ff780 (LWP 2173))]

Thread 4 (Thread 0x7f9645e2c700 (LWP 2176)):
#0  QTimerInfoList::repairTimersIfNeeded (this=0x190ccb0) at kernel/qeventdispatcher_unix.cpp:395
#1  0x00007f965506a1c6 in QTimerInfoList::timerWait (this=0x190ccb0, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#2  0x00007f9655068c2c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f9645e2bc4c) at kernel/qeventdispatcher_glib.cpp:136
#3  0x00007f9655068cd5 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#4  0x00007f9651382012 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#5  0x00007f9651382f0d in ?? () from /lib/libglib-2.0.so.0
#6  0x00007f96513835a9 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#7  0x00007f9655069446 in QEventDispatcherGlib::processEvents (this=0x1910180, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007f965503d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f965503dabc in QEventLoop::exec (this=0x7f9645e2bdd0, flags=...) at kernel/qeventloop.cpp:201
#10 0x00007f9654f54924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#11 0x00007f965501fc2f in QInotifyFileSystemWatcherEngine::run (this=0x18f0af0) at io/qfilesystemwatcher_inotify.cpp:248
#12 0x00007f9654f57175 in QThreadPrivate::start (arg=0x18f0af0) at thread/qthread_unix.cpp:320
#13 0x00007f965184ed7c in start_thread (arg=0x7f9645e2c700) at pthread_create.c:304
#14 0x00007f9658be9fdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9644bf5700 (LWP 2228)):
#0  0x00007f9658bdcebf in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9651383074 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f96513835a9 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f9655069446 in QEventDispatcherGlib::processEvents (this=0x1c11bd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f965503d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f965503dabc in QEventLoop::exec (this=0x7f9644bf4dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9654f54924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f965501fc2f in QInotifyFileSystemWatcherEngine::run (this=0x1c1b8f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9654f57175 in QThreadPrivate::start (arg=0x1c1b8f0) at thread/qthread_unix.cpp:320
#9  0x00007f965184ed7c in start_thread (arg=0x7f9644bf5700) at pthread_create.c:304
#10 0x00007f9658be9fdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f962a6d4700 (LWP 3545)):
#0  0x00007f9658bdcebf in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9653b5b32f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f9653b4d116 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f9653b4d749 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f9653b4d800 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f9653b5b2df in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f964ef38a88 in ?? () from /usr/lib/libpulsecommon-0.9.22.so
#7  0x00007f965184ed7c in start_thread (arg=0x7f962a6d4700) at pthread_create.c:304
#8  0x00007f9658be9fdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f96592ff780 (LWP 2173)):
[KCrash Handler]
#6  operator!= (this=<value optimized out>) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:75
#7  detach (this=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:75
#8  operator-> (this=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:78
#9  QTextCursor::removeSelectedText (this=<value optimized out>) at text/qtextcursor.cpp:1629
#10 0x00007f9655c3b224 in QTextControlPrivate::startDrag (this=0x2300fb0) at text/qtextcontrol.cpp:521
#11 0x00007f9655c42d98 in QTextControlPrivate::mouseMoveEvent (this=0x2300fb0, buttons=<value optimized out>, mousePos=...) at text/qtextcontrol.cpp:1612
#12 0x00007f9655c4547f in QTextControl::processEvent (this=<value optimized out>, e=0x7fffc3f23950, matrix=..., contextWidget=<value optimized out>) at text/qtextcontrol.cpp:933
#13 0x00007f9655c3b5e6 in QTextControl::processEvent (this=0x244e090, e=0x7fffc3f23950, coordinateOffset=..., contextWidget=0x1ecc7d0) at text/qtextcontrol.cpp:884
#14 0x00007f9655e6858b in sendControlEvent (this=0x246b760, e=0x7fffc3f23950) at widgets/qtextedit_p.h:99
#15 QTextEdit::mouseMoveEvent (this=0x246b760, e=0x7fffc3f23950) at widgets/qtextedit.cpp:1560
#16 0x00007f9655a4eccc in QWidget::event (this=0x246b760, event=0x7fffc3f23950) at kernel/qwidget.cpp:8244
#17 0x00007f9655dfea16 in QFrame::event (this=0x246b760, e=0x7fffc3f23950) at widgets/qframe.cpp:557
#18 0x00007f965503e627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1ecc7d0, event=0x7fffc3f23950) at kernel/qcoreapplication.cpp:846
#19 0x00007f96559fd9b1 in QApplicationPrivate::notify_helper (this=0x1836ad0, receiver=0x1ecc7d0, e=0x7fffc3f23950) at kernel/qapplication.cpp:4458
#20 0x00007f9655a02db3 in QApplication::notify (this=<value optimized out>, receiver=0x1ecc7d0, e=0x7fffc3f23950) at kernel/qapplication.cpp:4023
#21 0x00007f965671c866 in KApplication::notify (this=0x7fffc3f24610, receiver=0x1ecc7d0, event=0x7fffc3f23950) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f965503e49c in QCoreApplication::notifyInternal (this=0x7fffc3f24610, receiver=0x1ecc7d0, event=0x7fffc3f23950) at kernel/qcoreapplication.cpp:731
#23 0x00007f96559fea0d in sendEvent (receiver=0x1ecc7d0, event=0x7fffc3f23950, alienWidget=0x1ecc7d0, nativeWidget=0x222db40, buttonDown=0x7f96564de218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 QApplicationPrivate::sendMouseEvent (receiver=0x1ecc7d0, event=0x7fffc3f23950, alienWidget=0x1ecc7d0, nativeWidget=0x222db40, buttonDown=0x7f96564de218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#25 0x00007f9655a7e5e0 in QETWidget::translateMouseEvent (this=0x222db40, event=<value optimized out>) at kernel/qapplication_x11.cpp:4556
#26 0x00007f9655a7d02a in QApplication::x11ProcessEvent (this=0x7fffc3f24610, event=0x7fffc3f242a0) at kernel/qapplication_x11.cpp:3678
#27 0x00007f9655aa5152 in x11EventSourceDispatch (s=0x1835710, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#28 0x00007f9651382b3d in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#29 0x00007f9651383318 in ?? () from /lib/libglib-2.0.so.0
#30 0x00007f96513835a9 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#31 0x00007f96550693ef in QEventDispatcherGlib::processEvents (this=0x180adb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f9655aa4dee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f965503d882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f965503dabc in QEventLoop::exec (this=0x7fffc3f245a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f9655041ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#36 0x00007f9658eeb995 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#37 0x00007f9658b22eff in __libc_start_main (main=0x400730 <_start+256>, argc=3, ubp_av=0x7fffc3f24b38, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc3f24b28) at libc-start.c:226
#38 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 262675.

Possible duplicates by query: bug 262675.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-03-17 18:49:43 UTC
Thanks for the bug report! I think I've reproduced the bug by dragging some selected text slightly out of the "Rename Inline" box and dropping it there. My debug build crashes with the assert

ASSERT: "heartbeat != -1" in file kernel/qdnd_x11.cpp, line 1402

Pasting my backtrace below (I think the differences are due to debug vs no-debug build -> my build crashes earlier)

Thread 1 (Thread 0x7f12ead7f760 (LWP 7865)):
[KCrash Handler]
#6  0x00007f12e40a39e5 in raise () from /lib64/libc.so.6
#7  0x00007f12e40a4ee6 in abort () from /lib64/libc.so.6
#8  0x00007f12e5c0bdf0 in qt_message_output (msgType=QtFatalMsg, buf=0xe94318 "ASSERT: \"heartbeat != -1\" in file kernel/qdnd_x11.cpp, line 1402") at global/qglobal.cpp:2282
#9  0x00007f12e5c0bf6c in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f12e5db5c38 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fff8a3c1f90)
    at global/qglobal.cpp:2328
#10 0x00007f12e5c0c7da in qFatal (msg=0x7f12e5db5c38 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2511
#11 0x00007f12e5c0b9a3 in qt_assert (assertion=0x7f12e760c307 "heartbeat != -1", file=0x7f12e760c1f6 "kernel/qdnd_x11.cpp", line=1402) at global/qglobal.cpp:2027
#12 0x00007f12e6e70bee in QDragManager::cancel (this=0x7f5950, deleteSource=false) at kernel/qdnd_x11.cpp:1402
#13 0x00007f12e6dcd4db in QDrag::~QDrag (this=0xb5b1d0, __in_chrg=<value optimized out>) at kernel/qdrag.cpp:132
#14 0x00007f12e6dcd53a in QDrag::~QDrag (this=0xb5b1d0, __in_chrg=<value optimized out>) at kernel/qdrag.cpp:133
#15 0x00007f12e5d4fa48 in QObjectPrivate::deleteChildren (this=0xb1f600) at kernel/qobject.cpp:1955
#16 0x00007f12e6e0dcaf in QWidget::~QWidget (this=0x98ac60, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1644
#17 0x00007f12e6e0dede in QWidget::~QWidget (this=0x98ac60, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1664
#18 0x00007f12e5d4fa48 in QObjectPrivate::deleteChildren (this=0xe25140) at kernel/qobject.cpp:1955
#19 0x00007f12e6e0dcaf in QWidget::~QWidget (this=0xeb76e0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1644
#20 0x00007f12e72d5fd4 in QFrame::~QFrame (this=0xeb76e0, __in_chrg=<value optimized out>) at widgets/qframe.cpp:240
#21 0x00007f12e737fe96 in QAbstractScrollArea::~QAbstractScrollArea (this=0xeb76e0, __in_chrg=<value optimized out>) at widgets/qabstractscrollarea.cpp:521
#22 0x00007f12e7363110 in QTextEdit::~QTextEdit (this=0xeb76e0, __in_chrg=<value optimized out>) at widgets/qtextedit.cpp:646
#23 0x00007f12e80acc43 in KTextEdit::~KTextEdit (this=0xeb76e0, __in_chrg=<value optimized out>) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/widgets/ktextedit.cpp:276
#24 0x00007f12e80accc6 in KTextEdit::~KTextEdit (this=0xeb76e0, __in_chrg=<value optimized out>) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/widgets/ktextedit.cpp:279
#25 0x00007f12e5d544fa in qDeleteInEventHandler (o=0xeb76e0) at kernel/qobject.cpp:3986
#26 0x00007f12e5d4e673 in QObject::event (this=0xeb76e0, e=0xd6f690) at kernel/qobject.cpp:1200
#27 0x00007f12e6e21101 in QWidget::event (this=0xeb76e0, event=0xd6f690) at kernel/qwidget.cpp:8731
#28 0x00007f12e72d6b9b in QFrame::event (this=0xeb76e0, e=0xd6f690) at widgets/qframe.cpp:557
#29 0x00007f12e7381085 in QAbstractScrollArea::event (this=0xeb76e0, e=0xd6f690) at widgets/qabstractscrollarea.cpp:996
#30 0x00007f12e7364103 in QTextEdit::event (this=0xeb76e0, e=0xd6f690) at widgets/qtextedit.cpp:1070
#31 0x00007f12e80ad2b9 in KTextEdit::event (this=0xeb76e0, ev=0xd6f690) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/widgets/ktextedit.cpp:329
#32 0x00007f12e6db905a in QApplicationPrivate::notify_helper (this=0x63b2a0, receiver=0xeb76e0, e=0xd6f690) at kernel/qapplication.cpp:4462
#33 0x00007f12e6db8d5a in QApplication::notify (this=0x7fff8a3c91d0, receiver=0xeb76e0, e=0xd6f690) at kernel/qapplication.cpp:4427
#34 0x00007f12e7eb3ec2 in KApplication::notify (this=0x7fff8a3c91d0, receiver=0xeb76e0, event=0xd6f690) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#35 0x00007f12e5d35b9b in QCoreApplication::notifyInternal (this=0x7fff8a3c91d0, receiver=0xeb76e0, event=0xd6f690) at kernel/qcoreapplication.cpp:787
#36 0x00007f12e6da9ae3 in QCoreApplication::sendEvent (receiver=0xeb76e0, event=0xd6f690) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#37 0x00007f12e5d36dd4 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x611b10) at kernel/qcoreapplication.cpp:1428
#38 0x00007f12e5d369f5 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#39 0x00007f12e6e85bbd in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#40 0x00007f12e5d6e5cc in postEventSourceDispatch (s=0x639140) at kernel/qeventdispatcher_glib.cpp:277
#41 0x00007f12e0cf2a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f12e0cf3270 in ?? () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f12e0cf3510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f12e5d6eebb in QEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#45 0x00007f12e6e91eee in QGuiEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007f12e5d336fe in QEventLoop::processEvents (this=0x7fff8a3c35d0, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007f12e5d33852 in QEventLoop::exec (this=0x7fff8a3c35d0, flags=...) at kernel/qeventloop.cpp:201
#48 0x00007f12e73cd7b8 in QDialog::exec (this=0x7fff8a3c3690) at dialogs/qdialog.cpp:552
#49 0x00007f12e7d6bca3 in KInputDialog::getText (caption=..., label=..., value=..., ok=0x7fff8a3c382f, parent=0xae4870, validator=0x0, mask=..., whatsThis=..., completionList=...)
    at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/dialogs/kinputdialog.cpp:346
#50 0x00007f12e94fe483 in getNewFileName (u=..., text=..., suggestedFileName=..., widget=0xae4870) at /home/kde-devel/kde/src/KDE/kdelibs/kio/kio/paste.cpp:49
#51 0x00007f12e95001f0 in KIO::pasteMimeSource (mimeData=0x90e9e0, destUrl=..., dialogText=..., widget=0xae4870, clipboard=false) at /home/kde-devel/kde/src/KDE/kdelibs/kio/kio/paste.cpp:222
#52 0x00007f12ea08d103 in KonqOperations::doDrop (destItem=..., dest=..., ev=0x7fff8a3c5260, parent=0xae4870, userActions=...)
    at /home/kde-devel/kde/src/KDE/kde-baseapps/lib/konq/konq_operations.cpp:333
#53 0x00007f12ea08c0a5 in KonqOperations::doDrop (destItem=..., dest=..., ev=0x7fff8a3c5260, parent=0xae4870) at /home/kde-devel/kde/src/KDE/kde-baseapps/lib/konq/konq_operations.cpp:263
#54 0x00007f12ea36fdaf in DragAndDropHelper::dropUrls (this=0xa9b7c0, destItem=..., destPath=..., event=0x7fff8a3c5260, widget=0xae4870)
    at /home/kde-devel/kde/src/KDE/kde-baseapps/dolphin/src/views/draganddrophelper.cpp:112
#55 0x00007f12ea3271ca in DolphinView::dropUrls (this=0xae4870, destItem=..., destPath=..., event=0x7fff8a3c5260) at /home/kde-devel/kde/src/KDE/kde-baseapps/dolphin/src/views/dolphinview.cpp:840
#56 0x00007f12ea32ee13 in DolphinView::qt_metacall (this=0xae4870, _c=QMetaObject::InvokeMetaMethod, _id=45, _a=0x7fff8a3c41b0)
    at /home/kde-devel/kde/build/KDE/kde-baseapps/dolphin/src/dolphinview.moc:231
#57 0x00007f12e5d3dd0f in QMetaObject::metacall (object=0xae4870, cl=QMetaObject::InvokeMetaMethod, idx=72, argv=0x7fff8a3c41b0) at kernel/qmetaobject.cpp:237
#58 0x00007f12e5d52deb in QMetaObject::activate (sender=0xb0c370, m=0x7f12ea5d0760, local_signal_index=3, argv=0x7fff8a3c41b0) at kernel/qobject.cpp:3278
#59 0x00007f12ea36e07f in DolphinViewController::urlsDropped (this=0xb0c370, _t1=..., _t2=..., _t3=0x7fff8a3c5260)
    at /home/kde-devel/kde/build/KDE/kde-baseapps/dolphin/src/dolphinviewcontroller.moc:161
#60 0x00007f12ea36c023 in DolphinViewController::indicateDroppedUrls (this=0xb0c370, destItem=..., event=0x7fff8a3c5260)
    at /home/kde-devel/kde/src/KDE/kde-baseapps/dolphin/src/views/dolphinviewcontroller.cpp:89
#61 0x00007f12ea338bdb in DolphinDetailsView::dropEvent (this=0x10003d0, event=0x7fff8a3c5260) at /home/kde-devel/kde/src/KDE/kde-baseapps/dolphin/src/views/dolphindetailsview.cpp:240
#62 0x00007f12e6e20549 in QWidget::event (this=0x10003d0, event=0x7fff8a3c5260) at kernel/qwidget.cpp:8462
#63 0x00007f12e72d6b9b in QFrame::event (this=0x10003d0, e=0x7fff8a3c5260) at widgets/qframe.cpp:557
#64 0x00007f12e7381149 in QAbstractScrollArea::viewportEvent (this=0x10003d0, e=0x7fff8a3c5260) at widgets/qabstractscrollarea.cpp:1043
#65 0x00007f12e7434896 in QAbstractItemView::viewportEvent (this=0x10003d0, event=0x7fff8a3c5260) at itemviews/qabstractitemview.cpp:1628
#66 0x00007f12e747fa97 in QTreeView::viewportEvent (this=0x10003d0, event=0x7fff8a3c5260) at itemviews/qtreeview.cpp:1256
#67 0x00007f12e7381dc3 in QAbstractScrollAreaPrivate::viewportEvent (this=0xf0a5a0, event=0x7fff8a3c5260) at widgets/qabstractscrollarea_p.h:100
#68 0x00007f12e7381ebc in QAbstractScrollAreaFilter::eventFilter (this=0xe6e080, o=0x631ac0, e=0x7fff8a3c5260) at widgets/qabstractscrollarea_p.h:116
#69 0x00007f12e5d35ead in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x63b2a0, receiver=0x631ac0, event=0x7fff8a3c5260) at kernel/qcoreapplication.cpp:902
#70 0x00007f12e6db9031 in QApplicationPrivate::notify_helper (this=0x63b2a0, receiver=0x631ac0, e=0x7fff8a3c5260) at kernel/qapplication.cpp:4458
#71 0x00007f12e6db804c in QApplication::notify (this=0x7fff8a3c91d0, receiver=0x631ac0, e=0x7fff8a3c5260) at kernel/qapplication.cpp:4266
#72 0x00007f12e7eb3ec2 in KApplication::notify (this=0x7fff8a3c91d0, receiver=0x631ac0, event=0x7fff8a3c5260) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#73 0x00007f12e5d35b9b in QCoreApplication::notifyInternal (this=0x7fff8a3c91d0, receiver=0x631ac0, event=0x7fff8a3c5260) at kernel/qcoreapplication.cpp:787
#74 0x00007f12e6da9ae3 in QCoreApplication::sendEvent (receiver=0x631ac0, event=0x7fff8a3c5260) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#75 0x00007f12e6e7023e in QX11Data::xdndHandleDrop (this=0x63fc60, xe=0x7fff8a3c53b0, passive=false) at kernel/qdnd_x11.cpp:1183
#76 0x00007f12e6e71edb in QDragManager::drop (this=0x7f5950) at kernel/qdnd_x11.cpp:1725
#77 0x00007f12e6e70861 in QDragManager::eventFilter (this=0x7f5950, o=0xe6f3f0, e=0x7fff8a3c5d80) at kernel/qdnd_x11.cpp:1312
#78 0x00007f12e5d35db1 in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x63b2a0, receiver=0xe6f3f0, event=0x7fff8a3c5d80) at kernel/qcoreapplication.cpp:883
#79 0x00007f12e6db8f0a in QApplicationPrivate::notify_helper (this=0x63b2a0, receiver=0xe6f3f0, e=0x7fff8a3c5d80) at kernel/qapplication.cpp:4437
#80 0x00007f12e6db6fe7 in QApplication::notify (this=0x7fff8a3c91d0, receiver=0xe6f3f0, e=0x7fff8a3c5d80) at kernel/qapplication.cpp:4023
#81 0x00007f12e7eb3ec2 in KApplication::notify (this=0x7fff8a3c91d0, receiver=0xe6f3f0, event=0x7fff8a3c5d80) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#82 0x00007f12e5d35b9b in QCoreApplication::notifyInternal (this=0x7fff8a3c91d0, receiver=0xe6f3f0, event=0x7fff8a3c5d80) at kernel/qcoreapplication.cpp:787
#83 0x00007f12e6dbb83d in QCoreApplication::sendSpontaneousEvent (receiver=0xe6f3f0, event=0x7fff8a3c5d80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#84 0x00007f12e6db5550 in QApplicationPrivate::sendMouseEvent (receiver=0xe6f3f0, event=0x7fff8a3c5d80, alienWidget=0x0, nativeWidget=0xe6f3f0, buttonDown=0x7f12e7b39f28, lastMouseReceiver=..., 
    spontaneous=true) at kernel/qapplication.cpp:3120
#85 0x00007f12e6e5af76 in QETWidget::translateMouseEvent (this=0xe6f3f0, event=0x7fff8a3c68e0) at kernel/qapplication_x11.cpp:4461
#86 0x00007f12e6e57905 in QApplication::x11ProcessEvent (this=0x7fff8a3c91d0, event=0x7fff8a3c68e0) at kernel/qapplication_x11.cpp:3465
#87 0x00007f12e6e91b40 in x11EventSourceDispatch (s=0x639e60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#88 0x00007f12e0cf2a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#89 0x00007f12e0cf3270 in ?? () from /usr/lib64/libglib-2.0.so.0
#90 0x00007f12e0cf3510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#91 0x00007f12e5d6eebb in QEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#92 0x00007f12e6e91eee in QGuiEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#93 0x00007f12e5d336fe in QEventLoop::processEvents (this=0xeacd90, flags=...) at kernel/qeventloop.cpp:149
#94 0x00007f12e5d33852 in QEventLoop::exec (this=0xeacd90, flags=...) at kernel/qeventloop.cpp:201
#95 0x00007f12e6e72fc1 in QDragManager::drag (this=0x7f5950, o=0xb5b1d0) at kernel/qdnd_x11.cpp:1981
#96 0x00007f12e6dcd8e1 in QDrag::exec (this=0xb5b1d0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#97 0x00007f12e708e485 in QTextControlPrivate::startDrag (this=0xeaa610) at text/qtextcontrol.cpp:517
#98 0x00007f12e7093b3c in QTextControlPrivate::mouseMoveEvent (this=0xeaa610, e=0x7fff8a3c8230, button=Qt::NoButton, mousePos=..., modifiers=..., buttons=..., globalPos=...)
    at text/qtextcontrol.cpp:1623
#99 0x00007f12e70901f6 in QTextControl::processEvent (this=0x87a7a0, e=0x7fff8a3c8230, matrix=..., contextWidget=0x98ac60) at text/qtextcontrol.cpp:936
#100 0x00007f12e708ff18 in QTextControl::processEvent (this=0x87a7a0, e=0x7fff8a3c8230, coordinateOffset=..., contextWidget=0x98ac60) at text/qtextcontrol.cpp:886
#101 0x00007f12e7368e6b in QTextEditPrivate::sendControlEvent (this=0xe25140, e=0x7fff8a3c8230) at widgets/qtextedit_p.h:99
#102 0x00007f12e7365884 in QTextEdit::mouseMoveEvent (this=0xeb76e0, e=0x7fff8a3c8230) at widgets/qtextedit.cpp:1560
#103 0x00007f12e6e1fb5c in QWidget::event (this=0xeb76e0, event=0x7fff8a3c8230) at kernel/qwidget.cpp:8257
#104 0x00007f12e72d6b9b in QFrame::event (this=0xeb76e0, e=0x7fff8a3c8230) at widgets/qframe.cpp:557
#105 0x00007f12e7381149 in QAbstractScrollArea::viewportEvent (this=0xeb76e0, e=0x7fff8a3c8230) at widgets/qabstractscrollarea.cpp:1043
#106 0x00007f12e7381dc3 in QAbstractScrollAreaPrivate::viewportEvent (this=0xe25140, event=0x7fff8a3c8230) at widgets/qabstractscrollarea_p.h:100
#107 0x00007f12e7381ebc in QAbstractScrollAreaFilter::eventFilter (this=0x915d80, o=0x98ac60, e=0x7fff8a3c8230) at widgets/qabstractscrollarea_p.h:116
#108 0x00007f12e5d35ead in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x63b2a0, receiver=0x98ac60, event=0x7fff8a3c8230) at kernel/qcoreapplication.cpp:902
#109 0x00007f12e6db9031 in QApplicationPrivate::notify_helper (this=0x63b2a0, receiver=0x98ac60, e=0x7fff8a3c8230) at kernel/qapplication.cpp:4458
#110 0x00007f12e6db6fe7 in QApplication::notify (this=0x7fff8a3c91d0, receiver=0x98ac60, e=0x7fff8a3c8230) at kernel/qapplication.cpp:4023
#111 0x00007f12e7eb3ec2 in KApplication::notify (this=0x7fff8a3c91d0, receiver=0x98ac60, event=0x7fff8a3c8230) at /home/kde-devel/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#112 0x00007f12e5d35b9b in QCoreApplication::notifyInternal (this=0x7fff8a3c91d0, receiver=0x98ac60, event=0x7fff8a3c8230) at kernel/qcoreapplication.cpp:787
#113 0x00007f12e6dbb83d in QCoreApplication::sendSpontaneousEvent (receiver=0x98ac60, event=0x7fff8a3c8230) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#114 0x00007f12e6db5550 in QApplicationPrivate::sendMouseEvent (receiver=0x98ac60, event=0x7fff8a3c8230, alienWidget=0x98ac60, nativeWidget=0x10003d0, buttonDown=0x7f12e7b39f28, lastMouseReceiver=
    ..., spontaneous=true) at kernel/qapplication.cpp:3120
#115 0x00007f12e6e5af76 in QETWidget::translateMouseEvent (this=0x10003d0, event=0x7fff8a3c8d90) at kernel/qapplication_x11.cpp:4461
#116 0x00007f12e6e57905 in QApplication::x11ProcessEvent (this=0x7fff8a3c91d0, event=0x7fff8a3c8d90) at kernel/qapplication_x11.cpp:3465
#117 0x00007f12e6e91b40 in x11EventSourceDispatch (s=0x639e60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#118 0x00007f12e0cf2a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#119 0x00007f12e0cf3270 in ?? () from /usr/lib64/libglib-2.0.so.0
#120 0x00007f12e0cf3510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#121 0x00007f12e5d6eebb in QEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#122 0x00007f12e6e91eee in QGuiEventDispatcherGlib::processEvents (this=0x611740, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#123 0x00007f12e5d336fe in QEventLoop::processEvents (this=0x7fff8a3c9140, flags=...) at kernel/qeventloop.cpp:149
#124 0x00007f12e5d33852 in QEventLoop::exec (this=0x7fff8a3c9140, flags=...) at kernel/qeventloop.cpp:201
#125 0x00007f12e5d3628e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#126 0x00007f12e6db61f6 in QApplication::exec () at kernel/qapplication.cpp:3736
#127 0x00007f12ea8f3a22 in kdemain (argc=1, argv=0x7fff8a3c9708) at /home/kde-devel/kde/src/KDE/kde-baseapps/dolphin/src/main.cpp:98
#128 0x000000000040119c in main (argc=1, argv=0x7fff8a3c9708) at /home/kde-devel/kde/build/KDE/kde-baseapps/dolphin/src/dolphin_dummy.cpp:3
Comment 2 Frank Reininghaus 2011-03-17 18:50:21 UTC
*** Bug 262675 has been marked as a duplicate of this bug. ***
Comment 3 Vít Tuček 2011-04-06 23:34:33 UTC
Created attachment 58655 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

I was attempting an inline rename of a file. 

My steps:

1. Right click -> Rename file 
2. I didn't notice that the text is already selected andI clicked and drag mouse in an attempt to higlight a part of file name which I wanted to delete.
3. Dialog appeared: File name for dropped content (doesn't crash even after waiting for several seconds)
4. Clicking on cancel or closing the dialog via titlebar button makes Dolphin crash.

-- Backtrace (Reduced):
#6  operator!= (this=0x14d4000) at ../../src/corelib/thread/qbasicatomic.h:75
#7  detach (this=0x14d4000) at ../../src/corelib/tools/qshareddata.h:75
#8  operator-> (this=0x14d4000) at ../../src/corelib/tools/qshareddata.h:78
#9  QTextCursor::removeSelectedText (this=0x14d4000) at text/qtextcursor.cpp:1626
#10 0x00007f68b90953d4 in QTextControlPrivate::startDrag (this=0x14d3f60) at text/qtextcontrol.cpp:521