Bug 268395 - kwin cannot manage separate X screens
Summary: kwin cannot manage separate X screens
Status: RESOLVED DUPLICATE of bug 256242
Alias: None
Product: kwin
Classification: Plasma
Component: multi-screen (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-13 18:37 UTC by Tom Kijas
Modified: 2011-03-13 19:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Kijas 2011-03-13 18:37:54 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

Hi, i have two monitors, one built-in LCD in laptop and second-one is bug LCD in HDMI port.
I also use NVIDIA GT240m with latest drivers.
I want to use them as separately X-Screens, without xinerama.
With xinerama, composition doesn't work so I don't want it.
The point is, that without xinerama, I can control both screens, but in my bigger monitor composition is disabled and any widgets (like lancelot etc.), situated in the bigger screen opens on the built-in smaller monitor, instead of the bigger-one. I have panels on both screens and lancelot widget is also on both of them.

If I use xinerama, both screens have properly working widgets etc. but without composition.

If I use twinview, I cannot play any wine games :). So this is also not an option for me.

My question: How to make separate x screens work like in GNOME (without xinerama), I mean, if I open menu in bigger-one screen, this menu should opens in the bigger one screen.... not in smaller one :)

Reproducible: Always

Steps to Reproduce:
Open screen settings dialog, set-up two monitors as separates x-screens without xinerama, save to xorg.conf, restart X, login.

Actual Results:  
Smaller, built-in screen works properly, working widgets, working composition.
Bigger, HDMI screen has these problems:
I have panels on both, lancelot widgets on both.
If I click on lancelot in the bigger-one screen, it opens in the smaller-one screen. Why?

If I click Alt+F2, to run krunner, it appears again in smaller screen, not in the bigger one.

Expected Results:  
To work as in GNOME. There it is working properly, menus clicked in bigger screen opens in the bigger screen, also composition works on both screens without problems.

Thank you in advance.
P.S. Please, contact me if I should add any other information.
Comment 1 Martin Flöser 2011-03-13 19:03:17 UTC

*** This bug has been marked as a duplicate of bug 256242 ***