Bug 268198 - experiment/shape brush is shaky
Summary: experiment/shape brush is shaky
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Brush engines (show other bugs)
Version: git master (please specify the git hash!)
Platform: Unlisted Binaries Linux
: NOR normal
Target Milestone: ---
Assignee: LukasT
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-11 11:09 UTC by animtim
Modified: 2011-12-31 16:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description animtim 2011-03-11 11:09:38 UTC
Version:           svn trunk (using KDE 4.4.5) 
OS:                Linux

when drawing with experimental/shape brush, if you look very close, you'll see the shape is shaking a little while drawing it (it shakes between 2 pixels, or something like that)

Reproducible: Always
Comment 1 Halla Rempt 2011-03-26 12:37:15 UTC
Lukas, didn't you already fix this?
Comment 2 LukasT 2011-03-26 13:46:04 UTC
Nope.
Comment 3 LukasT 2011-12-30 12:31:19 UTC
Git commit 361d9134a9401716f4db02bbc10754ade689b86d by Lukáš Tvrdý.
Committed on 30/12/2011 at 13:28.
Pushed by lukast into branch 'master'.

Fix shaking of the experiment/shape brush

The problem was float coordinates and rounding.

M  +1    -2    krita/plugins/paintops/experiment/kis_fixed_painter.cpp

http://commits.kde.org/calligra/361d9134a9401716f4db02bbc10754ade689b86d
Comment 4 animtim 2011-12-30 13:06:01 UTC
Here it still shakes a little while drawing.
Maybe it shakes a little less (I'm not sure), but it still is :/ .
Comment 5 LukasT 2011-12-31 11:49:53 UTC
It used to shake for me when I was changing the position of the stroke's top-left corner.

How do you reproduce it?
Comment 6 animtim 2011-12-31 12:25:55 UTC
To reproduce I used to draw random circles (counterclockwise).
So now after your comment about top/left I notice indeed it shakes only if
the strokes goes to the top and/or the left.
Comment 7 animtim 2011-12-31 16:54:00 UTC
Ok I had an update issue, now it doesn't shake anymore indeed.
Bug fixed! :.)