Bug 268145 - Add support for torrents with broken announce-list field
Summary: Add support for torrents with broken announce-list field
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 300239 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-10 17:34 UTC by karaluh
Modified: 2012-05-25 16:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test case (5.37 KB, application/x-bittorrent)
2011-03-10 17:34 UTC, karaluh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karaluh 2011-03-10 17:34:10 UTC
Created attachment 57835 [details]
Test case

Version:           unspecified
OS:                Linux

As in summary. Currently ktorrent says the file is invalid. I could attach such .torrent file, but 

Reproducible: Didn't try




OS: Linux (i686) release 2.6.35-28-generic
Compiler: cc
Comment 1 Joris Guisson 2011-03-11 20:09:24 UTC
These torrents are invalid they do not have a proper announce-list field.
Comment 2 Joris Guisson 2011-03-11 20:10:11 UTC
Git commit 18bf0e06f0809aeb1b290387ac64f7043f35ec42 by Joris.
Committed on 11/03/2011 at 20:09.
Pushed by guisson into branch 'master'.

Be more lenient towards torrents with wrong announce-list field

BUG: 268145

M  +1    -0    ChangeLog     
M  +8    -8    src/torrent/torrent.cpp     

http://commits.kde.org/libktorrent/18bf0e06f0809aeb1b290387ac64f7043f35ec42
Comment 3 Joris Guisson 2011-03-11 20:11:02 UTC
Git commit 3a0138f9573d4edd2d9715d0a68a557b6df6bdff by Joris.
Committed on 11/03/2011 at 20:09.
Pushed by guisson into branch '1.1'.

Be more lenient towards torrents with wrong announce-list field

CCBUG: 268145

M  +1    -0    ChangeLog     
M  +8    -8    src/torrent/torrent.cpp     

http://commits.kde.org/libktorrent/3a0138f9573d4edd2d9715d0a68a557b6df6bdff
Comment 4 Joris Guisson 2012-05-25 16:43:22 UTC
*** Bug 300239 has been marked as a duplicate of this bug. ***